7

Looking at the Cisco documentation for HSRP IPv6 configuration I noticed the use of 'standby 1 ipv6 autoconfig'.

interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
 ipv6 address 2020:AB8:2001::1011/64
 ipv6 enable
 standby version 2
 standby 1 ipv6 autoconfig
 standby 1 preempt delay minimum 30
 standby 1 track Serial0/0

On my setup I decided to utilize a manually configured IPv6 address for the virtual IP. Is there a reason why I should not use a static virtual address in preference of a autoconfig?

 interface GigabitEthernet0/2
  no ip address
  standby version 2
  standby 1 ipv6 2001:DB8:1:23::1/64
  standby 1 priority 110
  standby 1 preempt delay minimum 10
  duplex auto
  speed auto
  media-type rj45
  ipv6 address 2001:DB8:1:23::2/64
  ipv6 ospf 1 area 23
 end


interface GigabitEthernet0/2
  no ip address
  standby version 2
  standby 1 ipv6 2001:DB8:1:23::1/64
  duplex auto
  speed auto
  media-type rj45
  ipv6 address 2001:DB8:1:23::3/64
  ipv6 ospf 1 area 23
end   
4
  • 1
    If you are using IPv6 Prefix delegation, you may not know the prefix, and the autoconfig can use whatever prefix is assigned to the interface. Also, with IPv6, you can use the zero address. The network zero address is the Router Anycast address.
    – Ron Maupin
    Nov 21, 2018 at 0:48
  • So is my configuration in correct?
    – dcrearer
    Nov 21, 2018 at 0:49
  • 2
    I do not see anything wrong with what you have, but if you are using IPv6 Prefix Delegation, then you may want to use the autoconfig.
    – Ron Maupin
    Nov 21, 2018 at 0:53
  • Also, remember that IPv6 uses the link-local address of a router so that multiple networks assigned to hosts all use the same address for the gateway. If you look closely at the Cisco documentation, you see the standby address is a link-local address: "standby [group-number] ipv6 {link-local-address | autoconfig}"
    – Ron Maupin
    Aug 24 at 13:06

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Browse other questions tagged or ask your own question.