1

I do an inter-vlan L3 switch lab on Eve-ng emulator. The topology like below

enter image description here

And this is output from some show command at the L3 switch:

Building configuration...

Current configuration : 1422 bytes
!
! Last configuration change at 09:42:06 EET Thu Nov 29 2018
!
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
service compress-config
!
hostname Switch
!
boot-start-marker
boot-end-marker
!
!
no logging console
!
no aaa new-model
clock timezone EET 2 0
!
ip routing
!
ip dhcp excluded-address 192.168.20.1 192.168.20.10
ip dhcp excluded-address 192.168.10.1 192.168.10.10
!
ip dhcp pool OfficePool
 network 192.168.10.0 255.255.255.0
 default-router 192.168.10.2
 dns-server 8.8.8.8
!
ip dhcp pool FactoryPool
 network 192.168.20.0 255.255.255.0
 default-router 192.168.20.2
 dns-server 8.8.8.8
!
!
ip cef
no ipv6 cef
!
!
!
spanning-tree mode rapid-pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
interface Ethernet0/0
 switchport access vlan 10
 switchport mode access
!
interface Ethernet0/1
 switchport access vlan 20
 switchport mode access
!
interface Ethernet0/2
 switchport access vlan 100
 switchport mode access
!
interface Ethernet0/3
!
interface Vlan10
 ip address 192.168.10.2 255.255.255.0
!
interface Vlan20
 ip address 192.168.20.2 255.255.255.0
!
interface Vlan100
 ip address 192.168.100.2 255.255.255.0
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
!
control-plane
!
!
line con 0
 logging synchronous
line aux 0
line vty 0 4
!
!
end

Switch#sh ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override

Gateway of last resort is not set

      192.168.10.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.10.0/24 is directly connected, Vlan10
L        192.168.10.2/32 is directly connected, Vlan10
      192.168.20.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.20.0/24 is directly connected, Vlan20
L        192.168.20.2/32 is directly connected, Vlan20
      192.168.100.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.100.0/24 is directly connected, Vlan100
L        192.168.100.2/32 is directly connected, Vlan100


Switch#sh ip int brief
Interface              IP-Address      OK? Method Status                Protocol
Ethernet0/0            unassigned      YES unset  up                    up
Ethernet0/1            unassigned      YES unset  up                    up
Ethernet0/2            unassigned      YES unset  up                    up
Ethernet0/3            unassigned      YES unset  up                    up
Vlan10                 192.168.10.2    YES manual up                    up
Vlan20                 192.168.20.2    YES manual up                    up
Vlan100                192.168.100.2   YES manual up                    up

Let bypass from upper link of L3 switch to Net cloud part. On the Lan network, the PCs can get IP by DHCP, but I can't ping from Vlan10 to Vlan20 (or vice versa)

enter image description here

Try to trace from one vlan to other vlan, it seem L3 switch can't route between the two vlan.

enter image description here

Could you please point what I am doing wrong here, how to Vlan10 can ping to Vlan20.

Thanks for reading and pls help.

14
  • Can you ping between the vlan interfaces on the switch directly?
    – Elias
    Nov 29 '18 at 8:46
  • Ping to the interfaces Ip is OK. Nov 29 '18 at 9:02
  • To be clear: also from one vlan ip to another vlan ip on the switch? If you use extended ping?
    – Elias
    Nov 29 '18 at 9:10
  • The Pcs on Vlan10 can ping to Vlan20 gateway (192.168.20.2) and vice versa, Pcs on Vlan20 can ping to Vlan10 gateway (192.168.10.2). But Pcs (Vlan10/Vlan20) can't ping to Pcs (Vlan20/Vlan10). Phew, I don't know what wrong here. Nov 29 '18 at 9:13
  • And can PCs on Vlan10 ping other PCs on Vlan10? Just to see if icmp is allowed in their firewall :)
    – Elias
    Nov 29 '18 at 10:00
2

I can't add a screenshot to a comment so here is the results I've had with that topology.

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.