4

I am studying for my CCENT. I threw together a PAT practice lab. Other than DHCP and RIP everything is pretty stock. No VLANs No security Just NAT overload on ACCESS router. I am stumped why it isn't translating It will still ping all around. show ip nat statistics, miss count is going up. Debugging for NAT is on but silent. It all looks like it should be working.

Is there something wrong with my configuration?

enter image description here

ACCESS#sho ip nat translations 

ACCESS#sho ip nat stat
Total translations: 0 (0 static, 0 dynamic, 0 extended)
Outside Interfaces: GigabitEthernet0/1
Inside Interfaces: GigabitEthernet0/0
Hits: 0  Misses: 163
Expired translations: 0
Dynamic mappings:

ACCESS#show run
Building configuration...

Current configuration : 981 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname ACCESS
!
ip cef
no ipv6 cef
!
license udi pid CISCO2911/K9 sn FTX1524DSR5-
!
spanning-tree mode pvst
!
interface GigabitEthernet0/0
 ip address 10.0.0.1 255.255.255.0
 ip helper-address 8.8.8.2
 ip nat inside
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 ip address 8.8.8.1 255.255.255.252
 ip nat outside
 duplex auto
 speed auto
!
interface GigabitEthernet0/2
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Vlan1
 no ip address
 shutdown
!
router rip
 version 2
 passive-interface GigabitEthernet0/0
 network 8.0.0.0
 network 10.0.0.0
!
ip nat inside source list 1 interface GigabitEthernet0/1 overload
ip classless
!
ip flow-export version 9
!
access-list 1 permit host 10.0.0.0
!
no cdp run
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
end
  • You really need to give us all the router configurations, and we need to know specifically what doesn't seem to be working. Also, if you are trying to run a routing protocol through NAPT, you must understand that is not going to work. – Ron Maupin Dec 3 '18 at 14:22
5

Looks like the NAT access-list 1 is too tight. host 10.0.0.0 will only match the single host with address 10.0.0.0, and you have no such host.

You almost certainly wanted this:

access-list 1 permit 10.0.0.0 0.0.0.255

which will include your hosts at the bottom of your diagram.

  • The wildcard mask got me. I entered it as a subnet mask. so, was my other traffic going as normal and NAT was just waiting for host 10.0.0.0 to translate? – Reckless Liberty Dec 3 '18 at 11:49
  • Also, can you please tell me how you edited my code to be in it's original format? thanks again – Reckless Liberty Dec 3 '18 at 11:51
  • Re mask: I believe so. Re formatting: mark some text, click { } in little edit menu. For inline, use back-ticks. If you edit the question you'll see it. – jonathanjo Dec 3 '18 at 11:53
  • I can't edit, I'm too new., what's a backtick? – Reckless Liberty Dec 3 '18 at 11:55
  • The back-tick is also sometimes called left-single-quote or grave (which I can't type here) en.wikipedia.org/wiki/Grave_accent#Use_in_programming You don't type the braces, you click on the braces icon, which isn't obvious to me either. Or you can type four spaces at the front of each line (and blank lines above and below) a block to mark it like the configs. – jonathanjo Dec 3 '18 at 11:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.