3

We have a service provider switch which has an interface that we use to connect to other users over.

We have been advised by the SP that we can use this interface how we wish (i.e. feed it into a switch to allow more users to access).

I am trying to add a switch in, so I can do some testing, but any time I connect it, the SP switchport goes error disabled, and recovers about 2 mins later.

I have turned off everything I can think of CDP, STP etc... and also increased the priority of the switch so it doesn't try to get picked as root (I know, not best practice, but I'm trying to see what mechanism is putting the port into Err-dis).

The interface on the SP switch is set as an access port, I know I have VLAN in the pic, but this is the VLAN number on the trunk back to the router. The switch interface works fine with the end equipment (a IP gateway). Also when I plug a laptop straight into it. It is only when I attach the second switch it goes err-dis.

Any ideas? I think I'm up against some setting for BPDU's but what?

Switches are Cisco 2960's.

enter image description here

  • 1
    The likely explanation is BPDU guard. You can look in the switch log to see why it's going error-disabled status. – Ron Trunk Dec 4 '18 at 16:06
  • Can I not change my test switch, to not send BPDU's? – user10021657 Dec 4 '18 at 16:11
  • You would need to disable STP, and that would not be a good idea. – Ron Maupin Dec 4 '18 at 16:13
  • CDP, LLDP, etc. can also cause a port to err-disable when it sees a mismatch in port configuration (access vs. trunk, different PVID, etc.) You need to provide the err-disable reason. – Ricky Beam Dec 4 '18 at 18:42
  • Did any answer help you? If so, you should accept the answer so that the question doesn't keep popping up forever, looking for an answer. Alternatively, you can provide and accept your own answer. – Ron Maupin Dec 25 '18 at 10:11
3

The provider switch probably has portfast and bpduguard enabled for the switch interfaces. That will disable the switch interface if it sees any BPDUs enter the interface from another switch. That is a standard best practice.

Unless you have access to change the provider switch configuration, there is not much you can do about it but contact the provider for help, and the question would be off-topic as a network not under your direct control.

If you can modify the provider switch configuration, you can disable portfast and bpduguard for the switch interface.

  • Or turn off spanning-tree on the port connected to the ISP. It doesn't need to be part of your STP anyway. Yes, there's the possibility of a loop if that port is ever connected to anything else. There are locking connectors to reduce that risk. – Ricky Beam Dec 4 '18 at 18:41
  • I don't believe the 2960 can disable STP on a single interface, only by VLAN. – Ron Maupin Dec 4 '18 at 18:45
  • 1
    spanning-tree bpdufilter enable (Don't send or receive BPDUs on this interface) – Ricky Beam Dec 4 '18 at 20:01
  • spanning-tree bpdufilter enable works a treat, thanks for your help! Also thanks everyone for the background info, although it's non standard, it allows me to do my testing, and I'm working with the SP now on a permanent solution. – user10021657 Dec 5 '18 at 11:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.