2

I have the following topology (using IPv6) interfaces:

IPv6 Static Network Route

I have the following static routes configured on it:

R1#sh ipv6 route static
IPv6 Routing Table - default - 9 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP
       H - NHRP, I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea
       IS - ISIS summary, D - EIGRP, EX - EIGRP external, NM - NEMO
       ND - ND Default, NDp - ND Prefix, DCE - Destination, NDr - Redirect
       RL - RPL, O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1
       OE2 - OSPF ext 2, ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       la - LISP alt, lr - LISP site-registrations, ld - LISP dyn-eid
       lA - LISP away, a - Application
S   2004::/64 [1/0]
     via GigabitEthernet0/2, directly connected
S   2005::/64 [1/0]
     via 2003::2

I can ping 2005::2 just fine! The traceroute gives expected results too:

R1#traceroute 2005::1  
Type escape sequence to abort.
Tracing the route to 2005::1

  1 2003::2 12 msec 5 msec 4 msec

But when I try to ping 2004::2, configured using the command ipv6 route 2004::/64 Gi0/2, I get timed out:

R1#ping 2004::1      
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2004::1, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)

I know we're not supposed to have Ethernet interfaces configured as exit interfaces to prevent ARP table overflows and/or prevent performance issues, but I'm just trying to get a proof of concept/to learn and I don't have serial interfaces on my VIRL images.

Strangely enough, i can ping 2001::1 (R1) from R2 (2004::1):

R2#ping 2001::1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001::1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 3/4/7 ms
R2#traceroute 2001::1
Type escape sequence to abort.
Tracing the route to 2001::1

  1 2002::1 9 msec 8 msec 8 msec

So, what am I doing wrong?


Config Dump

Interfaces and routes on R1:

R1#sh ipv6 int br
GigabitEthernet0/0     [up/up]
    FE80::EC1:8FFF:FE5A:C100
    2001::1
GigabitEthernet0/1     [up/up]
    FE80::EC1:8FFF:FE5A:C101
    2003::1
GigabitEthernet0/2     [up/up]
    FE80::EC1:8FFF:FE5A:C102
    2002::1
GigabitEthernet0/3     [administratively down/down]
    unassigned
R1#sh ipv6 route 
IPv6 Routing Table - default - 9 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP
       H - NHRP, I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea
       IS - ISIS summary, D - EIGRP, EX - EIGRP external, NM - NEMO
       ND - ND Default, NDp - ND Prefix, DCE - Destination, NDr - Redirect
       RL - RPL, O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1
       OE2 - OSPF ext 2, ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       la - LISP alt, lr - LISP site-registrations, ld - LISP dyn-eid
       lA - LISP away, a - Application
C   2001::/64 [0/0]
     via GigabitEthernet0/0, directly connected
L   2001::1/128 [0/0]
     via GigabitEthernet0/0, receive
C   2002::/64 [0/0]
     via GigabitEthernet0/2, directly connected
L   2002::1/128 [0/0]
     via GigabitEthernet0/2, receive
C   2003::/64 [0/0]
     via GigabitEthernet0/1, directly connected
L   2003::1/128 [0/0]
     via GigabitEthernet0/1, receive
S   2004::/64 [1/0]
     via GigabitEthernet0/2, directly connected
S   2005::/64 [1/0]
     via 2003::2
L   FF00::/8 [0/0]
     via Null0, receive

R1#sh run
Building configuration...

Current configuration : 3268 bytes
!
! Last configuration change at 05:38:27 UTC Sun Dec 9 2018
!
version 15.6
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
ethernet lmi ce
!
!
!
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
!
!
!
!
!
no ip icmp rate-limit unreachable
!
!
!
!
!
!
no ip domain lookup
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!         
!
redundancy
!
no cdp log mismatch duplex
!
ip tcp synwait-time 5
! 
!
!
!
!
!
!
!
!
!
!
!
!
interface GigabitEthernet0/0
 no ip address
 duplex auto
 speed auto
 media-type rj45
 ipv6 address 2001::1/64
 ipv6 enable
!
interface GigabitEthernet0/1
 no ip address
 duplex auto
 speed auto
 media-type rj45
 ipv6 address 2003::1/64
!
interface GigabitEthernet0/2
 no ip address
 duplex auto
 speed auto
 media-type rj45
 ipv6 address 2002::1/64
!
interface GigabitEthernet0/3
 no ip address
 shutdown
 duplex auto
 speed auto
 media-type rj45
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
ipv6 route 2004::/64 GigabitEthernet0/2
ipv6 route 2005::/64 2003::2
!
!
!
control-plane
!
banner exec ^C
**************************************************************************
* IOSv is strictly limited to use for evaluation, demonstration and IOS  *
* education. IOSv is provided as-is and is not supported by Cisco's      *
* Technical Advisory Center. Any use or disclosure, in whole or in part, *
* of the IOSv Software or Documentation to any third party for any       *
* purposes is expressly prohibited except as otherwise authorized by     *
* Cisco in writing.                                                      *
**************************************************************************^C
banner incoming ^C
**************************************************************************
* IOSv is strictly limited to use for evaluation, demonstration and IOS  *
* education. IOSv is provided as-is and is not supported by Cisco's      *
* Technical Advisory Center. Any use or disclosure, in whole or in part, *
* of the IOSv Software or Documentation to any third party for any       *
* purposes is expressly prohibited except as otherwise authorized by     *
* Cisco in writing.                                                      *
**************************************************************************^C
banner login ^C
**************************************************************************
* IOSv is strictly limited to use for evaluation, demonstration and IOS  *
* education. IOSv is provided as-is and is not supported by Cisco's      *
* Technical Advisory Center. Any use or disclosure, in whole or in part, *
* of the IOSv Software or Documentation to any third party for any       *
* purposes is expressly prohibited except as otherwise authorized by     *
* Cisco in writing.                                                      *
**************************************************************************^C
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
 transport input none
!
no scheduler allocate
!
end

Interfaces and routes on R2:

R2#sh ipv6 int br
GigabitEthernet0/0     [up/up]
    FE80::EC1:8FFF:FEC5:C700
    2004::1
GigabitEthernet0/1     [up/up]
    FE80::EC1:8FFF:FEC5:C701
    2002::2
GigabitEthernet0/2     [administratively down/down]
    unassigned
GigabitEthernet0/3     [administratively down/down]
    unassigned
R2#sh ipv6 route 
IPv6 Routing Table - default - 6 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP
       H - NHRP, I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea
       IS - ISIS summary, D - EIGRP, EX - EIGRP external, NM - NEMO
       ND - ND Default, NDp - ND Prefix, DCE - Destination, NDr - Redirect
       RL - RPL, O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1
       OE2 - OSPF ext 2, ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       la - LISP alt, lr - LISP site-registrations, ld - LISP dyn-eid
       lA - LISP away, a - Application
S   2001::/64 [1/0]
     via 2002::1
C   2002::/64 [0/0]
     via GigabitEthernet0/1, directly connected
L   2002::2/128 [0/0]
     via GigabitEthernet0/1, receive
C   2004::/64 [0/0]
     via GigabitEthernet0/0, directly connected
L   2004::1/128 [0/0]
     via GigabitEthernet0/0, receive
L   FF00::/8 [0/0]
     via Null0, receive

R2#sh run            
Building configuration...

Current configuration : 3200 bytes
!
! Last configuration change at 04:25:49 UTC Sun Dec 9 2018
!
version 15.6
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
ethernet lmi ce
!
!
!
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
!
!
!
!
!
no ip icmp rate-limit unreachable
!
!
!
!
!
!
no ip domain lookup
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!         
!
redundancy
!
no cdp log mismatch duplex
!
ip tcp synwait-time 5
! 
!
!
!
!
!
!
!
!
!
!
!
!
interface GigabitEthernet0/0
 no ip address
 duplex auto
 speed auto
 media-type rj45
 ipv6 address 2004::1/64
!
interface GigabitEthernet0/1
 no ip address
 duplex auto
 speed auto
 media-type rj45
 ipv6 address 2002::2/64
!
interface GigabitEthernet0/2
 no ip address
 shutdown
 duplex auto
 speed auto
 media-type rj45
!
interface GigabitEthernet0/3
 no ip address
 shutdown
 duplex auto
 speed auto
 media-type rj45
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
ipv6 route 2001::/64 2002::1
!
!
!
control-plane
!
banner exec ^C
**************************************************************************
* IOSv is strictly limited to use for evaluation, demonstration and IOS  *
* education. IOSv is provided as-is and is not supported by Cisco's      *
* Technical Advisory Center. Any use or disclosure, in whole or in part, *
* of the IOSv Software or Documentation to any third party for any       *
* purposes is expressly prohibited except as otherwise authorized by     *
* Cisco in writing.                                                      *
**************************************************************************^C
banner incoming ^C
**************************************************************************
* IOSv is strictly limited to use for evaluation, demonstration and IOS  *
* education. IOSv is provided as-is and is not supported by Cisco's      *
* Technical Advisory Center. Any use or disclosure, in whole or in part, *
* of the IOSv Software or Documentation to any third party for any       *
* purposes is expressly prohibited except as otherwise authorized by     *
* Cisco in writing.                                                      *
**************************************************************************^C
banner login ^C
**************************************************************************
* IOSv is strictly limited to use for evaluation, demonstration and IOS  *
* education. IOSv is provided as-is and is not supported by Cisco's      *
* Technical Advisory Center. Any use or disclosure, in whole or in part, *
* of the IOSv Software or Documentation to any third party for any       *
* purposes is expressly prohibited except as otherwise authorized by     *
* Cisco in writing.                                                      *
**************************************************************************^C
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
 transport input none
!
no scheduler allocate
!
end

Router 3

R3#sh run
Building configuration...

Current configuration : 3200 bytes
!
! Last configuration change at 04:25:55 UTC Sun Dec 9 2018
!
version 15.6
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
ethernet lmi ce
!
!
!
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
!
!
!
!
!
no ip icmp rate-limit unreachable
!
!
!
!
!
!
no ip domain lookup
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!         
!
redundancy
!
no cdp log mismatch duplex
!
ip tcp synwait-time 5
! 
!
!
!
!
!
!
!
!
!
!
!
!
interface GigabitEthernet0/0
 no ip address
 duplex auto
 speed auto
 media-type rj45
 ipv6 address 2003::2/64
!
interface GigabitEthernet0/1
 no ip address
 duplex auto
 speed auto
 media-type rj45
 ipv6 address 2005::1/64
!
interface GigabitEthernet0/2
 no ip address
 shutdown
 duplex auto
 speed auto
 media-type rj45
!
interface GigabitEthernet0/3
 no ip address
 shutdown
 duplex auto
 speed auto
 media-type rj45
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
ipv6 route 2001::/64 2003::1
!
!
!
control-plane
!
banner exec ^C
**************************************************************************
* IOSv is strictly limited to use for evaluation, demonstration and IOS  *
* education. IOSv is provided as-is and is not supported by Cisco's      *
* Technical Advisory Center. Any use or disclosure, in whole or in part, *
* of the IOSv Software or Documentation to any third party for any       *
* purposes is expressly prohibited except as otherwise authorized by     *
* Cisco in writing.                                                      *
**************************************************************************^C
banner incoming ^C
**************************************************************************
* IOSv is strictly limited to use for evaluation, demonstration and IOS  *
* education. IOSv is provided as-is and is not supported by Cisco's      *
* Technical Advisory Center. Any use or disclosure, in whole or in part, *
* of the IOSv Software or Documentation to any third party for any       *
* purposes is expressly prohibited except as otherwise authorized by     *
* Cisco in writing.                                                      *
**************************************************************************^C
banner login ^C
**************************************************************************
* IOSv is strictly limited to use for evaluation, demonstration and IOS  *
* education. IOSv is provided as-is and is not supported by Cisco's      *
* Technical Advisory Center. Any use or disclosure, in whole or in part, *
* of the IOSv Software or Documentation to any third party for any       *
* purposes is expressly prohibited except as otherwise authorized by     *
* Cisco in writing.                                                      *
**************************************************************************^C
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
 transport input none
!
no scheduler allocate
!
end

Running Config Dump

  • You need to provide the network device configuraions. We cannot guess where you may have gone wrong. – Ron Maupin Dec 9 '18 at 5:58
  • What kind of configs are we talking about? Running config? – Somenath Sinha Dec 9 '18 at 5:59
  • Yes, from all the routers. – Ron Maupin Dec 9 '18 at 6:03
  • Also, all the routers' souting tables. – Ron Maupin Dec 9 '18 at 6:03
  • @RonMaupin Added. Please check. – Somenath Sinha Dec 9 '18 at 6:16
3

Remember that IPv6 doesn't use ARP. There is no broadcast on IPv6, and ARP uses broadcast. IPv6 uses ND, which uses multicast.

Notice the difference in the route configurations:

ipv6 route 2004::/64 GigabitEthernet0/2
ipv6 route 2005::/64 2003::2
!

You are not giving an actual next hop address for the network on the other side of R2. If you point the route to the interface, it should work:

ipv6 route 2004::/64 2002::2

-or-

ipv6 route 2004::/64 GigabitEthernet0/2 2002::2

Ethernet is a multiaccess network, not a point-to-point network type, so you really need to tell IPv6 what the next hop address is.


It may be interesting to try using a point-to-point network on the link between R1 and R2, e.g. 2002::/127 with addresses of 2002:: and 2002::1.

Also, you should not really use Global IPv6 addresses for testing. There are IPv6 ranges for such things, e.g. 2001:2::/48 or ULA addressing.

1

When pinging 2004::2 from the R1, the router needs to perform neighbor discovery in order to successfully perform L2 encapsulation. To accomplish this task the router is sending ICMPv6 Neighbor solicitation message to the solicited node multicast address ff02::1:ff00:2 (ff02::1:ff00:0/104 is used as prefix, and the last 24 bits are taken from the real destination which is in this case ::2), however since the 2004::2 is not present on the link between R1--R2 no one will respond, thus the encapsulation fails and the ping fails as well, that is why you need to specify next hop address as well. This scenario would work in IPv4 thanks to proxy ARP (if enabled on the incoming interface on R2).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.