2

I'm having trouble getting the output shown at 03:14 here: Frame Relay configuration by Kevin Wallace

Frame Relay Switch config

My Network is 3 routers, each connected to the frame relay switch via Serial2/0 interface, with nothing else. I am trying to make a hub-and-spoke topology with R1 as the hub and R2 and R3 as the spokes. The frame relay switch used is the default frame relay switch applicance in GNS3.

Update: Original problem solved. Need help with 2nd one:

Original problem was caused due to a misconfigured Frame relay switch. However, the Frame-relay LMI has been changed to ANSI on every router to match the Frame relay. Why is the frame-relay LMI-type still wrong? i.e., why is it CISCO instead of ANSI?

My 3 routers have the configuration:

R1#sh run | s Serial2/0
interface Serial2/0
 description Conn to FR
 ip address 10.1.1.1 255.255.255.0
 encapsulation frame-relay
 serial restart-delay 0
 frame-relay lmi-type ansi

R2(config)#do sh run | s Serial2/0
interface Serial2/0
 description Conn to R1
 ip address 10.1.1.2 255.255.255.0
 encapsulation frame-relay
 serial restart-delay 0
 frame-relay lmi-type ansi

R3#sh run | s Serial2/0
interface Serial2/0
 description Conn to R1
 ip address 10.1.1.3 255.255.255.0
 encapsulation frame-relay
 serial restart-delay 0
 frame-relay lmi-type ansi

As far as I can tell, I've configured the routers exactly the same way that Kevin has. However, when I use the show frame-relay pvc command, or the show frame-relay map command, I get only information about the first PVC/mapping:

R1#sh frame pvc

PVC Statistics for interface Serial2/0 (Frame Relay DTE)

              Active     Inactive      Deleted       Static
  Local          1            0            0            0
  Switched       0            0            0            0
  Unused         0            0            0            0

DLCI = 102, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial2/0

  input pkts 1             output pkts 1            in bytes 34        
  out bytes 34             dropped pkts 0           in pkts dropped 0         
  out pkts dropped 0                out bytes dropped 0         
  in FECN pkts 0           in BECN pkts 0           out FECN pkts 0         
  out BECN pkts 0          in DE pkts 0             out DE pkts 0         
  out bcast pkts 1         out bcast bytes 34        
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
  pvc create time 00:51:48, last time pvc status changed 00:51:48

R2#sh frame pvc     

PVC Statistics for interface Serial2/0 (Frame Relay DTE)

              Active     Inactive      Deleted       Static
  Local          2            0            0            0
  Switched       0            0            0            0
  Unused         0            0            0            0

DLCI = 103, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial2/0

  input pkts 5             output pkts 5            in bytes 170       
  out bytes 170            dropped pkts 0           in pkts dropped 0         
  out pkts dropped 0                out bytes dropped 0         
  in FECN pkts 0           in BECN pkts 0           out FECN pkts 0         
  out BECN pkts 0          in DE pkts 0             out DE pkts 0         
  out bcast pkts 5         out bcast bytes 170       
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
  pvc create time 00:52:39, last time pvc status changed 00:52:39

DLCI = 201, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial2/0

  input pkts 11            output pkts 10           in bytes 724       
  out bytes 690            dropped pkts 0           in pkts dropped 0         
  out pkts dropped 0                out bytes dropped 0         
  in FECN pkts 0           in BECN pkts 0           out FECN pkts 0         
  out BECN pkts 0          in DE pkts 0             out DE pkts 0         
  out bcast pkts 5         out bcast bytes 170       
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
  pvc create time 00:52:39, last time pvc status changed 00:52:39

R3#sh frame pvc

PVC Statistics for interface Serial2/0 (Frame Relay DTE)

              Active     Inactive      Deleted       Static
  Local          1            0            0            0
  Switched       0            0            0            0
  Unused         0            0            0            0

DLCI = 301, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial2/0

  input pkts 5             output pkts 2            in bytes 170       
  out bytes 68             dropped pkts 0           in pkts dropped 0         
  out pkts dropped 0                out bytes dropped 0         
  in FECN pkts 0           in BECN pkts 0           out FECN pkts 0         
  out BECN pkts 0          in DE pkts 0             out DE pkts 0         
  out bcast pkts 2         out bcast bytes 68        
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
  pvc create time 00:52:18, last time pvc status changed 00:52:18

In the output of the tutorial, R1 shows the PVCs 102 and 103, R2 shows 201 and R3 shows 301.

Further, in the case of frame-relay map:

R1#sh frame map
Serial2/0 (up): ip 10.1.1.2 dlci 102(0x66,0x1860), dynamic,
              broadcast,
              CISCO, status defined, active

R2#sh frame map
Serial2/0 (up): ip 10.1.1.3 dlci 103(0x67,0x1870), dynamic,
              broadcast,
              CISCO, status defined, active
Serial2/0 (up): ip 10.1.1.1 dlci 201(0xC9,0x3090), dynamic,
              broadcast,
              CISCO, status defined, active

R3#sh frame map
Serial2/0 (up): ip 10.1.1.2 dlci 301(0x12D,0x48D0), dynamic,
              broadcast,, status defined, active

Why is there a disparity between the results? I'm new to Frame relays, and hence don't know what I should be doing. Basically, what am I doing different from the tutorial?


Config Dump

R1:

R1#sh run
Building configuration...

Current configuration : 2055 bytes
!
! Last configuration change at 10:50:17 UTC Mon Dec 24 2018
!
version 15.5
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
!
!
!
bsd-client server url https://cloudsso.cisco.com/as/token.oauth2
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
!
!
!
!
!
no ip icmp rate-limit unreachable
!
!
!
!         
!
!
!
!


!
!
!
!
no ip domain lookup
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
cts logging verbose
!
!
!
redundancy
!
!
ip tcp synwait-time 5
! 
!
!
!
!         
!
!
!
!
!
!
!
!
interface Ethernet0/0
 no ip address
 shutdown
!
interface Ethernet0/1
 no ip address
 shutdown
!
interface Ethernet0/2
 no ip address
 shutdown
!
interface Ethernet0/3
 no ip address
 shutdown
!
interface Ethernet1/0
 no ip address
 shutdown
!
interface Ethernet1/1
 no ip address
 shutdown
!
interface Ethernet1/2
 no ip address
 shutdown 
!
interface Ethernet1/3
 no ip address
 shutdown
!
interface Serial2/0
 description Conn to FR
 ip address 10.1.1.1 255.255.255.0
 encapsulation frame-relay
 serial restart-delay 0
 frame-relay lmi-type ansi
!
interface Serial2/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/3
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial3/0
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial3/1
 no ip address
 shutdown 
 serial restart-delay 0
!
interface Serial3/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial3/3
 no ip address
 shutdown
 serial restart-delay 0
!
router ospf 1
 network 10.0.0.0 0.0.0.255 area 0
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
 transport input none
!
!
end

R2:

R2#sh run
Building configuration...

Current configuration : 2055 bytes
!
! Last configuration change at 10:59:24 UTC Mon Dec 24 2018
!
version 15.5
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
!
!
!
bsd-client server url https://cloudsso.cisco.com/as/token.oauth2
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
!
!
!
!
!
no ip icmp rate-limit unreachable
!
!
!
!         
!
!
!
!


!
!
!
!
no ip domain lookup
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
cts logging verbose
!
!
!
redundancy
!
!
ip tcp synwait-time 5
! 
!
!
!
!         
!
!
!
!
!
!
!
!
interface Ethernet0/0
 no ip address
 shutdown
!
interface Ethernet0/1
 no ip address
 shutdown
!
interface Ethernet0/2
 no ip address
 shutdown
!
interface Ethernet0/3
 no ip address
 shutdown
!
interface Ethernet1/0
 no ip address
 shutdown
!
interface Ethernet1/1
 no ip address
 shutdown
!
interface Ethernet1/2
 no ip address
 shutdown 
!
interface Ethernet1/3
 no ip address
 shutdown
!
interface Serial2/0
 description Conn to R1
 ip address 10.1.1.2 255.255.255.0
 encapsulation frame-relay
 serial restart-delay 0
 frame-relay lmi-type ansi
!
interface Serial2/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/3
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial3/0
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial3/1
 no ip address
 shutdown 
 serial restart-delay 0
!
interface Serial3/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial3/3
 no ip address
 shutdown
 serial restart-delay 0
!
router ospf 1
 network 10.0.0.0 0.0.0.255 area 0
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
 transport input none
!
!
end

R3:

R3#sh run
Building configuration...

Current configuration : 2055 bytes
!
! Last configuration change at 10:28:04 UTC Mon Dec 24 2018
!
version 15.5
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
!
!
!
bsd-client server url https://cloudsso.cisco.com/as/token.oauth2
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
!
!
!
!
!
no ip icmp rate-limit unreachable
!
!
!
!         
!
!
!
!


!
!
!
!
no ip domain lookup
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
cts logging verbose
!
!
!
redundancy
!
!
ip tcp synwait-time 5
! 
!
!
!
!         
!
!
!
!
!
!
!
!
interface Ethernet0/0
 no ip address
 shutdown
!
interface Ethernet0/1
 no ip address
 shutdown
!
interface Ethernet0/2
 no ip address
 shutdown
!
interface Ethernet0/3
 no ip address
 shutdown
!
interface Ethernet1/0
 no ip address
 shutdown
!
interface Ethernet1/1
 no ip address
 shutdown
!
interface Ethernet1/2
 no ip address
 shutdown 
!
interface Ethernet1/3
 no ip address
 shutdown
!
interface Serial2/0
 description Conn to R1
 ip address 10.1.1.3 255.255.255.0
 encapsulation frame-relay
 serial restart-delay 0
 frame-relay lmi-type ansi
!
interface Serial2/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/3
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial3/0
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial3/1
 no ip address
 shutdown 
 serial restart-delay 0
!
interface Serial3/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial3/3
 no ip address
 shutdown
 serial restart-delay 0
!
router ospf 1
 network 10.0.0.0 0.0.0.255 area 0
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
 transport input none
!
!
end

P.S. Each router is a IOU L3 appliance in GNS3 running I86BI_LINUX-ADVENTERPRISEK9-M), Version 15.5(2)T

  • Did any answer help you? If so, you should accept the answer so that the question doesn't keep popping up forever, looking for an answer. Alternatively, you can provide and accept your own answer. – Ron Maupin Dec 25 '18 at 10:28
2

Frame relay LMI is local to the link, which is between your router and the frame relay switch. Apparently, your frame relay switch is configured for frame-relay lmi-type cisco.

Cisco supports three different Local Management Interface (LMI) types for Frame Relay: Cisco, ANSI Annex D, and Q933-A Annex A. Beginning with Cisco IOS Software Release 11.2, the LMI autosense feature allows a Frame Relay interface to autodetect the LMI type supported by the directly connected Frame Relay switch. Based on the LMI status messages it receives from the Frame Relay switch, the router automatically configures its Frame Relay interface with the supported LMI type acknowledged by the Frame Relay switch.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.