2

Scenario is in old asa firewall 5505 I have switch port access vlan command in different interface. Just like below:

interface Ethernet0/0
!
interface Ethernet0/1
 switchport access vlan 2
!
interface Ethernet0/2
 switchport access vlan 2
!
interface Ethernet0/3
 switchport access vlan 2
!
interface Ethernet0/4
 switchport access vlan 2
!
interface Ethernet0/5
 switchport access vlan 2
!
interface Ethernet0/6
 switchport access vlan 2
!
interface Ethernet0/7
 switchport access vlan 2
!
interface Vlan1
 nameif Outside
 security-level 0
 ip address x.x.x.x 255.255.255.224 
!
interface Vlan2
 nameif Inside
 security-level 100
 ip address 172.16.0.1 255.255.0.0 

From above I can use different interface as same network of 172.16.0.1.

But in 5506 command is not supported. Is there any thing I can do for the same scenario I can run in 5506 asa.

Ref:

GigabitEthernet1/1         unassigned      YES manual administratively down down
GigabitEthernet1/2         unassigned      YES unset  administratively down down
GigabitEthernet1/3         unassigned      YES unset  administratively down down
GigabitEthernet1/4         unassigned      YES unset  administratively down down
GigabitEthernet1/5         unassigned      YES unset  administratively down down
GigabitEthernet1/6         unassigned      YES unset  administratively down down
GigabitEthernet1/7         unassigned      YES unset  administratively down down
GigabitEthernet1/8         unassigned      YES unset  administratively down down
Internal-Control1/1        127.0.1.1       YES unset  up                    up
Internal-Data1/1           unassigned      YES unset  down                  down
Internal-Data1/2           unassigned      YES unset  up                    up
Internal-Data1/3           unassigned      YES unset  up                    up
Internal-Data1/4           169.254.1.1     YES unset  up                    up
Management1/1              unassigned      YES unset  administratively down down

Please help. It is urgent. Thank you.

  • 2
    Which command is not supported? Please include the commands you are trying to add to your 5506. – Ron Trunk Dec 28 '18 at 19:58
  • I'm not sure I completely understand. You can only have one layer-3 interface in a network. The switch interfaces are layer-2 interfaces, and they are all in the network for VLAN 2. You do not assign layer-3 addresses to layer-2 interfaces. – Ron Maupin Dec 28 '18 at 19:59
  • In asa 5505 first ex. Ethernet 0/2-7 are using the same subnet of VLAN 2. This how can I enable in 5506 as switchport access vlan command is not working inside in asa 5506 in interface GigabitEthernet1/2-7 – chackers Dec 28 '18 at 20:10
5

The ASA 5506 doesn't have the switchport commands like the 5505. In routed mode, each interface is on a separate subnet, like a router.

  • But when I use the routed mode BVI command is not supported ? As ASA should be working in routed more then the transparent mode. – chackers Dec 28 '18 at 20:30
  • Look at this example: petenetlive.com/KB/Article/0001422 – Ron Trunk Dec 28 '18 at 20:50
  • Thanks man. But I already looked at it. And it is only working in transparent mode. @rontrunk. So I am searching for option to do the same in routed mode. – chackers Dec 28 '18 at 20:56
  • Oh, I see now I understand what you're trying to do. Bad news, I'm afraid. Edited my answer. – Ron Trunk Dec 28 '18 at 21:08
  • So is there any option available to do the same or not ? – chackers Dec 28 '18 at 21:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.