4

I am working with 2 identical industrial machines with multiple Ethernet switches per machine. The basic layout looks like this:

Switch 1 Machine A -> Switch 2 Machine A -> Switch 4 Machine A
                  |-> Switch 3 Machine A
                  \-> Switch 1 Machine B -> Switch 2 Machine B -> Switch 4 Machine B
                                        \-> Switch 3 Machine B

I double checked every Ethernet cable in the machines and confirmed there are no loops

Each switch has multiple devices on it (some of which are daisy chained) All the switches are Allen Bradley Stratix 5700 Industrial Managed Ethernet Switches that have IPs set but no other settings modified from the defaults.

When we power down Machine B (including all of the Machine B switches) connection is lost between our PLC which is on Machine A Switch 1 and our safety inputs which are on Machine A switch 2

Why would I be loosing this connectivity? It takes about 30 seconds for all the devices to reconnect and stops Machine A from working until it is all back online. Why would it only be this way? I do not see the same behavior on machine B when I power off Machine A. Is there something I can do from the managed switch side to force the information on a certain path so that the loss of Machine B's switches doesn't cause connectivity loss?

Thanks

  • 4
    It seems those switches have some spanning-tree protocol activated by default - have you set a root switch in your network? Have you checked the switch log? – Zac67 Jan 3 at 20:32
  • @Zac67 There is no loop so how can there be Spanning Tree? I thought Spanning Tree was to set up redundancies in case of link failures? No there is no Root Switch set. I tried to recreate the problem to see if it added entries into the SYSLOG but this time it was fine on power down and lost connection on power up. There were no new entries in the SYSLOG – Evan Jan 3 at 20:44
  • Even though there are no loops, spanning tree is still blocking ports when the root disappears. – Ron Trunk Jan 3 at 20:46
4

Welcome to Network Engineering! The 30 second loss of connectivity is a strong indication that spanning-tree is causing problems. If a switch on B is the root, switch A will block all ports when it no longer "hears" the root switch.

You should:

  1. Set the all the switch's STP mode to Rapid Spanning Tree.
  2. Set all the ports excepts those that link switches to PortFast.
  3. Set switch 1 Machine A to be the spanning tree root.

You can also turn off spanning tree IF and ONLY IF you are sure you can't create a loop by inadvertently connecting two switches together.

  • Makes sense. I see the settings to change to Rapid Spanning Tree and to set which ports are using PortFast but I am not seeing how to set up tree root. I have a table with 1 row where the only editable fields are Enable check box and Priority. See Here – Evan Jan 4 at 12:14
  • 1
    The switch with the lowest priority becomes the root. Set the root switch priority to 4096. – Ron Trunk Jan 4 at 13:30
  • What happens with a tie in priority? Wouldn't changing the root to be in Machine A make the same problem just with the machines swapped: If Machine A shuts off then Machine B fails to communicate. I think it is safe to say there will be no loops so I am fine with turning off spanning, I would just like to understand more. – Evan Jan 4 at 14:18
  • 1
    Yes, you are right. B will block, although with RSTP that will be just a second or two. In case of a tie, the switch with the lowest MAC address becomes the root. – Ron Trunk Jan 4 at 15:00
  • Makes sense. However because we are doing safety devices over Ethernet being down for a second stops the machine. I disabled the Spanning Tree and the problem resolved. Thanks for your help! – Evan Jan 4 at 15:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.