0

On a ProCurve V1910 I have configured Voice VLAN as follows in network settings using the Web UI:

  1. LLDP -> Global Setup -> LLDP Enable -> Set Enable
  2. VLAN -> Modify Port -> Select ports -> Set Link Type to Hybrid, leaving default production VLAN as untagged membership
  3. Voice VLAN -> Setup -> Set Voice VLAN Security to [Disable]
  4. Voice VLAN -> Port Setup -> Select Ports -> Port Mode [Auto] and Voice VLAN Port State to [Enable], enter the voice VLAN ID in the textbox and [Apply]

If I now connect the IP phone, in the LLDP settings the phone gets recognized as Telephone with Voice media type.

Snippet from LLDP neighbour port details:

System capabilities supported : Telephone 
System capabilities enabled   : Telephone
[...]
Media policy type        : Voice
Unknown Policy           : No  
VLAN tagged              : Yes
Media policy VlanID      : 300

I would now expect the switch to recognize that it should enable VLAN 300 as tagged VLAN.

However, for that to work I first need to add my IP phones OUI to the "Voice VLAN" configuration. Only if I add the OUI the switch recognizes the phone and everything works as expected. (Yealink phone on VLAN300, forwarding the production VLAN on the PC port)

Am I missing something? What's the point of LLDP if I need to add the OUI for Voice VLAN to work?

  • That's not really doing "voice vlan"; that's an "oui vlan". The switch should simply place the voice vlan information in the lldp message(s), and let the phone figure out how to get there. (which is how bigger HP (HPE) hardware does it.) – Ricky Beam Jan 4 at 20:38
  • That is what happens as far as I haven't configured the phone to place itself in tagged vlan300 and yet it is on vlan300. (So that's what lldp does). Problem is the v1910 will only tag vlan300 on a port if oui matches. So the phone does seem to interpret LLDP info from the switch but not vice versa. Switch does not tag the voice vlan based on its LLDP neighbour data – Jasper Jan 5 at 7:40
0

So I figured out what to do to fix this.

First, open a CLI console to the switch (this functionality doesn't seem to be supported in the Web UI)

Then enter these commands:

_cmdline-mode on
* choose Y to ignore warning and enter password: 512900

system-view
undo voice vlan security enable
lldp enable
voice vlan track lldp
save

Now the OUI records arent required for Voice VLAN to work.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.