1

I am trying to set up a new network for a small business, and I can’t figure out what I have misconfigured. Hoping someone can provide me with some ideas.

I have 6 VLANs set up. 10.10.10.0/24, 10.10.20.0/24, 10.10.30.0/24, 10.10.40.0/24, 10.10.50.0/24, and 10.10.60.0/24. VLAN 40 is set as the management VLAN for all the switches and for the ESXi hosts. My switches you can see in the diagram are an HPE 1920s 48port, HPE 1920s 24 port, and a Dell VRTX R1-2210 switch (2 external ports and 4 internal ports per host). ESXi is installed on the 3 hosts and the hosts are set to and accessible on VLAN 40 from the switches. When my laptop is on VLAN 40 I can ping all VLAN interfaces of all the switches and the ESXi hosts with the GW set to .11, the core switch. My problem is that when I install a VM on host1 on VLAN20, it can not reach the gateway (.11). I would have assumed the trunks misconfigured between .11 and .12 but that shouldn’t be the case I think as my laptop is on switc2 (.12) and I can reach everything going through the .11 gateway. BUT… my VM CAN reach .12, so the traffic appears to be leaving both the vSwitchH1, and the trunk out of the VRTX. Which confuses me a bit. Why can’t it go the last leg to .11? To clarify, my VM can ping 10.10.20.12, but not 10.10.20.11, and therefor can’t reach it’s gateway.

I have been working on this for a while and have tried a few different things which reach beyond my networking knowledge. I was having weird issues with one of the internal VRTX ports (te2/4) not being accessible, but I moved the v40 access port to a different internal port and it started working, so I think it may be a defective port.

I thought based on some weird initial behavior I may have been having a spanning tree issue (there was another switch in this setup initially- but I have removed it to get this working). So I set up manually forcing RSTP (this is the default and best for the VRTX according to my research) and manually configuring the RSTP root switch. That didn’t seem to have any real impact. I have since factory reset all the switches to clear everything out and sit at the current config in the picture. The only manual change I have done is go back to forcing RSTP from the HP switches, but I did not manually configure the root again. (also, logs didn’t actually show any STP errors or anything). I’m kind of lost now and wondering if I have made a dumb mistake. I’m obviously not a network engineer. Any ideas would be appreciated. Thanks!

I will try to include a picture here but not sure of the best method. If it doesn't look good I will try another method. enter image description here

EDIT TO ADD DEVICE CONFIGS Working on the VRTX device config, but it keeps giving me an error trying to download the config.

SWITCH1 .11

!Current Configuration:
!
!System Description "HPE OfficeConnect Switch 1920S 48G 4SFP JL382A, PD.02.06, 
Linux 3.6.5-a07f8920, U-Boot 2012.10-00118-g3773021 (Oct 11 2016 - 15:39:54)"
!System Software Version "PD.02.06"
!System Up Time          "1 days 0 hrs 54 mins 53 secs"
!Additional Packages     HPE QOS,HPE IPv6 Management,HPE Routing
!Current SNTP Synchronized Time: SNTP Client Mode Is Disabled
!
network protocol none
network parms 192.168.1.1 255.255.255.0 0.0.0.0
vlan database
vlan 10,20,30,40,50,60
vlan name 10 "VLAN10"
vlan name 20 "VLAN20"
vlan name 30 "VLAN30"
vlan name 40 "VLAN40"
vlan name 50 "VLAN50"
vlan name 60 "VLAN60"
vlan routing 10 1
vlan routing 20 2
vlan routing 30 3
vlan routing 40 4
vlan routing 50 5
vlan routing 60 6
exit
network mgmt_vlan 40
configure
!clock timezone -5 minutes 0
clock timezone id 17
time-range Schedule-1
exit
time-range Schedule-2
exit
ip routing
no username guest
line console
exit
line telnet
exit
line ssh
exit
spanning-tree
spanning-tree mode rstp
interface 49
addport TRK 1
exit
interface 50
addport TRK 1
exit
interface 51
addport TRK 2
exit
interface 52
addport TRK 2
exit
snmp-server sysname "USWITCH1"
snmp-server contact ""
!
interface 1
spanning-tree port mode
exit
*REMOVED UNCONFIGURED INTERFACE**
interface 48
spanning-tree port mode
vlan pvid 40
vlan participation exclude 1
vlan participation include 40
exit
interface TRK 1
spanning-tree port mode
vlan participation include 10,20,30,40,50,60
vlan tagging 10,20,30,40,50,60
exit
interface TRK 2
spanning-tree port mode
vlan participation include 10,20,30,40,50,60
vlan tagging 10,20,30,40,50,60
exit
interface TRK 3
spanning-tree port mode
exit
*REMOVED UNCONFIGURED TRUNKS**
interface TRK 16
spanning-tree port mode
exit
interface vlan 10
bandwidth 10000
routing
ip address 10.10.10.11 255.255.255.0
ip mtu 1500
no ip unreachables
no ip redirects
exit
interface vlan 20
bandwidth 10000
routing
ip address 10.10.20.11 255.255.255.0
ip mtu 1500
no ip unreachables
no ip redirects
exit
interface vlan 30
bandwidth 10000
routing
ip address 10.10.30.11 255.255.255.0
ip mtu 1500
no ip unreachables
no ip redirects
exit
interface vlan 40
bandwidth 10000
routing
ip address 10.10.40.11 255.255.255.0
ip mtu 1500
no ip unreachables
no ip redirects
exit
interface vlan 50
bandwidth 10000
routing
ip address 10.10.50.11 255.255.255.0
ip mtu 1500
no ip unreachables
no ip redirects
exit
interface vlan 60
bandwidth 10000
routing
ip address 10.10.60.11 255.255.255.0
ip mtu 1500
no ip unreachables
no ip redirects
exit
exit

SWITCH2 .12

!Current Configuration:
!
!System Description "HPE OfficeConnect Switch 1920S 24G 2SFP JL381A, PD.02.06, Linux 3.6.5-a07f8920, U-Boot 2012.10-00118-g3773021 (Oct 11 2016 - 15:39:54)"
!System Software Version "PD.02.06"
!System Up Time          "1 days 0 hrs 54 mins 26 secs"
!Additional Packages     HPE QOS,HPE IPv6 Management,HPE Routing
!Current SNTP Synchronized Time: SNTP Client Mode Is Disabled
!
network protocol none
network parms 192.168.1.2 255.255.255.0 0.0.0.0
vlan database
vlan 10,20,30,40,50,60
vlan name 10 "VLAN10"
vlan name 20 "VLAN20"
vlan name 30 "VLAN30"
vlan name 40 "VLAN40"
vlan name 50 "VLAN50"
vlan name 60 "VLAN60"
vlan routing 10 1
vlan routing 20 2
vlan routing 30 3
vlan routing 40 4
vlan routing 50 5
vlan routing 60 6
exit
network mgmt_vlan 40
configure
!clock timezone -5 minutes 0
clock timezone id 17
time-range Schedule-1
exit
time-range Schedule-2
exit
ip routing
no username guest
line console
exit
line telnet
exit
line ssh
exit
spanning-tree
spanning-tree mode rstp
interface 25
addport TRK 1
exit
interface 26
addport TRK 1
exit
interface 1
addport TRK 2
exit
interface 2
addport TRK 2
exit
snmp-server sysname "USWITCH2"
snmp-server contact ""
!
interface 3
spanning-tree port mode
exit
interface 4
spanning-tree port mode
exit
*REMOVED UNCONFIGURED INTERFACES**
interface 24
spanning-tree port mode
vlan pvid 40
vlan participation exclude 1
vlan participation include 40
exit
interface TRK 1
spanning-tree port mode
vlan participation include 10,20,30,40,50,60
vlan tagging 10,20,30,40,50,60
exit
interface TRK 2
spanning-tree port mode
vlan participation include 10,20,40,50,60
vlan tagging 10,20,40,50,60
exit
interface TRK 3
spanning-tree port mode
exit
**REMOVED UNCONFIGURED TRUNKS**
interface TRK 8
spanning-tree port mode
exit
interface vlan 10
bandwidth 10000
routing
ip address 10.10.10.12 255.255.255.0
ip mtu 1500
no ip unreachables
no ip redirects
exit
interface vlan 20
bandwidth 10000
routing
ip address 10.10.20.12 255.255.255.0
ip mtu 1500
no ip unreachables
no ip redirects
exit
interface vlan 30
bandwidth 10000
routing
ip address 10.10.30.12 255.255.255.0
ip mtu 1500
no ip unreachables
no ip redirects
exit
interface vlan 40
bandwidth 10000
routing
ip address 10.10.40.12 255.255.255.0
ip mtu 1500
no ip unreachables
no ip redirects
exit
interface vlan 50
bandwidth 10000
routing
ip address 10.10.50.12 255.255.255.0
ip mtu 1500
no ip unreachables
no ip redirects
exit
interface vlan 60
bandwidth 10000
routing
ip address 10.10.60.12 255.255.255.0
ip mtu 1500
no ip unreachables
no ip redirects
exit
ip route 0.0.0.0 0.0.0.0 10.10.40.11
exit

Having some issues with the VRTX config file, still working on trying to get it, but here are some of the configuration settings

VRTX PICS

enter image description here

enter image description here

enter image description here

enter image description here

enter image description here

enter image description here

enter image description here

  • Please edit your question to include the network device configurations. You can refer to the Network Engineering Question Checklist for guidance, then edit your question with the necessary information. – Ron Maupin Jan 11 at 16:08
  • no worries, thank you! I will get the device configurations and add them to the post. – ns_jjb Jan 11 at 16:24
  • Double-check VLAN tagged memberships for te1/1,2,3 - possibly the VM is associated with a pNIC that's not tagged. Also check up to which point/switch the VM's MAC is visible in the VLAN. – Zac67 Jan 11 at 18:33
  • @Zac67 thanks for the reply! For host1 module the TE1/1,2,3 NICs are trunks which carry tagged traffic for 10,20,40,50,60 and those 3 NICs are associated with vSwitchH1, which have port groups VLAN10, VLAN20, VLAN40, VLAN50, and VLAN60. I just double checked those settings and they are as I have just stated. – ns_jjb Jan 11 at 19:03
  • @Zac67 2/2...I just double checked those settings and they are as I have just stated. TE 1/4 is an untagged Access port for VLAN40 which connects to ESXi. Also I can see the MAC for the VM in the address table on the VRTX switch, it shows it coming from TE1/3, I can see it on switch2 in the MAC table which shows it coming from TRK2, and I can see it on switch1 in the MAC table as well, also showing it coming from TRK2. – ns_jjb Jan 11 at 19:09

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.