4

I have a lab where I would like to configure an PPPoE client and server. I have a ISP and a router device who are both connected to each other with the FaseEthernet0/1 interface.

Client config:

interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
 pppoe enable
 pppoe-client dial-pool-number 1
!
interface Dialer1
 mtu 1492
 ip address negotiated
 encapsulation ppp
 dialer pool 1
 ppp chap password 0 MyPassword

ISP config:

username CPE password 0 MyPassword
!
bba-group pppoe MyGroup
 virtual-template 1
 sessions per-mac limit 2
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
 pppoe enable group MyGroup
!
interface Virtual-Template1
 ip address 10.0.0.1 255.255.255.0
 peer default ip address pool MyPool
 ppp authentication chap callin
!
ip local pool MyPool 10.0.0.2 10.0.0.254

This does not seem to establish a connection. When I run show pppoe session on the client router, I get the following output:

router#show pppoe session 
     1 client session 

Uniq ID  PPPoE  RemMAC          Port                  Source   VA         State
           SID  LocMAC                                         VA-st
    N/A      0  0000.0000.0000  Fa0/1                 Di1      N/A        PADISNT 
                0000.0000.0000   

I can't ping from the client to the ISP. What is wrong and how to fix it?

Edit: the pysical interfaces where down, this fixed it a bit. Now it prints the following text on the console every few seconds:

*Jan  1 01:55:46.519: %DIALER-6-BIND: Interface Vi2 bound to profile Di1
*Jan  1 01:55:46.523: %LINK-3-UPDOWN: Interface Virtual-Access2, changed state to up
*Jan  1 01:55:46.543: %DIALER-6-UNBIND: Interface Vi2 unbound from profile Di1
*Jan  1 01:55:46.547: %LINK-3-UPDOWN: Interface Virtual-Access2, changed state to down

Disabling authentication fixed it and brings the PPPoE up. But that still is not really a solution.

1 Answer 1

2

On your ISP router, you're asking for a CHAP authentication with username CPE and password MyPassword:

username CPE password 0 MyPassword

and

interface Virtual-Template1
 ip address 10.0.0.1 255.255.255.0
 peer default ip address pool MyPool
 ppp authentication chap callin

Yet, on your client router, you don't provide a username:

interface Dialer1
 mtu 1492
 ip address negotiated
 encapsulation ppp
 dialer pool 1
 ppp chap password 0 MyPassword

This obviously fails at the authentication stage! And that's why when you disable authentication it works correctly.

Just add

ppp chap hostname CPE

to your dialer configuration:

interface Dialer1
 mtu 1492
 ip address negotiated
 encapsulation ppp
 dialer pool 1
 ppp chap hostname CPE
 ppp chap password 0 MyPassword

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.