2

This is a screenshot from a Cisco book. It says that 2 VLANs can be bridged using some L2 device also. As far as I know it is possible only by using some L3 device. Can someone please explain it how 2 VLANs can be bridged using a L2 device? enter image description here

  • 1
    You can short circuit two VLANs by using two layer 2 switches which individually connected ports are in the two respective VLANs. For instance, connect switch 1 port 1 in access VLAN 2 with switch 2 port 1 in access VLAN 3. Then traffic can flow from VLAN 2 to VLAN 3 and vice versa. You would need a bit more configuration though as the switch will probably shut down the port, when it receives a BPDU packet. Also the IP subnets might be different etc. – user36472 Jan 23 '19 at 10:34
  • Did any answer help you? If so, you should accept the answer so that the question doesn't keep popping up forever, looking for an answer. Alternatively, you can provide and accept your own answer. – Ron Maupin Dec 14 '19 at 18:58
3

Simply put, if you bridge two VLANs together, they effectively become one VLAN.

There will no longer be a distinction between the VLANs -- they will act as one. For example a broadcast will be forwarded to all ports on both VLANs. Flooding will span both VLANs

  • So if I connect 2 vlans of the same switch using a cable, I would be able to send packets between 2 VLANs? – MUSR Jan 23 '19 at 13:22
  • Yes (ignoring spanning tree). There will no longer be a distinction between the VLANs -- they will act as one. For example a broadcast will be forwarded to all ports on both VLANs. Flooding will span both VLANs. – Ron Trunk Jan 23 '19 at 14:25
2

A bridge / L2 device forwards frames based on the destination MAC address. Most often this is a common switch. If you bridge two VLANs they become a single L2 broadcast domain. Normally you wouldn't want that.

A router / L3 device forwards packets based on the destination IP address. If you use it to connect two VLANs they can communicate across the router (on L3/IP) but stay separate L2 broadcast domains.

1

Yes, bridging VLANs into a single broadcast domain (allowing them to be on the same IP subnet) is a fairly simple matter. And it does not necessarily require an external switch.

I would not recommend bridged VLANs as a permanent/production solution, But it can be quite useful in transitional evolutions; consolidation of subnets for instance. I use it during deployment of new sites to bridge an upstream management VLAN to the local one.

Here is an example configuration using a Cisco SG220-26 switch:

sg220-oi#sho run interfaces GigabitEthernet 2,3,25
interface gi2
 switchport mode access
 switchport access vlan 262
 spanning-tree bpdufilter enable
 description "Vlan262-256bridge"
 no cdp enable
 no cdp log mismatch native
!
interface gi3
 switchport mode access
 switchport access vlan 256
 spanning-tree bpdufilter enable
 description "Vlan262-256bridge"
 no cdp enable
 no cdp log mismatch native
!
interface gi25
 switchport trunk allowed vlan add 2,260,262
 description "Uplink (vlan2/outside)"
!

Notes:

  • External management VLAN 262 is "trunked" to the switch on port 25

  • VLAN 262 is then bridged to the local management VLAN 256 using access ports 2 & 3.

  • You must disable spanning-tree on the two ports you will bridge (bpdufilter enable) or the switch may perceive a loop with undesirable results.

  • Also, if present, you should disable cisco discovery protocol/mismatch logging to keep from flooding your switches logs with VLAN mismatch errors.

Once configured, simply patch the two access ports together with a CAT6 patch cable - no external switch required.

Hope someone finds this useful.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.