2

I have a problem. After I've reseted my router configuration it doesn't get IP from LTE SIM card. Seems like my celullar0 interface is in spoofing mode.

> Router#show interfaces cellular 0     Cellular0 is up (spoofing), line
> protocol is up (spoofing)   Hardware is 4G WWAN Modem - Global (Europe
> & Australia) Multimode LTE/DC-HSPA+/HSPA+/HSPA/U   Internet address
> will be assigned dynamically by the network   MTU 1500 bytes, BW 50000
> Kbit/sec, DLY 100000 usec, 
>      reliability 255/255, txload 1/255, rxload 1/255   Encapsulation SLIP, loopback not set   Keepalive not supported    Last input never,
> output never, output hang never   Last clearing of "show interface"
> counters never   Input queue: 0/75/0/0 (size/max/drops/flushes); Total
> output drops: 0   Queueing strategy: fifo   Output queue: 0/10
> (size/max)   5 minute input rate 0 bits/sec, 0 packets/sec   5 minute
> output rate 0 bits/sec, 0 packets/sec
>      0 packets input, 0 bytes, 0 no buffer
>      Received 0 broadcasts (0 IP multicasts)
>      0 runts, 0 giants, 0 throttles 
>      0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
>      0 packets output, 0 bytes, 0 underruns
>      0 output errors, 0 collisions, 0 interface resets
>      0 unknown protocol drops
>      0 output buffer failures, 0 output buffers swapped out

My configuration is below:

Router#show running-config 
Building configuration...

Current configuration : 2733 bytes
!
! Last configuration change at 12:30:58 UTC Thu Jan 31 2019 by root
!
version 15.6
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
!
!
!
!
!
!         
!
!
!
!
!
!
!
!
!
!
!


!
!
!
!
ip cef
no ipv6 cef
!
!
!
!         
!
multilink bundle-name authenticated
!
!
chat-script lte "" "AT!CALL" TIMEOUT 20 "OK"
!
!
!
!
!
license udi pid C899G-LTE-GA-K9 sn FCZ2124E2E6
!
!
!
redundancy
!
!
!
!
!
controller Cellular 0
 lte modem link-recovery rssi onset-threshold -110
 lte modem link-recovery monitor-timer 20
 lte modem link-recovery wait-timer 10
 lte modem link-recovery debounce-count 6
!
! 
!
!
!
!
!
!
!
!
!
interface Cellular0
 ip address negotiated
 encapsulation slip
 history BPS
 dialer in-band
 dialer string lte
 dialer-group 1
!
interface Cellular1
 no ip address
 encapsulation slip
!
interface GigabitEthernet0
 no ip address
!
interface GigabitEthernet1
 no ip address
!
interface GigabitEthernet2
 no ip address
!
interface GigabitEthernet3
 no ip address
!
interface GigabitEthernet4
 no ip address
!
interface GigabitEthernet5
 no ip address
!
interface GigabitEthernet6
 no ip address
!
interface GigabitEthernet7
 no ip address
!
interface GigabitEthernet8
 duplex auto
 speed auto
!
interface GigabitEthernet9
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Vlan1
 no ip address
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!         
ip ssh server algorithm encryption aes128-ctr aes192-ctr aes256-ctr
ip ssh client algorithm encryption aes128-ctr aes192-ctr aes256-ctr
!
ip sla 1
 icmp-echo 1.1.1.1 source-interface Cellular0
 tag ###-- ping cloudflare dns to keep LTE up
 frequency 10
ip sla schedule 1 life forever start-time now
ipv6 ioam timestamp
!
!
control-plane
!
!
!
mgcp behavior rsip-range tgcp-only
mgcp behavior comedia-role none
mgcp behavior comedia-check-media-src disable
mgcp behavior comedia-sdp-force disable
!
mgcp profile default
!         
!
!
!
!
!
!
line con 0
 privilege level 15
 login local
 no modem enable
line aux 0
 privilege level 15
 login local
line 2
 privilege level 15
 login local
 no activation-character
 no exec
 transport preferred none
 transport input all
 stopbits 1
line 3
 script dialer lte
 login local
 no exec
 rxspeed 100000000
 txspeed 50000000
line 8
 privilege level 15
 login local
 no exec
line vty 0 4
 access-class login-acl in vrf-also
 privilege level 15
 login local
 transport preferred ssh
 transport input telnet ssh
!
scheduler allocate 20000 1000
!
end

Before the reset it was working fine, can you please tell me where the problem is?

  • Try to change encapsulation on Cellular0 to encapsulation ppp – user36472 Jan 31 at 12:49
  • @Cown i tried, but i get an error: Cellular0: Only SLIP encapsulation supported – Tomas Jan 31 at 12:54
  • Ok, what APN are you suppose to use from your SIM ISP? – user36472 Jan 31 at 12:54
  • Just for clarification: The word spoofing indicates that the line really is not up, but the dialer is forcing the line to masquerade as "up" so that upper level protocols will continue to operate as expected. Spoofing is a state added to allow Dial on Demand (DDR) to work. But because no packets are routed to an interface that is "down", it must pretend to be up (spoof) so packets will be routed to it even when it is not connected. Spoofing is the normal state on a dialer interface. – user36472 Jan 31 at 13:03
  • When you find out your APN configuration i suggest you read: wannabelab.blogspot.com/2016/04/… - it's a complete walk through of how to setup your router with LTE. – user36472 Jan 31 at 13:06
3

You need to setup the APN as specified by your SIM company/ISP under the Cellular0 interface.

Just for clarification: The word spoofing indicates that the line is really not up, but the dialer is forcing the line to masquerade as "up" so that upper level protocols will continue to operate as expected. Spoofing is a state added to allow Dial on Demand (DDR) to work. But because no packets are routed to an interface that is "down", it must pretend to be up (spoof) so packets will be routed to it even when it is not connected. Spoofing is the normal state on a dialer interface.

Alternatively there's a complete configuration guide below for the 899G router. https://wannabelab.blogspot.com/2016/04/cisco-899-4g-lte-router-configuration.html

0

We configure the dialer to dial on lost route so we don't have to eat up our data plan with pings to keep the link up:

dialer watch-list 1 ip 66.66.66.66 255.255.255.255

Because that route (66.66.66.66/32) is never in the routing table, the dialer will always bring the connection up even if there is no data to be sent.

LAB-819#sh dialer

Ce0 - dialer type = IN-BAND ASYNC NO-PARITY
Idle timer (never), Fast idle timer (20 secs)
Wait for carrier (30 secs), Re-enable (15 secs)
Dialer state is data link layer up
Dial reason: Dialing on watched route loss
Time until disconnect never
Current call connected 1d10h
Connected to lte

Dial String      Successes   Failures    Last DNIS   Last status
lte                     14          7    1d10h          successful   Default

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.