3

This may sound a bit unusual, but I'm looking for someone who can answer with a sanitized NXOS configuration with the following features used:

  • vPC
  • FEX
  • EIGRP, OSPF or ISIS (IPv4)
  • HSRP or VRRP

This configuration will be used to test config parsing for ciscoconfparse. I'm looking for the whole config: snmp, logging, vPC peer-link, etc... passwords / snmp-communities / sensitive-ip info changed but not removed.

2
  • I have a configuration with OSPF and VRRP and another one with vPC. No FEX. Would it help? – JFL Feb 10 '19 at 12:27
  • certainly... I can manually add the fex bits in... can you post both configs? vPC is definitely wanted – Mike Pennington Feb 10 '19 at 12:27
5

Full Nexus 7010 configuration.

version 6.2(12)
power redundancy-mode ps-redundant

hostname removed
no system admin-vdc
install feature-set fex
vdc DCE-200-N7010-01 id 1
  limit-resource module-type m1 f1 m1xl m2xl 
  allow feature-set fex
  allocate interface Ethernet1/1-48
  allocate interface Ethernet2/1-32
  allocate interface Ethernet3/1-32
  allocate interface Ethernet4/1-32
  allocate interface Ethernet7/1-24
  limit-resource vlan minimum 16 maximum 4094
  limit-resource monitor-session minimum 0 maximum 2
  limit-resource monitor-session-erspan-dst minimum 0 maximum 23
  limit-resource vrf minimum 2 maximum 1000
  limit-resource port-channel minimum 0 maximum 768
  limit-resource u4route-mem minimum 96 maximum 96
  limit-resource u6route-mem minimum 24 maximum 24
  limit-resource m4route-mem minimum 58 maximum 58
  limit-resource m6route-mem minimum 8 maximum 8
  limit-resource monitor-session-inband-src minimum 0 maximum 1
  limit-resource anycast_bundleid minimum 0 maximum 16
  limit-resource monitor-session-mx-exception-src minimum 0 maximum 1
  limit-resource monitor-session-extended minimum 0 maximum 12
feature-set fex

feature telnet
feature tacacs+
cfs eth distribute
feature bgp
feature udld
feature interface-vlan
feature netflow
feature hsrp
feature lacp
feature vpc
feature vtp
feature bfd
feature sla sender
feature sla responder

logging level pixm 2
logging level vtp 2
logging level xmlma 7
username admin password 5 password  role network-admin
no password strength-check
ip domain-lookup
tacacs-server key 7 xxx
ip tacacs source-interface loopback1
tacacs-server host 10.10.6.165 
tacacs-server host 10.10.2.130 
aaa group server tacacs+ tacacs 
    server 10.10.6.165 
    server 10.10.2.130 
    use-vrf management
errdisable recovery interval 120
errdisable recovery cause all

control-plane
  service-policy input copp-system-policy
vtp mode transparent
vtp domain 4
fex 104
  pinning max-links 1
  description
fex 105
  pinning max-links 1
  description
-- Rest of FEX truncated --
bfd interval 250 min_rx 250 multiplier 3
bfd echo-interface loopback1
snmp-server location This is the location
snmp-server user admin network-admin auth md5 md5-password priv priv-password localizedkey
rmon event 1 log trap public description
rmon event 2 log trap public description
rmon event 3 log trap public description
rmon event 4 log trap public description
rmon event 5 log trap public description
snmp-server community read-write group network-admin
snmp-server community read group network-operator
ntp server 10.10.2.10
ntp server 10.10.2.10 prefer
aaa authentication login default group tacacs 
aaa authorization config-commands default group tacacs 

ip route 0.0.0.0/0 <default route>
-- Layer 2 VLANs truncated
flow timeout active 60
flow exporter EXPORTER-1
  description
  destination 10.10.3.206 use-vrf TESTVRF
  transport udp 9991
  source Vlan3059
  version 9
track 2 interface Ethernet3/31 line-protocol
flow record FLOW-RECORD-1
  match ipv4 source address
  match ipv4 destination address
  match transport source-port
  match transport destination-port
  collect counter bytes long
  collect counter packets long
flow monitor MONITOR-1
  record netflow-original
  exporter EXPORTER-1

-- VLANs truncated --

-- spanning-tree VLAN priority removed --
route-map internal permit 10
  match ip address permit-any 
vrf context VRF
vrf context removed
vrf context removed
  -- routes truncated --
vrf context removed
vrf context removed
vrf context removed
vrf context removed
vrf context removed
vrf context removed
vrf context removed
  address-family ipv4 unicast
vrf context removed
vrf context management
  ip route 0.0.0.0/0 10.10.248.1
vrf context vpc-keepalive
vpc domain 4
  role priority 1000
  peer-keepalive destination 10.255.255.2 source 10.255.255.1 vrf vpc-keepalive
  peer-gateway
  ip arp synchronize
port-profile type ethernet VmWare
  switchport
  switchport mode trunk
  switchport trunk allowed vlan 11,14-15,192,301,550,700,2001-2003,2032-2034
  switchport trunk allowed vlan add 2064,2128,2140,2150,2180,2240-2241
  switchport trunk allowed vlan add 2243,2254,3100-3103,3108,3130,3236
  switchport trunk allowed vlan add 3239
  spanning-tree port type edge trunk
  no shutdown
  description
  state enabled
port-profile type ethernet XenApp
  switchport
  switchport mode trunk
  spanning-tree port type edge trunk
  switchport trunk allowed vlan 2064,2248,3101-3105,3340
  no shutdown
  description
  state enabled


interface mgmt0
  vrf member management
  ip address 10.10.248.50/24

interface Vlan1

interface Vlan8
  no shutdown
  vrf member vpc-keepalive
  no ip redirects
  ip address 192.168.254.1/30

interface Vlan249
  description
  no shutdown
  vrf member removed
  no ip redirects
  ip address 10.249.255.253/16
  hsrp 2 
    authentication text HSRPAUTH
    preempt 
    priority 105 forwarding-threshold lower 1 upper 105
    ip 10.249.0.1
    track 2 

interface Vlan400
  description
  no shutdown
  vrf member removed
  no ip redirects
  ip address 10.5.129.3/24
  hsrp 2 
    authentication text HSRPAUTH
    preempt 
    priority 105 forwarding-threshold lower 1 upper 105
    ip 10.5.129.1
    track 2 

interface Vlan403
  description
  no shutdown
  vrf member removed
  no ip redirects
  ip address 10.5.131.3/25
  hsrp 2 
    authentication text HSRPAUTH
    preempt 
    priority 105 forwarding-threshold lower 1 upper 105
    ip 10.5.131.1
    track 2 

interface Vlan404
  description
  no shutdown
  vrf member removed
  no ip redirects
  ip address 10.5.131.131/25
  hsrp 2 
    authentication text HSRPAUTH
    preempt 
    priority 105 forwarding-threshold lower 1 upper 105
    ip 10.5.131.129
    track 2 

interface Vlan405
  description
  no shutdown
  vrf member removed
  no ip redirects
  ip address 10.5.132.3/22
  hsrp 2 
    authentication text HSRPAUTH
    preempt 
    priority 105 forwarding-threshold lower 1 upper 105
    ip 10.5.132.1
    track 2 

interface Vlan550
  description
  no shutdown
  vrf member removed
  no ip redirects
  ip address 10.111.50.3/24
  hsrp 2 
    authentication text HSRPAUTH
    preempt 
    priority 105 forwarding-threshold lower 1 upper 105
    ip 10.111.50.1
    track 2 

interface Vlan551
  description
  no shutdown
  vrf member removed
  no ip redirects
  ip address 10.111.51.3/24
  hsrp 2 
    authentication text HSRPAUTH
    preempt 
    priority 105 forwarding-threshold lower 1 upper 105
    ip 10.111.51.1
    track 2 

interface Vlan552
  description
  no shutdown
  vrf member removed
  no ip redirects
  ip address 10.111.52.3/24
  hsrp 2 
    authentication text HSRPAUTH
    preempt 
    priority 105 forwarding-threshold lower 1 upper 105
    ip 10.111.52.1
    track 2 

interface Vlan600
  description
  no shutdown
  vrf member removed
  no ip redirects
  ip address 10.237.128.253/24
  hsrp 7 
    authentication text HSRPAUTH
    preempt 
    priority 105 forwarding-threshold lower 1 upper 105
    ip 10.237.128.1

interface Vlan700
  description
  no shutdown
  vrf member removed
  no ip redirects
  ip address 10.237.0.253/24
  hsrp 7 
    authentication text HSRPAUTH
    preempt 
    priority 105 forwarding-threshold lower 1 upper 105
    ip 10.237.0.1

interface Vlan900
  description
  no shutdown
  vrf member removed
  no ip redirects
  ip address 10.152.200.194/28
  hsrp 0 
    preempt delay reload 180 
    priority 105 forwarding-threshold lower 1 upper 105
    timers msec 250 msec 750
    ip 10.152.200.193
    track 2 

interface Vlan997
  description
  no shutdown
  vrf member removed
  no ip redirects
  ip address 10.166.182.253/24
  hsrp 0 
    authentication text HSRPAUTH
    preempt 
    priority 105 forwarding-threshold lower 1 upper 105
    ip 10.166.182.1
    track 2 

-- 500 interface VLANs removed --

interface Vlan3237
  description
  no shutdown
  vrf member removed
  no ip redirects
  ip address 10.223.137.3/24
  hsrp 2 
    authentication text HSRPAUTH
    preempt delay reload 180 
    priority 105 forwarding-threshold lower 1 upper 105
    timers msec 250 msec 750
    ip 10.223.137.1
    track 2 

interface Vlan3238
  description
  no shutdown
  vrf member removed
  no ip redirects
  ip address 10.223.138.3/24
  hsrp 2 
    authentication text HSRPAUTH
    preempt delay reload 180 
    priority 105 forwarding-threshold lower 1 upper 105
    timers msec 250 msec 750
    ip 10.223.138.1
    track 2 

interface Vlan3239
  description
  no shutdown
  vrf member removed
  no ip redirects
  ip address 10.223.139.3/24
  hsrp 2 
    authentication text HSRPAUTH
    preempt delay reload 180 
    priority 105 forwarding-threshold lower 1 upper 105
    timers msec 250 msec 750
    ip 10.223.139.1
    track 2 

interface Vlan3305
  description
  no shutdown
  vrf member removed
  no ip redirects
  ip address 10.223.55.253/24
  hsrp 0 
    authentication text HSRPAUTH
    preempt 
    priority 105 forwarding-threshold lower 1 upper 105
    ip 10.223.55.1
    track 2 

interface Vlan3308
  description
  no shutdown
  vrf member removed
  no ip redirects
  ip address 10.223.208.253/24
  hsrp 2 
    authentication text HSRPAUTH
    preempt 
    priority 105 forwarding-threshold lower 1 upper 105
    ip 10.223.208.1
    track 2 

interface Vlan3336
  description
  no shutdown
  vrf member removed
  no ip redirects
  ip address 10.223.236.3/24
  hsrp 2 
    authentication text HSRPAUTH
    preempt delay reload 180 
    priority 105 forwarding-threshold lower 1 upper 105
    timers msec 250 msec 750
    ip 10.223.236.1
    track 2 

interface Vlan3339
  description
  no shutdown
  vrf member removed
  no ip redirects
  ip address 10.223.239.3/24
  hsrp 2 
    authentication text HSRPAUTH
    preempt delay reload 180 
    priority 105 forwarding-threshold lower 1 upper 105
    timers msec 250 msec 750
    ip 10.223.239.1
    track 2 

interface Vlan3405
  description
  no shutdown
  vrf member removed
  no ip redirects
  ip address 10.223.56.253/24
  hsrp 0 
    authentication text HSRPAUTH
    preempt 
    priority 105 forwarding-threshold lower 1 upper 105
    ip 10.223.56.1
    track 2 

interface Vlan3505
  description
  no shutdown
  vrf member removed
  no ip redirects
  ip address 10.223.57.253/24
  hsrp 0 
    authentication text HSRPAUTH
    preempt 
    priority 105 forwarding-threshold lower 1 upper 105
    ip 10.223.57.1
    track 2 

interface port-channel50
  description
  switchport
  switchport mode trunk
  vpc 50

interface port-channel80
  description

interface port-channel80.1
  description
  encapsulation dot1q 3051
  ip address 10.10.200.133/30
  no shutdown

interface port-channel80.2
  description
  encapsulation dot1q 3052
  vrf member removed
  ip address 10.138.200.133/30
  no shutdown

interface port-channel80.3
  description
  encapsulation dot1q 3053
  vrf member removed
  ip address 10.140.200.133/30
  no shutdown

interface port-channel80.4
  description
  encapsulation dot1q 3054
  vrf member removed
  ip address 10.142.200.133/30
  no shutdown

interface port-channel80.5
  description
  encapsulation dot1q 3055
  vrf member removed
  ip address 10.144.200.133/30
  no shutdown

interface port-channel80.6
  description
  encapsulation dot1q 3056
  vrf member removed
  ip address 10.146.200.133/30
  no shutdown

interface port-channel80.7
  description
  encapsulation dot1q 3057
  vrf member removed
  ip address 10.148.200.133/30
  no shutdown

interface port-channel80.8
  description
  encapsulation dot1q 3058
  vrf member removed
  ip address 10.150.200.133/30
  no shutdown

interface port-channel80.9
  description
  encapsulation dot1q 3059
  vrf member removed
  ip address 10.152.200.133/30
  no shutdown

interface port-channel101
  description
  switchport
  switchport mode trunk
  spanning-tree port type network
  vpc peer-link

interface port-channel104
  description
  switchport
  switchport mode fex-fabric
  fex associate 104
  mtu 9216

-- port-channels truncated --

interface port-channel3291
  description
  shutdown
  switchport
  switchport access vlan 2002
  vpc 3291

interface port-channel3991
  description
  switchport
  switchport mode trunk
  switchport trunk allowed vlan 11
  vpc 3991

-- Module 1 truncated --

interface Ethernet1/48
  description
  vrf member vpc-keepalive
  ip address 10.255.255.1/30
  no shutdown

interface Ethernet2/1
  description
  switchport
  switchport mode fex-fabric
  fex associate 112
  mtu 9216
  channel-group 112
  no shutdown

interface Ethernet2/2
  description
  switchport
  switchport mode fex-fabric
  fex associate 111
  mtu 9216
  channel-group 111
  no shutdown

interface Ethernet2/3
  description
  switchport
  switchport mode fex-fabric
  fex associate 124
  channel-group 124
  no shutdown

interface Ethernet2/4
  description
  switchport
  switchport mode fex-fabric
  fex associate 117
  mtu 9216
  channel-group 117
  no shutdown

interface Ethernet2/5
  description
  switchport
  switchport mode fex-fabric
  fex associate 105
  channel-group 105
  no shutdown

interface Ethernet2/6
  description
  switchport
  switchport mode fex-fabric
  fex associate 132
  channel-group 132
  no shutdown

interface Ethernet2/7
  description
  switchport
  switchport mode fex-fabric
  fex associate 132
  channel-group 132
  no shutdown

interface Ethernet2/8
  description
  switchport
  switchport mode fex-fabric
  fex associate 131
  channel-group 131
  no shutdown

interface Ethernet2/9
  description
  switchport
  switchport mode fex-fabric
  fex associate 108
  mtu 9216
  channel-group 108
  no shutdown

interface Ethernet2/10
  description
  switchport
  switchport mode fex-fabric
  fex associate 104
  mtu 9216
  channel-group 104
  no shutdown

interface Ethernet2/11
  description
  switchport
  switchport mode fex-fabric
  fex associate 120
  mtu 9216
  channel-group 120
  no shutdown

interface Ethernet2/12
  description
  switchport
  switchport mode fex-fabric
  fex associate 121
  mtu 9216
  channel-group 121
  no shutdown

interface Ethernet2/13
  description
  switchport
  switchport mode fex-fabric
  fex associate 132
  channel-group 132
  no shutdown

interface Ethernet2/14
  description
  switchport

interface Ethernet2/15
  description
  switchport
  switchport mode fex-fabric
  fex associate 131
  channel-group 131
  no shutdown

interface Ethernet2/16
  description
  switchport
  switchport mode fex-fabric
  fex associate 130
  channel-group 130

interface Ethernet2/17
  description
  switchport
  switchport mode fex-fabric
  fex associate 107
  mtu 9216
  channel-group 107
  no shutdown

interface Ethernet2/18
  description
  switchport
  switchport mode fex-fabric
  fex associate 115
  channel-group 115
  no shutdown

interface Ethernet2/19
  description
  switchport
  switchport mode fex-fabric
  fex associate 130
  channel-group 130
  no shutdown

interface Ethernet2/20
  description
  switchport
  switchport mode fex-fabric
  fex associate 129
  channel-group 129
  no shutdown

interface Ethernet2/21
  description
  switchport
  switchport mode fex-fabric
  fex associate 129
  channel-group 129
  no shutdown

interface Ethernet2/22
  description
  switchport
  switchport mode fex-fabric
  fex associate 123
  channel-group 123
  no shutdown

interface Ethernet2/23
  description
  switchport
  switchport mode fex-fabric
  fex associate 124

interface Ethernet2/24
  description
  switchport
  switchport mode fex-fabric
  fex associate 137
  channel-group 137
  no shutdown

interface Ethernet2/25
  description
  switchport
  switchport mode fex-fabric
  fex associate 116
  channel-group 116
  no shutdown

interface Ethernet2/26
  description
  switchport
  switchport mode fex-fabric
  fex associate 113
  channel-group 113
  no shutdown

interface Ethernet2/27
  description
  switchport
  switchport mode fex-fabric
  fex associate 137
  channel-group 137
  no shutdown

interface Ethernet2/28
  description
  switchport
  switchport mode fex-fabric
  fex associate 138
  channel-group 138
  no shutdown

interface Ethernet2/29
  description
  switchport
  switchport mode fex-fabric
  fex associate 138
  channel-group 138
  no shutdown

interface Ethernet2/30
  description
  switchport
  switchport mode fex-fabric
  fex associate 132
  channel-group 132
  no shutdown

interface Ethernet2/31
  description
  switchport
  switchport mode fex-fabric
  fex associate 130
  channel-group 130
  no shutdown

interface Ethernet2/32
  description

-- Module 3 and 4 truncated --

interface Ethernet7/3
  description
  switchport
  switchport mode fex-fabric
  fex associate 135
  mtu 9216
  channel-group 135
  no shutdown

interface Ethernet7/4
  description
  switchport
  switchport mode fex-fabric
  fex associate 135
  mtu 9216
  channel-group 135
  no shutdown

interface Ethernet7/5
  description
  switchport
  switchport mode fex-fabric
  fex associate 199
  mtu 9216
  channel-group 199
  no shutdown

interface Ethernet7/6
  description
  switchport
  switchport mode fex-fabric
  fex associate 126
  mtu 9216
  channel-group 126
  no shutdown

interface Ethernet7/7
  description
  switchport
  switchport mode fex-fabric
  fex associate 126
  mtu 9216
  channel-group 126
  no shutdown

interface Ethernet7/8
  description
  switchport
  switchport mode fex-fabric
  fex associate 140
  mtu 9216
  channel-group 140
  no shutdown

interface Ethernet7/9
  description
  switchport
  switchport mode fex-fabric
  fex associate 140
  mtu 9216
  channel-group 140
  no shutdown

interface Ethernet7/23
  description
  channel-group 80 mode active
  no shutdown

interface Ethernet7/24
  description
  channel-group 80 mode active
  no shutdown

interface loopback1
  description
  ip address 10.10.200.253/32

-- FEX switch interfaces removed --

clock timezone europe 1 0
clock summer-time CEST 5 Sun Mar 02:00 5 Sun Oct 03:00 60
cli alias name removed
line console
line vty
boot kickstart bootflash:/n7000-s1-kickstart.6.2.16.bin sup-1
boot system bootflash:/n7000-s1-dk9.6.2.16.bin sup-1
boot kickstart bootflash:/n7000-s1-kickstart.6.2.16.bin sup-2
boot system bootflash:/n7000-s1-dk9.6.2.16.bin sup-2
router bgp xxx
  router-id loopback1
  log-neighbor-changes
  address-family ipv4 unicast
    redistribute direct route-map internal
    redistribute static route-map internal
  neighbor 10.10.200.134 remote-as xxx
    password 3 xxx
    address-family ipv4 unicast
      soft-reconfiguration inbound
  neighbor 10.10.200.242 remote-as xxx
    password 3 xxx
    shutdown
    address-family ipv4 unicast
      soft-reconfiguration inbound
  neighbor 10.137.200.1 remote-as xxx
    password 3 xxx
    address-family ipv4 unicast
      soft-reconfiguration inbound
  neighbor 10.138.200.242 remote-as xxx
    shutdown
  vrf removed
    address-family ipv4 unicast
      redistribute direct route-map internal
      redistribute static route-map internal
    neighbor 10.138.200.134 remote-as xxx
      password 3 xxx
      address-family ipv4 unicast
        soft-reconfiguration inbound
    neighbor 10.138.200.242 remote-as xxx
      password 3 xxx
      shutdown
      address-family ipv4 unicast
        soft-reconfiguration inbound
    neighbor 10.138.201.130 remote-as xxx
      bfd
      password 3 xxx
      address-family ipv4 unicast
        soft-reconfiguration inbound
    neighbor 10.139.200.1 remote-as xxx
      password 3 xxx
      address-family ipv4 unicast
        soft-reconfiguration inbound
  vrf removed
    address-family ipv4 unicast
      redistribute direct route-map internal
      redistribute static route-map internal
    neighbor 10.140.200.134 remote-as xxx
      password 3 xxx
      address-family ipv4 unicast
        soft-reconfiguration inbound
    neighbor 10.140.200.242 remote-as xxx
      password 3 xxx
      shutdown
      address-family ipv4 unicast
        soft-reconfiguration inbound
    neighbor 10.141.200.1 remote-as xxx
      password 3 xxx
      address-family ipv4 unicast
        soft-reconfiguration inbound
  vrf removed
    address-family ipv4 unicast
      redistribute direct route-map internal
      redistribute static route-map internal
    neighbor 10.142.200.134 remote-as xxx
      password 3 xxx
      address-family ipv4 unicast
        soft-reconfiguration inbound
    neighbor 10.142.200.242 remote-as xxx
      password 3 xxx
      shutdown
      address-family ipv4 unicast
        soft-reconfiguration inbound
    neighbor 10.143.200.1 remote-as xxx
      password 3 xxx
      address-family ipv4 unicast
        soft-reconfiguration inbound
  vrf removed
    address-family ipv4 unicast
      redistribute direct route-map internal
      redistribute static route-map internal
    neighbor 10.144.200.134 remote-as xxx
      password 3 xxx
      address-family ipv4 unicast
        soft-reconfiguration inbound
    neighbor 10.144.200.242 remote-as xxx
      password 3 xxx
      shutdown
      address-family ipv4 unicast
        soft-reconfiguration inbound
    neighbor 10.145.200.1 remote-as xxx
      password 7 removed
      address-family ipv4 unicast
        soft-reconfiguration inbound
  vrf removed
    address-family ipv4 unicast
      redistribute direct route-map internal
      redistribute static route-map internal
    neighbor 10.146.200.134 remote-as xxx
      password 3 xxx
      address-family ipv4 unicast
        soft-reconfiguration inbound
    neighbor 10.146.200.242 remote-as xxx
      password 3 xxx
      shutdown
      address-family ipv4 unicast
        soft-reconfiguration inbound
    neighbor 10.147.200.1 remote-as xxx
      password 3 xxx
      address-family ipv4 unicast
        soft-reconfiguration inbound
  vrf removed
    address-family ipv4 unicast
      redistribute direct route-map internal
      redistribute static route-map internal
    neighbor 10.148.200.134 remote-as xxx
      password 3 xxx
      address-family ipv4 unicast
        soft-reconfiguration inbound
    neighbor 10.148.200.242 remote-as xxx
      password 3 xxx
      shutdown
      address-family ipv4 unicast
        soft-reconfiguration inbound
    neighbor 10.149.200.1 remote-as xxx
      password 3 xxx
      address-family ipv4 unicast
        soft-reconfiguration inbound
  vrf removed
    address-family ipv4 unicast
      redistribute direct route-map internal
      redistribute static route-map internal
    neighbor 10.150.200.134 remote-as xxx
      password 3 xxx
      address-family ipv4 unicast
        soft-reconfiguration inbound
    neighbor 10.150.200.242 remote-as xxx
      password 3 xxx
      shutdown
      address-family ipv4 unicast
        soft-reconfiguration inbound
    neighbor 10.151.200.1 remote-as xxx
      password 3 xxx
      address-family ipv4 unicast
        soft-reconfiguration inbound
  vrf removed
    address-family ipv4 unicast
      redistribute direct route-map internal
      redistribute static route-map internal
    neighbor 10.152.200.134 remote-as xxx
      password 3 xxx
      address-family ipv4 unicast
        soft-reconfiguration inbound
    neighbor 10.152.200.242 remote-as xxx
      password 3 xxx
      shutdown
      address-family ipv4 unicast
        next-hop-self
        soft-reconfiguration inbound
    neighbor 10.152.201.130 remote-as 65301
      bfd
      password 3 xxx
      address-family ipv4 unicast
        soft-reconfiguration inbound
    neighbor 10.152.201.134 remote-as 65301
    neighbor 10.153.200.1 remote-as xxx
      password 3 xxx
      address-family ipv4 unicast
        soft-reconfiguration inbound
monitor session 1 
  source interface Ethernet3/30 both
  destination interface Ethernet3/2
  no shut
monitor session 45 type erspan-source
  description
  erspan-id 45
  vrf default
  destination ip 10.136.21.253
  source interface Ethernet111/1/2 both
  source interface Ethernet111/1/3 both
  no shut

monitor erspan origin ip-address <loopback> global
no system auto-upgrade epld
logging server 10.10.10.67
logging server 10.10.10.68
logging source-interface loopback 1
2
  • @MikePennington Full Nexus 7010 is 85257 lines long but i'm only allowed to post 30000 and that's without fex switch interfaces. – user36472 Feb 10 '19 at 16:38
  • @MikePennington Full config with a lot of stuff truncated. – user36472 Feb 10 '19 at 16:53
3

An additional Full Nexus 6000 configuration:

version 7.0(7)N1(1)
interface breakout slot 1 port 1-12 map 10g-4x
interface breakout slot 2 port 1-12 map 10g-4x

hostname removed

feature telnet
feature tacacs+
cfs eth distribute
feature bgp
feature pbr
feature udld
feature interface-vlan
feature hsrp
feature lacp
feature dhcp
feature vpc
feature lldp
feature vtp
feature fex
feature bfd

username admin password 5 xxx  role network-admin

banner motd #Nexus 6000 Switch
#

ip domain-lookup
tacacs-server key 7 xxx
ip tacacs source-interface loopback1
tacacs-server host 10.10.6.165
tacacs-server host 10.10.2.130
aaa group server tacacs+ tacacs
  server 10.10.6.165
  server 10.10.2.130
  use-vrf management
ip access-list xxx-GW
  10 permit ip 10.187.1.92/32 any
  20 permit icmp 10.187.1.92/32 any
  30 permit ip 10.10.248.66/32 any
  40 permit icmp 10.10.248.66/32 any
  50 permit icmp 10.10.248.66/32 any log
ip access-list permit-any
  10 permit ip any any
ip access-list xxx-mobil
  statistics per-entry
  10 permit tcp 10.8.204.0/23 10.156.180.20/32 eq 13010
  20 permit tcp 10.8.204.0/23 10.156.180.20/32 eq 14010
  30 permit ip 10.8.204.0/24 any
  40 permit ip 10.8.205.0/24 any
  50 permit ip 10.8.206.0/24 any
  60 permit ip 10.8.207.0/24 any
ip access-list xxx-mobil-out
  statistics per-entry
  10 permit ip any 10.8.204.0/24
  20 permit ip 10.32.24.235/24 10.8.205.80/32
  30 permit ip any 10.8.205.0/24
  40 permit ip any 10.8.206.0/24
  50 permit ip any 10.8.207.0/24
vtp mode transparent
fex 102
  pinning max-links 1
  description removed
fex 103
  pinning max-links 1
  description removed
fex 109
  pinning max-links 1
  description removed
fex 112
  pinning max-links 1
  description removed
fex 113
  pinning max-links 1
  description removed
fex 117
  pinning max-links 1
  description removed
fex 118
  pinning max-links 1
  description removed
fex 120
  pinning max-links 1
  description removed
fex 123
  pinning max-links 1
  description removed
fex 125
  pinning max-links 1
  description removed
fex 126
  pinning max-links 1
  description removed
fex 129
  pinning max-links 1
  description removed
fex 133
  pinning max-links 1
  description removed
fex 188
  pinning max-links 1
  description removed
fex 189
  pinning max-links 1
  description removed
fex 198
  pinning max-links 1
  description removed
fex 199
  pinning max-links 1
  description removed
bfd interval 250 min_rx 250 multiplier 3
bfd echo-interface loopback1
snmp-server contact who@where
snmp-server location this is the location
snmp-server user admin network-admin auth md5 md5-password priv priv-password localizedkey
rmon event 1 log trap public description FATAL(1) owner PMON@FATAL
rmon event 2 log trap public description CRITICAL(2) owner PMON@CRITICAL
rmon event 3 log trap public description ERROR(3) owner PMON@ERROR
rmon event 4 log trap public description WARNING(4) owner PMON@WARNING
rmon event 5 log trap public description INFORMATION(5) owner PMON@INFO
snmp-server community rAti05 group network-operator
snmp-server community psk79RTN group network-admin
ntp server 10.10.10.10 prefer
ntp source-interface mgmt0
aaa authentication login default group tacacs

ip route 10.217.0.0/16 10.2.10.10 name RSD-DMZ
vlan 1
-- Layer 2 VLANs removed --

spanning-tree pathcost method long
-- Spanning-tree VLAN priority removed -- 
route-map MED0 permit 10
  set metric 0
route-map MED100 permit 10
  set metric 100
route-map MED200 permit 10
  set metric 200
route-map xxx-GW pbr-statistics
route-map xxx-GW permit 10
  match ip address xxx-GW
  set ip default next-hop verify-availability 10.2.10.10
route-map internal permit 10
  match ip address permit-any
service dhcp
ip dhcp relay
vrf context removed
routes removed
vrf context removed
vrf context removed
vrf context removed
vrf context removed
vrf context removed
vrf context removed
vrf context removed
vrf context removed
vrf context removed
vrf context removed
vrf context removed
vrf context removed

vrf context management
  ip route 0.0.0.0/0 10.136.201.244
vpc domain 10
  role priority 1000
  peer-keepalive destination <neighbor IP> source <local IP>
  delay restore 150
  peer-gateway
  ip arp synchronize
port-profile type ethernet vmware
  switchport mode trunk
  spanning-tree port type edge trunk
  switchport trunk allowed vlan removed
  state enabled
port-profile type ethernet access
  spanning-tree port type edge
  state enabled


interface Vlan1
  description removed
  no shutdown
  vrf member removed
  ip address 192.168.253.253/24
  hsrp 0
    authentication text HSRPA
    preempt delay reload 180
    priority 105
    timers msec 250 msec 750
    ip 192.168.253.1

interface Vlan6
  vrf member removed
  ip address 10.10.180.253/29
  hsrp 0
    preempt delay reload 180
    priority 105
    timers msec 250 msec 750

interface Vlan10
  description removed
  no shutdown
  vrf member removed
  ip address 10.2.0.253/21
  hsrp 0
    authentication text HSRPA
    preempt delay reload 180
    priority 105
    timers msec 250 msec 750
    ip 10.2.0.1

interface Vlan30
  description removed
  no shutdown
  vrf member removed
  no ip redirects
  ip address 10.2.8.2/21
  ip address xx.xx.224.6/24 secondary
  ip address xx.xx.224.253/24 secondary
  ip policy route-map xxx-GW
  hsrp 0
    authentication text HSRPA
    preempt delay reload 180
    priority 105
    timers msec 250 msec 750
    ip 10.2.8.1
    ip xx.xx.224.1 secondary
    ip xx.xx.224.5 secondary
  ip dhcp relay address xx.xx.5.10
  ip dhcp relay address xx.xx.5.10
  ip dhcp relay address 10.45.174.200

interface Vlan55
  description removed
  no shutdown
  vrf member removed
  no ip redirects
  ip address 10.128.2.253/24
  hsrp 0
    authentication text HSRPA
    preempt delay reload 180
    priority 105
    timers msec 250 msec 750
    ip 10.128.2.1

interface Vlan60
  description removed
  no shutdown
  vrf member removed
  ip address 10.217.0.4/24
  hsrp 2
    authentication text HSRPAUTH
    preempt delay reload 180
    priority 105
    timers msec 250 msec 750
    ip 10.217.0.6

interface Vlan61
  description removed
  no shutdown
  vrf member removed
  ip address 10.217.1.4/24
  hsrp 2
    authentication text HSRPAUTH
    preempt delay reload 180
    priority 105
    timers msec 250 msec 750
    ip 10.217.1.6

interface Vlan85
  description removed
  no shutdown
  vrf member removed
  ip address 10.217.25.5/24
  hsrp 0
    preempt delay reload 180
    priority 105
    timers msec 250 msec 750
    ip 10.217.25.4

-- interface vlans truncated -- 


interface Vlan3809
  description removed
  no shutdown
  vrf member removed
  no ip redirects
  ip address 10.173.209.3/24
  hsrp 2
    authentication text HSRPAUTH
    preempt delay reload 180
    priority 105
    timers msec 250 msec 750
    ip 10.173.209.1
  ip dhcp relay address xx.xx.5.10
  ip dhcp relay address xx.xx.5.10
  ip dhcp relay address 10.45.174.200

interface port-channel50
  description removed
  switchport mode trunk
  spanning-tree port type network
  vpc peer-link

interface port-channel100
  description removed
  switchport mode trunk
  switchport trunk allowed vlan 79,301,304-306,3801
  vpc 100

interface port-channel102
  description removed
  switchport mode fex-fabric
  fex associate 102

interface port-channel103
  description removed
  switchport mode fex-fabric
  fex associate 103

-- fex port-channels removed --

interface port-channel3231
  description removed
  switchport mode trunk
  switchport trunk allowed vlan 2004,2240
  vpc 3231

interface port-channel3232
  description removed
  switchport mode trunk
  switchport trunk allowed vlan 2004,2240
  vpc 3232

-- vpc port-channels removed --

interface port-channel3993
  description removed
  switchport mode trunk
  switchport trunk allowed vlan 2015,2248
  spanning-tree port type edge trunk
  vpc 3993

interface Ethernet1/1/1
  description removed
  switchport mode fex-fabric
  fex associate 198
  channel-group 198

interface Ethernet1/1/2
  description removed
  switchport mode fex-fabric
  fex associate 198
  channel-group 198

interface Ethernet1/1/3
  description removed
  switchport mode fex-fabric
  fex associate 199
  channel-group 199

interface Ethernet1/1/4
  description removed
  switchport mode fex-fabric
  fex associate 199
  channel-group 199

interface Ethernet1/2/1
  description removed
  no switchport

interface Ethernet1/2/1.1
  description removed
  encapsulation dot1q 3221
  ip address 10.137.201.3/29

interface Ethernet1/2/1.2
  description removed
  encapsulation dot1q 3223
  vrf member removed
  ip address 10.139.201.3/29

interface Ethernet1/2/1.3
  description removed
  encapsulation dot1q 3225
  vrf member removed
  ip address 10.141.201.3/29

interface Ethernet1/2/1.4
  description removed
  encapsulation dot1q 3227
  vrf member removed
  ip address 10.143.201.3/29

interface Ethernet1/2/1.5
  description removed
  encapsulation dot1q 3229
  vrf member removed
  ip address 10.145.201.3/29

interface Ethernet1/2/1.6
  description removed
  encapsulation dot1q 3231
  vrf member removed
  ip address 10.147.201.3/29

interface Ethernet1/2/1.7
  description removed
  encapsulation dot1q 3233
  vrf member removed
  ip address 10.149.201.3/29

interface Ethernet1/2/1.8
  description removed
  encapsulation dot1q 3235
  vrf member removed
  ip address 10.151.201.3/29

interface Ethernet1/2/1.9
  description removed
  encapsulation dot1q 3237
  vrf member removed
  ip address 10.153.201.3/29

interface Ethernet1/2/1.10
  description removed
  encapsulation dot1q 3239
  vrf member removed
  ip address 10.155.201.3/29

interface Ethernet1/2/1.85
  description removed
  encapsulation dot1q 3241
  vrf member removed
  ip address 10.xx.xx.3/29

interface Ethernet1/2/1.86
  description removed
  encapsulation dot1q 3243
  vrf member removed
  ip address 10.163.201.3/29

interface Ethernet1/2/2
  description removed
  shutdown
  switchport mode fex-fabric
  fex associate 112
  channel-group 112

interface Ethernet1/2/3
  description removed
  shutdown
  switchport mode fex-fabric
  fex associate 112
  channel-group 112

interface Ethernet1/2/4
  description removed
  shutdown
  switchport mode fex-fabric
  fex associate 112
  channel-group 112

interface Ethernet1/3/1
  description removed
  switchport mode trunk
  spanning-tree port type network

interface Ethernet1/3/2
  description removed
  switchport mode fex-fabric
  fex associate 113
  channel-group 113

interface Ethernet1/3/3
  description removed
  switchport mode trunk
  channel-group 3151 mode active

interface Ethernet1/3/4
  description removed
  switchport mode trunk
  channel-group 3151 mode active

interface Ethernet1/4/1
  description removed
  switchport mode fex-fabric
  fex associate 123
  channel-group 123

interface Ethernet1/4/2
  description removed
  switchport mode fex-fabric
  fex associate 123
  channel-group 123

interface Ethernet1/4/3
  description removed
  switchport mode fex-fabric
  fex associate 123
  channel-group 123

interface Ethernet1/4/4
  description removed
  switchport mode fex-fabric
  fex associate 123
  channel-group 123

interface Ethernet1/5/1
  description removed
  switchport mode fex-fabric
  fex associate 118
  channel-group 118

interface Ethernet1/5/2
  description removed
  switchport mode fex-fabric
  fex associate 118
  channel-group 118

interface Ethernet1/5/3
  description removed
  switchport mode fex-fabric
  fex associate 118
  channel-group 118

interface Ethernet1/5/4
  description removed
  switchport mode fex-fabric
  fex associate 118
  channel-group 118

interface Ethernet1/6/1
  description removed
  switchport mode fex-fabric
  fex associate 126
  channel-group 126

interface Ethernet1/6/2
  description removed
  switchport mode fex-fabric
  fex associate 126
  channel-group 126

interface Ethernet1/6/3
  description removed
  switchport mode fex-fabric
  fex associate 126
  channel-group 126

interface Ethernet1/6/4
  description removed
  switchport mode fex-fabric
  fex associate 126
  channel-group 126

interface Ethernet1/7/1
  description removed
  switchport mode fex-fabric
  fex associate 109
  channel-group 109

interface Ethernet1/7/2
  description removed
  switchport mode fex-fabric
  fex associate 109
  channel-group 109

interface Ethernet1/7/3
  description removed
  switchport mode fex-fabric
  fex associate 109
  channel-group 109

interface Ethernet1/7/4
  description removed
  switchport mode fex-fabric
  fex associate 109
  channel-group 109

interface Ethernet1/8/1
  description removed
  switchport mode fex-fabric
  fex associate 120
  channel-group 120

interface Ethernet1/8/2
  description removed
  switchport mode fex-fabric
  fex associate 120
  channel-group 120

interface Ethernet1/8/3
  description removed
  switchport mode fex-fabric
  fex associate 120
  channel-group 120

interface Ethernet1/8/4
  description removed
  switchport mode fex-fabric
  fex associate 120
  channel-group 120

interface Ethernet1/9/1
  description removed
  switchport mode fex-fabric
  fex associate 103
  channel-group 103

interface Ethernet1/9/2
  description removed
  switchport mode fex-fabric
  fex associate 103
  channel-group 103

interface Ethernet1/9/3
  description removed
  switchport mode fex-fabric
  fex associate 103
  channel-group 103

interface Ethernet1/9/4
  description removed
  switchport mode fex-fabric
  fex associate 103
  channel-group 103

interface Ethernet1/10/1
  description removed
  switchport mode trunk
  switchport trunk allowed vlan 30,50-85,100-105,172,701,998,2002-2003,2248,2251,2254
  spanning-tree port type normal
  speed 1000

interface Ethernet1/10/2
  description removed
  shutdown

interface Ethernet1/10/3
  description removed
  shutdown

interface Ethernet1/10/4
  description removed
  shutdown

interface Ethernet1/11/1
  description removed
  switchport mode trunk
  switchport trunk allowed vlan 14-17,51,79,84,100-101,104-105,150,200,320-324,500-599,3056,3081,3085,3091,3700-3701,3800-3801
  spanning-tree port type network

interface Ethernet1/11/2
  description removed
  shutdown

interface Ethernet1/11/3
  description removed
  shutdown

interface Ethernet1/11/4
  description removed
  shutdown

interface Ethernet1/12/1
  description removed
  no cdp enable
  switchport access vlan 150
  spanning-tree port type edge
  speed 1000

interface Ethernet1/12/2
  description removed
  shutdown

interface Ethernet1/12/3
  description removed
  shutdown

interface Ethernet1/12/4
  description removed
  shutdown

-- mod 2/3/4 removed --

interface mgmt0
  vrf member management
  ip address 10.136.201.241/29

interface loopback1
  ip address 10.136.201.253/32

-- Fex Switch interfaces truncated --

clock timezone europe 1 0
clock summer-time CEST 5 Sun Mar 02:00 5 Sun Oct 03:00 60
cli alias name wr copy run start
cli alias name t1 telnet 10.136.201.241 vrf management
cli alias name t2 telnet 10.136.201.242 vrf management
cli alias name q exit
line console
line vty
boot kickstart bootflash:/n6000-uk9-kickstart.7.1.4.N1.1.bin
boot system bootflash:/n6000-uk9.7.1.4.N1.1.bin
router bgp 65301
  router-id 10.136.200.254
  log-neighbor-changes
  address-family ipv4 unicast
    redistribute direct route-map internal
    redistribute static route-map internal
  neighbor 10.136.201.242 remote-as 65301
    password removed
    address-family ipv4 unicast
      soft-reconfiguration inbound
  neighbor 10.137.201.1 remote-as 65101
    password removed
    address-family ipv4 unicast
      route-map MED0 out
      soft-reconfiguration inbound
  vrf removed
    address-family ipv4 unicast
      redistribute direct route-map internal
      redistribute static route-map internal
      default-information originate
    neighbor 10.138.201.129 remote-as 65300
      bfd
      password removed
      address-family ipv4 unicast
        soft-reconfiguration inbound
    neighbor 10.138.201.242 remote-as 65301
      password removed
      address-family ipv4 unicast
    neighbor 10.139.201.1 remote-as 65101
      password removed
      address-family ipv4 unicast
        route-map MED0 out
        soft-reconfiguration inbound
  vrf removed
    address-family ipv4 unicast
      redistribute direct route-map internal
      redistribute static route-map internal
    neighbor 10.140.201.242 remote-as 65301
      password removed
      address-family ipv4 unicast
        soft-reconfiguration inbound
    neighbor 10.141.201.1 remote-as 65101
      password removed
      address-family ipv4 unicast
        route-map MED0 out
        soft-reconfiguration inbound
  vrf removed
    address-family ipv4 unicast
      redistribute direct route-map internal
      redistribute static route-map internal
      default-information originate
    neighbor 10.142.201.242 remote-as 65301
      password removed
      address-family ipv4 unicast
        soft-reconfiguration inbound
    neighbor 10.143.201.1 remote-as 65101
      password removed
      address-family ipv4 unicast
        route-map MED0 out
        next-hop-self
        soft-reconfiguration inbound
  vrf removed
    address-family ipv4 unicast
      redistribute direct route-map internal
      redistribute static route-map internal
      default-information originate
    neighbor 10.144.201.242 remote-as 65301
      password removed
      address-family ipv4 unicast
        soft-reconfiguration inbound
    neighbor 10.145.201.1 remote-as 65101
      password removed
      address-family ipv4 unicast
        route-map MED0 out
        soft-reconfiguration inbound
  vrf removed
    address-family ipv4 unicast
      redistribute direct route-map internal
      redistribute static route-map internal
    neighbor 10.146.201.242 remote-as 65301
      password removed
      address-family ipv4 unicast
        soft-reconfiguration inbound
    neighbor 10.147.201.1 remote-as 65101
      password removed
      address-family ipv4 unicast
        route-map MED0 out
        soft-reconfiguration inbound
  vrf removed
    address-family ipv4 unicast
      redistribute direct route-map internal
      redistribute static route-map internal
    neighbor 10.148.201.242 remote-as 65301
      password removed
      address-family ipv4 unicast
        soft-reconfiguration inbound
    neighbor 10.149.201.1 remote-as 65101
      password removed
      address-family ipv4 unicast
        route-map MED0 out
        soft-reconfiguration inbound
  vrf removed
    address-family ipv4 unicast
      redistribute direct route-map internal
      redistribute static route-map internal
      default-information originate
    neighbor 10.150.201.242 remote-as 65301
      password removed
      address-family ipv4 unicast
        soft-reconfiguration inbound
    neighbor 10.151.201.1 remote-as 65101
      password removed
      address-family ipv4 unicast
        route-map MED0 out
        soft-reconfiguration inbound
  vrf removed
    address-family ipv4 unicast
      redistribute direct route-map internal
      redistribute static route-map internal
    neighbor 10.152.201.129 remote-as 65300
      bfd
      password removed
      address-family ipv4 unicast
        soft-reconfiguration inbound
    neighbor 10.152.201.242 remote-as 65301
      password removed
      address-family ipv4 unicast
        next-hop-self
        soft-reconfiguration inbound
    neighbor 10.153.201.1 remote-as 65101
      password removed
      address-family ipv4 unicast
        route-map MED0 out
        soft-reconfiguration inbound
  vrf removed
    address-family ipv4 unicast
      redistribute direct route-map internal
      redistribute static route-map internal
      default-information originate
    neighbor 10.154.201.242 remote-as 65301
      password removed
      address-family ipv4 unicast
        soft-reconfiguration inbound
    neighbor 10.155.201.1 remote-as 65101
      password removed
      address-family ipv4 unicast
        route-map MED0 out
        soft-reconfiguration inbound
  vrf removed
    address-family ipv4 unicast
      redistribute direct route-map internal
      redistribute static route-map internal
      default-information originate
    neighbor 10.160.201.242 remote-as 65301
      password removed
      shutdown
      address-family ipv4 unicast
        soft-reconfiguration inbound
    neighbor 10.xx.xx.1 remote-as 65101
      password removed
      shutdown
      address-family ipv4 unicast
        route-map MED0 out
        soft-reconfiguration inbound
  vrf removed
    address-family ipv4 unicast
      redistribute direct route-map internal
      redistribute static route-map internal
      default-information originate
    neighbor 10.xx.xx.242 remote-as 65301
      password removed
      address-family ipv4 unicast
        soft-reconfiguration inbound
    neighbor 10.163.201.1 remote-as 65101
      password removed
      address-family ipv4 unicast
        route-map MED0 out
        soft-reconfiguration inbound
monitor session 1 
  source interface port-channel3982 both
  source vlan 3503 
  destination interface Ethernet2/12/1
  no shut
monitor session 2 
  source vlan 2106 
logging server 10.10.248.67
logging server 10.10.254.235
logging server 10.10.15.12
logging server 10.10.248.66
logging source-interface loopback1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.