1

Router0 has 1 subinterface on gi0/0 and can't get a ip trough dhcp. Is there something I forgot?

The configs:

Router0(got no ip from dhcp):

interface GigabitEthernet0/0
 ip address dhcp
 duplex auto
 speed auto

interface GigabitEthernet0/0.1
 encapsulation dot1Q 1 native
 ip address 192.168.1.254 255.255.255.0

interface Vlan1
 no ip address
 shutdown

Router1(got ip from dhcp):

interface GigabitEthernet0/0
 ip address dhcp
 duplex auto
 speed auto

interface Vlan1
 no ip address
 shutdown

Network

4

You cannot have two interfaces in the router with addresses in the same network. You didn't define a different VLAN for GigabitEthernet0/0 than the native VLAN, so it will try to get an address in the native VLAN, but you have that defined on GigabitEthernet0/0.1. Routers route traffic between networks, not from a network back to the same network, so your interfaces must be in different networks.

-1

The ports of a router can not be on same subnets

that's why your second port can not get ip from dhcp

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.