0

I need help for IPSec tunnel. Currently, I am working on a small task to create remote access between my laptop and office router, in order to access the office LAN network. IPSec tunnel is working fine but the LAN to LAN communication is not working ok (I am unable to access any LAN network in my office). Although I am able to ping the LAN Gateway which is configured on the same router, I am not able to access the server connected to the router on the same interface. On the server side, there is a default gateway which is 192.168.1.1 and I have ping the server IP (192.168.1.137) with loopback address which wasn't from the same subnet and its working fine. Can someone help me out?

My Configurations details are mentioned below.

  • --> Ping from Home to GW is working fine after IPSEc formation
  • --> Ping from temporary IP from loopback is working fine which means end system is configured with default gateway.
  • --> This is the configured topology

Servers ----> Switch ----> Router |||||_____Internet_____||||| (Home Desktop System)

HR-1#show running-config 
Building configuration...

Current configuration : 3789 bytes
!
! Last configuration change at 08:26:23 ACST Thu Feb 28 2019 by user34
!
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname HR-1
!
boot-start-marker
boot-end-marker
!

ip cef
!
!
!
ip dhcp excluded-address 192.168.1.1 192.168.1.99
ip dhcp excluded-address 192.168.1.199 192.168.1.254
!
ip dhcp pool Server_Form
 network 192.168.1.0 255.255.255.0
 default-router 192.168.1.1
 dns-server 8.8.8.8 8.8.4.4
 option 66 ascii 
 lease infinite
!
!
!
ip domain name HR-1.com.bh

no ipv6 cef
!
!
multilink bundle-name authenticated
! 
!
!
!
!
crypto isakmp policy 10
 encr 3des
 authentication pre-share
 group 2
!
crypto isakmp keepalive 30 20 periodic
!
crypto isakmp client configuration group HomeVPN
 key XXXXXXXX
 pool vpn-client
 acl 108
crypto isakmp profile vpnclient
   match identity group HomeVPN
   client authentication list userauthen
   isakmp authorization list groupauthor
   client configuration address respond
   virtual-template 1
!
!
crypto ipsec transform-set myset3 esp-3des esp-md5-hmac 
 mode tunnel
!
crypto ipsec profile HomeVPN
 set transform-set myset3 
 set isakmp-profile vpnclient
!
!
!
!
!
!
!
interface Loopback100
 ip address 10.192.168.1 255.255.255.0
!
interface GigabitEthernet0/0
 description -----WAN LINK ----
 ip address 37.131.254.1 255.255.255.252
 ip access-group InternetOut out
 ip nat outside
 ip flow ingress
 ip tcp adjust-mss 1200
 media-type rj45
 speed auto
 duplex full
 no negotiation auto
!
interface GigabitEthernet0/1
 description ------Connection Server Form --------
 ip address 192.168.1.1 255.255.255.0
 ip nat inside
 ip flow ingress
 media-type rj45
 speed auto
 duplex full
 no negotiation auto

!
interface Virtual-Template1 type tunnel
 ip unnumbered GigabitEthernet0/1
 no ip redirects
 ip nat inside
 ip flow ingress
 ip tcp adjust-mss 1280
 tunnel mode ipsec ipv4
 tunnel protection ipsec profile HomeVPN
!
ip local pool vpn-client 10.10.10.10 10.10.10.20
ip nat inside source list NAT interface GigabitEthernet0/0 overload
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
ip route 0.0.0.0 0.0.0.0 37.131.254.1
ip route 10.10.10.0 255.255.255.0 Null0
!
ip access-list extended InternetOut
 permit ip host 37.131.94.35 any
 permit ip host 10.10.10.17 any
 permit ip any any reflect Internet timeout 300
ip access-list extended NAT
 permit ip 192.168.1.0 0.0.0.255 any
ip access-list extended encrypt-to-vpn-clients
 permit ip 192.168.1.0 0.0.0.255 any
!
access-list 108 permit ip 192.168.1.0 0.0.0.255 10.10.10.0 0.0.0.255
!
snmp-server community public RO
!
!
!
control-plane
!
!
line con 0
 stopbits 1
line aux 0
 stopbits 1
line vty 0 4
 transport input all
!
!
end

HR-1#    
  • Hi when ever I add, it doesnt show me in a proper format. – Muhammad Usman Feb 28 at 4:27
  • When you include something like the configuration, use the Preformatted-text option ({}). – Ron Maupin Feb 28 at 4:28
  • Still not working. – Muhammad Usman Feb 28 at 4:29
  • Just highlight the text and press the Preformatted-text button ({}). – Ron Maupin Feb 28 at 4:29
  • I did it, but it is stil showing – Muhammad Usman Feb 28 at 4:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.