0

The Workflow for Deploying Segment Routing according to this is the following:

  1. Configure the Segment Routing Global Block (SRGB) Enable Segment;
  2. Routing and Node SID on the IGP Configure Segment Routing on the BGP;
  3. Configure the SR-TE Policy;
  4. Configure TI-LFA Configure the Segment;
  5. Routing Mapping Server Collect Traffic Statistics;

I'm using as instance test 2 Cisco IOS XR Software XRv9000 Version 6.4.1 routers deployed in Cisco Sandbox.

I could configure the steps 1 and 2 which are explained in Configure SRGB and SRLB Configure SR for OSPF Protocol respectively. Then, I directly configured SR-TE policies in R1-XRv9000 because the policies should be configured only in Head-end

The full configuration of both routers is shown here

Has anybody tried to implement SR before? The steps which I followed might be wrong.

Configuration:

———————————————————————————————————————————
| R1-XRv9000 full configuration with SR-TE|
———————————————————————————————————————————
interface Loopback0
 ipv4 address 1.1.1.1 255.255.255.252
!
interface tunnel-ip30
 ipv4 address 10.10.1.1 255.255.255.252
 tunnel mode gre ipv4
 tunnel source MgmtEth0/RP0/CPU0/0
 tunnel destination 192.168.122.31
!
interface MgmtEth0/RP0/CPU0/0
 description *** MANAGEMENT INTERFACE ***
 ipv4 address dhcp
!
interface GigabitEthernet0/0/0/0
 shutdown
!
interface GigabitEthernet0/0/0/1
 shutdown
!
interface GigabitEthernet0/0/0/2
 shutdown
!
interface GigabitEthernet0/0/0/3
 shutdown
!
interface GigabitEthernet0/0/0/4
 shutdown
!
router static
 address-family ipv4 unicast
  0.0.0.0/0 192.168.122.1
 !
!
router ospf 1
 router-id 7.0.0.1
 segment-routing global-block 18000 19999
 segment-routing mpls
 segment-routing forwarding mpls
 area 0
  mpls traffic-eng
  segment-routing mpls
  interface Loopback0
   passive enable
   prefix-sid absolute 18001
  !
  interface tunnel-ip30
   network point-to-point
  !
 !
 mpls traffic-eng router-id Loopback0
!
mpls traffic-eng
!
segment-routing
 local-block 30000 30999
 traffic-eng
  segment-list list-1
   index 1 mpls label 400102
   index 2 mpls label 400202
  !
  segment-list list-2
   index 1 mpls label 400302
   index 2 mpls label 400402
  !
  policy 1
   binding-sid mpls 15001
   color 1 end-point ipv4 7.0.0.2
   candidate-paths
    preference 10
     explicit segment-list list-1
      weight 2
     !
     explicit segment-list list-2
      weight 2
     !
    !
   !
  !
 !
!
————————————————————————————————
|R2-XRv9000 full configuration |
————————————————————————————————

interface Loopback0
 ipv4 address 2.2.2.2 255.255.255.252
!
interface tunnel-ip30
 ipv4 address 10.10.1.2 255.255.255.252
 tunnel mode gre ipv4
 tunnel source MgmtEth0/RP0/CPU0/0
 tunnel destination 192.168.122.21
!
interface MgmtEth0/RP0/CPU0/0
 description *** MANAGEMENT INTERFACE ***
 ipv4 address dhcp
!
interface GigabitEthernet0/0/0/0
 shutdown
!        
interface GigabitEthernet0/0/0/1
 shutdown
!
interface GigabitEthernet0/0/0/2
 shutdown
!
interface GigabitEthernet0/0/0/3
 shutdown
!
interface GigabitEthernet0/0/0/4
 shutdown
!
router static
 address-family ipv4 unicast
  0.0.0.0/0 192.168.122.1
 !
!
router ospf 1
 router-id 7.0.0.2
 segment-routing global-block 18000 19999
 segment-routing mpls
 segment-routing forwarding mpls
 area 0
  mpls traffic-eng
  segment-routing mpls
  interface Loopback0
   passive enable
   prefix-sid absolute 18002
  !
  interface tunnel-ip30
   network point-to-point
  !
 !
 mpls traffic-eng router-id Loopback0
!
mpls traffic-eng
!
segment-routing
 local-block 30000 30999
!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.