5

I've been trying to figure out how to achieve the outcome below.

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
232  VLAN 10                        active  Fa3/0/1,Fa3/0/2,Fa3/0/3,Fa3/0/4,                               
                                            Fa3/0/5,Fa3/0/14,Fa3/0/15,

233  VLAN 20                        active  Fa3/0/1, Fa3/0/2, Fa3/0/3, 
                                            Fa3/0/4, Fa3/0/5,Fa3/0/17, 
1002 fddi-default                     act/unsup
1003 token-ring-default               act/unsup
1004 fddinet-default                  act/unsup
1005 trnet-default                    act/unsup

In short, trying to assign two VLANs to a single switchport in access mode. How is this possible?

2
  • The correct question would be what are you trying to achive with such configuration? Without knowing more about the real problem, it is unlikely to be answered. The solution proposed above is wrong.
    – user54905
    Mar 19, 2019 at 10:06
  • Did any answer help you? if so, you should accept the answer so that the question doesn't keep popping up forever, looking for an answer. Alternatively, you could post and accept your own answer.
    – Ron Maupin
    Dec 31, 2020 at 4:49

2 Answers 2

6

First of all an access port is by definition can only carry one Vlan.

Voice vlan is used, when if its actually a voice vlan traffic needed to be carried.

so lets say both vlans 232 and 233 are Data Vlans.

You have to apply like below.

interface Fa3/0/1,
switchport mode trunk
switchport trunk allowed vlan 232,233 
end

Now , Trunk mode is used carry multiple vlans (Vlan tagging).

If you don't specify the "allowed vlan" by default all the vlans created on the switch will be tagged on this interface.

And if the vlan 233 is voice vlan (used to connect IPphones).

interface Fa3/0/1
 switchport mode access
 switchport access vlan 232
 switchport voice vlan 233

Please ask if any clarifications needed.

Regards, Hazif Ismail

1
  • 1
    Feel free to add the remaining from my previous answer.
    – user36472
    Mar 18, 2019 at 15:55
0

Access port can carry only one VLAN. Your requirement of carrying multiple Vlans on access-port is not feasible .

Instead to this your requirement can be fulfilled by configured switch port with trunk link and allowing required Vlans ..

Switch(config) # int f0/1

Switch(config)#switchport mode trunk

Switch(config)#switchport trunk Allowed vlan add 10,20

Switch (config)# no shutdown

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.