5

I know that MUX-UNI can only be configure on a 7600 running certain IOS version, SR and SX I believe. Does that not include SRE?

Logged into a 7600 running 12.2(33)SRE9a, with the following configuration;

interface GigabitEthernet8/3
 description Link to a box
 no ip address
!
interface GigabitEthernet8/3.123
 description L3 link to a box
 encapsulation dot1Q 556
 ip address 10.21.225.65 255.255.255.248
!
interface GigabitEthernet8/3.456
 description PWE3 to a box
 encapsulation dot1Q 920
 xconnect 172.16.25.25 1026 encapsulation mpls
  mtu 1500

When I try to reconfigure this as a MUX-UNI interface the following happens;

r1(config-if)#int gi8/3
r1(config-if)#switchport 
Subinterfaces configured on this interface will not be available after mode change. To re-use reserved internal vlans, subinterfaces need to be deleted before changing the mode.
Proceed with the command? [confirm]

I can't find any Cisco doc's that say "yes" or "no" definitively on this.

Update:

The supervisor is a RSP720-3CXl-GE. The line card I was trying to configure is an old WS-X6516A-GBIC. But I thought this wasn't depending on the line card but the IOS. I configured another port on that line card and selected "confirm" and sure enough it shut down and removed the sub-interfaces. I tried to then configure the port as a switchport first and then add sub-interfaces but I couldn't assign an IP address to the sub-interface;

r1(config)#do show run | b 8/1
interface GigabitEthernet8/1
 switchport
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 58,59
 switchport mode trunk
!
interface GigabitEthernet8/1.58

r1(config)#int gi8/1.58
r1(config-subif)#ip ?
Interface IP configuration subcommands:
  access-group        Specify access control for packets
  admission           Apply Network Admission Control
  auth-proxy          Apply authenticaton proxy
  dhcp                Configure DHCP parameters for this interface
  header-compression  IPHC options
  rsvp                RSVP Interface Commands
  vrf                 VPN Routing/Forwarding parameters on the interface

I tried the same configuration on a different line card, WS-X6748-GE-TX, same result, couldn't configure an IP address because the option is not given under the sub-interface configuration mode.

5
  • 1
    What happens when you configure the switchport / trunking before the xconnect and subintfs? Also which supervisor / linecard models are you using? Jan 9, 2014 at 11:02
  • If you enable switchport, you make the interface a L2 interface so no IP addressing is possible. You can put IP addresses on the SVIs for vlans 58 and 59.
    – Ron Trunk
    Jan 9, 2014 at 12:29
  • Is that true for MUX-UNI though, as opposed to "regular" interfaces?
    – Baldrick
    Jan 9, 2014 at 12:35
  • @jwbensley, your update introduces another question besides the xconnect pw issue. Perhaps two questions are justified since the issues are not related Jan 9, 2014 at 12:36
  • Ah OK, so I think I have missed something here. With MUX-UNI we can't create L3 sub interface, I could create a sub-interface for an Xconnect then create SVIs for L3 access of the L2 port? Is that correct?
    – Baldrick
    Jan 9, 2014 at 12:38

1 Answer 1

5

MUX-UNI support:

It looks like you're trying to configure a MUX-UNI with:

  • A Layer3 interface on Vlan 556
  • A Vlan-mode PW on Vlan 920

The WS-X6516A is considered a Catalyst 6500 / Cisco 7600 LAN Card; LAN cards have some feature restrictions... one of the restrictions is how you configure a Layer3 interface on a LAN card with dot1q encapsulation.

When you're building a MUX-UNI combination of Pseudo-Wire services, and Layer3 services on a dot1q-trunked Catalyst 6500 LAN card, you must do the following:

  • Configure the Layer3 services on an SVI. Direct Layer3 subinterface configuration on the LAN switchports is not supported on Sup720
  • Configure the Pseudo-wire as a subinterface of the LAN card (omit the PW vlan from the dot1q trunk though.

I'll use your example...

interface GigabitEthernet8/1
 switchport
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 556
 switchport mode trunk
 switchport nonegotiate
!
interface GigabitEthernet8/1.123
 ! Configure PW-ID 1026 on Vlan 920, note that vlan-920 is *not* explicitly trunked on Gi8/1
 encapsulation dot1q 920
 xconnect 172.16.25.25 1026 encapsulation mpls
  mtu 1500
!
interface Vlan556
 no shutdown
 ! insert optional VRF configuration here
 ip address 192.0.2.254

If you use this configuration as a template, MUX-UNI will work for you.

What was wrong with your configuration

  • You tried to use a Layer3 IP subinterface directly on the switchport, which is not supported on 6500 / 7600-series LAN cards and Sup720
  • The original MUX-UNI configuration on Gi8/3 was not made a switchport first.

Catalyst6500 LAN Card IP subinterfaces

Because Catalyst6500 Vlans have a global scope throughout the chassis, LAN cards on Sup720 support a routed dot1q subinterface, as long as you have not used that same vlan elsewhere... example:

! ensure vlan 100 is unused, so we can use it on a Gi4/1 subinterface
no vlan 100
interface GigabitEthernet4/1
 no switchport
interface GigabitEthernet4/1.100
 encapsulation dot1q 100
 ip address 192.0.2.1 255.255.255.0
2
  • I would +2 if I could regarding the "what was wrong with your configuration" part, better than just giving a correct answer is how you got there :) Great work Mike Pennington, thanks for clearing this up, I think I had read a couple of difference sources that said different things and confused my self.
    – Baldrick
    Jan 9, 2014 at 17:39
  • Cisco's 6500 / 7600 series is a wonderful platform once you get used to the quirks, but it had an mpls CLI evolution over several years, which was also complicated by the feature differences between the LAN cards and WAN cards (i.e OSM, SIP-x00, or ES series). You are certainly not alone in the confusion about how to use it. Jan 9, 2014 at 18:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.