6

I have Cisco Layer 3 switch with IP routing enabled on it. I have different VLANs configured on it and its working perfectly. Now i have added another VLAN (SVI) and assigned that VLAN to one of the port , but VLAN interface is still showing "VLAN350 is down, line protocol is down". I made sure i entered "no shutdown" command on SVI and physical interface. Following is my config. Please tell me what i am doing wrong.

ip dhcp pool VLAN-350-POOL
 network 192.168.10.0 255.255.255.0
 default router 192.168.10.1
 dns-server 8.8.8.8 8.8.4.4
 lease 2

spanning-tree mode rapid-pvst
spanning-tree loopguard default
spanning-tree portfast bpduguard default
spanning-tree extend system-id
spanning-tree vlan 1,100,200,300 priority 0

interface GigabitEthernet1/9
 switchport access vlan 350
 switchport mode access
 keepalive 1
 speed 1000
 duplex full
 spanning-tree portfast

interface vlan350
ip address 192.168.10.1 255.255.255.0

I have attached a laptop to Gigabit Port 1/9 and its not getting any IP address from the pool (Since VLAN350 is still not coming up).

Any help is appreciated. Thanks.

  • Did you define the VLAN with the global vlan 350 command? Just creating the SVI doesn't actually create the VLAN. – Ron Maupin Mar 19 '19 at 17:46
  • I did not. I will try now. – Junaid Mar 19 '19 at 17:47
  • 1
    I did it and its up. Thanks a lot!!! – Junaid Mar 19 '19 at 17:49
5

Creating an SVI doesn't actually create the VLAN. You should use the global vlan command to create the VLAN. Something like:

vlan 350
 name <vlan_name>
 exit
!
| improve this answer | |
3

I'm gonna copy/paste something and the answer:

"...most common cases when troubleshooting SVI in up/down state:

  1. Make sure that the VLAN this SVI represents exists in the VLAN database.
  2. SVI has a feature called "autostate" that is enabled by default. This feature is used to bring the SVI up automatically as long as there is at least one interface in that VLAN and at least one interface is up/up. So, if an SVI is not coming up, make sure that a functional port exists in that VLAN.
  3. Sometimes, you just want to bring the SVI up without having any functional interface in the VLAN. For instance, you want to manage a switch through SVI but there is no access port needed on the switch for that VLAN (as it will pass through the trunk). In this case, make sure, that the SVI vlan is allowed through the trunk."

So, you just have to create the vlan 350 and add an active interface into it. I did a pilot for this and when the vlan was created, the SVI state changed to UP/DOWN. Then added an active interface and the SVI went UP/UP.

And if this doesn't solve your issue, let us know.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.