0

I have two routers like bellow:

in the Router1, I configured like bellow:

!
router bgp 100
 bgp log-neighbor-changes
 no synchronization
 neighbor 12.0.0.2 remote-as 200
 network 1.0.0.0 mask 255.255.255.0
 network 11.0.0.0 mask 255.255.255.0
!

and the Router2 have bellow configure:

!
router bgp 200
 bgp log-neighbor-changes
 no synchronization
!

I only executed the Router1's interface gig0/0:

neighbor 12.0.0.2 remote-as 200

I did not execute the neighbor command in Router2.

Whether there need the neighbor command in Router2 interface to Router1?


you see, in the Router1 bgp 100 I added:

network 1.0.0.0 mask 255.255.255.0
network 11.0.0.0 mask 255.255.255.0

but in the Router2 bgp 200 there do not have the routes.

3

Whether there need the neighbor command in Router2 interface to Router1?

Yes, a remote AS is required for every configured neighbor, so R2 needs to know which AS R1 uses by using the remote-as statement

but in the Router2 bgp 200 there do not have the routes.

I'm not 100% sure what you're saying here, but if you mean that R2 does not receive those routes from R1, the first thing to check is the state of the BGP session using show ip bgp summary or show ip bgp neighbor <peer IP>. I'm fairly certain that since you didn't configure a remote AS on one side, the BGP session is currently down and thus no routes are exchanged.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.