1

Just purchased the MikroTik "Cloud Router Switch" (CRS125-24G-15-2HnD-IN) with the possible misunderstanding that I could define multiple networks within the router and assign various switch ports to the various networks.

The goal is to support a small multi-node OpenStack lab and I wanted to divide the 24 ports into 3 different networks. I've never used RouterOS before and can't figure out how to do this in "WebFig".

Is this possible? If so, how?

Thanks!

1
  • yes, that is correct. it can do it, it will do wirespeed switching if you define masters and slaves.
    – rekeds
    Commented Apr 3, 2014 at 15:18

1 Answer 1

6

Assuming you don't specifically need VLANs you'd pick one port to be the master port for each group and set it to be the master port for every other port in the group. Ports with the same master port are isolated from ports with a different master port. Then you set a IP address on the master port for routing (if necessary).

For example, if you assume three groups of three ports (2-4, 5-7, 8-10) you'd do the following (note that I'm using CLI terminology so if I write /interface ethernet set master-port=ether2 where name=ether3 and you are using webfig or winbox you'd click on interface, go to the ethernet tab, click on ether3, and change the master-port option):

/interface ethernet set ether3 master-port=ether2
/interface ethernet set ether4 master-port=ether2
/interface ethernet set ether6 master-port=ether5 
/interface ethernet set ether7 master-port=ether5
/interface ethernet set ether8 master-port=ether8
/interface ethernet set ether9 master-port=ether8

/ip address add address=192.168.1.1/24 interface=ether2
/ip address add address=192.168.2.1/24 interface=ether5
/ip address add address=192.168.3.1/24 interface=ether8

Mikrotik's CRS example page has more examples along with a example if you need VLAN support. If you need routing between switch groups or VLANs be aware that per the block diagram there is only a single 1G connection between the routing engine and the switch chip.

7
  • Thanks very much for this lead. It sounds like I can switch at wire speed if I am passing traffic amongst the same network (eg if I define 8 ports in network 10.0.10.0/24 and put all my OpenStack stuff there). That sound right? Now the only thing I have to figure out is how the heck to unset a slave interface from the existing default RouterOS setup which slaves all interfaces to ether2. Right now this is what I see: failure: ether18-slave-local already in ether2-master-local
    – user132791
    Commented Jan 12, 2014 at 2:28
  • Actually I figured out how to unset: /interface ethernet set ether17 master-port=none Then you can reset to a new master port.
    – user132791
    Commented Jan 12, 2014 at 3:49
  • Yep, you should see wire speed between ports in the same group. Normally you should be able to set the master-port without unsetting it first but I have not tried it specifically on a CRS, just their other platforms. Usually I start from a blank slate with /system reset-configuration and then connect by mac address using winbox.
    – jda
    Commented Jan 12, 2014 at 4:51
  • Thanks again! Alas for me I'm really trying to avoid Winbox for a couple reasons: I don't have any devices with RS232, and I don't have a USB serial to RJ45 console cable that the CRS would need. (I'm searching for one though!), and secondly I have no Windows computers anywhere where I could do the winbox stuff. I'm creating networks on the CRS now and all seems to be working aside from some DHCP stuff but no worries there I'm sure I can figure it out. I really owe ya, man; you saved my Saturday!
    – user132791
    Commented Jan 12, 2014 at 13:18
  • 1
    Glad to help. Two things about winbox just in case. It can actually connect over raw ethernet without IP configured and it runs great in wine on OS X and Linux. That makes it a lifesaver if you don't have or forget your console cable.
    – jda
    Commented Jan 12, 2014 at 17:46

Not the answer you're looking for? Browse other questions tagged or ask your own question.