3

So I have a ASA I can connect via SSL perfectly fine receiving internet.My issue is that I cannot ping any device on the network especially the inside network on my router. My topology is a ASA 5505 - 1841 Router - 2960 switch - end devices I would like to be able to access my end devices via the VPN. Below is my ASA Config:

ASA Version 9.0(4)
!
hostname AwBTech-ASA
enable password 8Ry2YjIyt7RRXU24 encrypted
names
ip local pool VPN_POOL 192.168.10.100-192.168.10.200 mask 255.255.255.0
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 11.0.0.1 255.0.0.0
!
interface Vlan2
 nameif outside
 security-level 0
 ip address dhcp setroute
!
ftp mode passive
object network obj_any
 subnet 0.0.0.0 0.0.0.0
object network Permit_Lan_IP
 subnet 11.0.0.0 255.0.0.0
access-list SPLIT_TUNNEL standard permit 11.0.0.0 255.0.0.0
pager lines 24
logging asdm informational
mtu inside 1500
mtu outside 1500
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
no arp permit-nonconnected
nat (inside,outside) source dynamic any interface
!
object network obj_any
 nat (inside,outside) dynamic interface
timeout xlate 3:00:00
timeout pat-xlate 0:00:30
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
timeout floating-conn 0:00:00
dynamic-access-policy-record DfltAccessPolicy
user-identity default-domain LOCAL
http server enable
http 192.168.1.0 255.255.255.0 inside
http redirect outside 80
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart warmstart
crypto ipsec security-association pmtu-aging infinite
crypto ca trustpool policy
telnet timeout 5
ssh timeout 5
console timeout 0

dhcpd dns 4.2.2.2
dhcpd auto_config outside
!
dhcpd address 11.0.0.2-11.0.0.32 inside
dhcpd enable inside
!
threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
sysopt connection permit-vpn
webvpn
 enable outside
 anyconnect-essentials
 anyconnect image disk0:/anyconnect-win-2.5.2014-k9.pkg 1
 anyconnect enable
 tunnel-group-list enable
group-policy ANYCONNECT_POLICY internal
group-policy ANYCONNECT_POLICY attributes
 dns-server value 8.8.8.8
 vpn-tunnel-protocol ssl-client ssl-clientless
 split-tunnel-policy tunnelspecified
 split-tunnel-network-list value SPLIT_TUNNEL
 webvpn
  anyconnect keep-installer installed
  anyconnect dpd-interval client 30
  anyconnect ask none default anyconnect
username andrew.burger password hPmaC1bXkbJlXpLy encrypted privilege 15
username andrew.burger attributes
 service-type remote-access
tunnel-group MY_TUNNEL type remote-access
tunnel-group MY_TUNNEL general-attributes
 address-pool VPN_POOL
 default-group-policy ANYCONNECT_POLICY
tunnel-group MY_TUNNEL webvpn-attributes
 group-alias SSL_USERS enable
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum client auto
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny
  inspect sunrpc
  inspect xdmcp
  inspect sip
  inspect netbios
  inspect tftp
  inspect ip-options
!
service-policy global_policy global
prompt hostname context
no call-home reporting anonymous
Cryptochecksum:75f7cc40a6a189853de7e2f8cb472b60
: end

Router Configuration:

version 15.1
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname AwBTech-Router
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
dot11 syslog
ip source-route
!
!
ip dhcp excluded-address 192.168.0.1 192.168.0.2
ip dhcp excluded-address 192.168.0.1 192.168.0.3
!
ip dhcp pool DATA
   import all
   network 10.10.10.0 255.255.255.0
   dns-server 4.2.2.2
   default-router 10.10.10.1
!
!
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
license udi pid CISCO1841 sn FTX1044W1U4
!
redundancy
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 ip address dhcp
 ip nat outside
 ip virtual-reassembly
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 10.10.10.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly
 duplex auto
 speed auto
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
ip nat inside source list 101 interface FastEthernet0/0 overload
ip route 0.0.0.0 0.0.0.0 dhcp
!
access-list 101 permit ip 10.10.10.0 0.0.0.255 any
!
!
!
!
!
!
control-plane
!
!
line con 0
line aux 0
line vty 0 4
 login
 transport input all
!
scheduler allocate 20000 1000
end
2
  • You should include the router configuration. You may have a problem, e.g. NAT, on the router, but we cannot tell.
    – Ron Maupin
    Commented Mar 30, 2019 at 19:28
  • Did any answer help you? If so, you should accept the answer so that the question doesn't keep popping up forever, looking for an answer. Alternatively, you can provide and accept your own answer.
    – Ron Maupin
    Commented Dec 15, 2019 at 1:27

1 Answer 1

2

The problem is that your VPN terminates on the outside of the router inside-source NAT. To do what you want, you need to terminate the VPN on the inside of the router inside-source NAT.

In the case you have explained:

ASA 5505 - 1841 Router - 2960 switch - end devices

You would normally NAT on the ASA and not on the router, or you would terminate the VPN on the router or put the router outside the ASA. You should only use NAT where you actually need it, which would be between the public and private addressing.

Your problem is that the addresses inside the router inside-source NAT do not exist where the VPN terminates. Only the outside router address can be seen by the VPN end-point, and you would need specific NAT entries to allow access from the outside to the inside.


Also, the 11.0.0.018 network you use on the ASA does not belong to you, so you should not use that address range.

1
  • How would I start to do that? My apologies I just started working is Asas
    – andrewixl
    Commented Mar 30, 2019 at 20:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.