2

I'm new to the forum and I'm working on my CCNA cert. I received a 2600 Router last week and it boots but only into ROM mode. It appears it needs more memory to run the current image. Besides adding more memory, how can I resolve this issue? Below is the startup sequence:

System Bootstrap, Version 12.2(10r)1, RELEASE SOFTWARE (fc1)
TAC Support: http://www.cisco.com/tac
Copyright (c) 2002 by cisco Systems, Inc.
C2600 platform with 32768 Kbytes of main memory

program load complete, entry point: 0x80008000, size: 0xa29528
Self decompressing the image : #################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################### [OK]

Smart Init is enabled
smart init is sizing iomem
  ID            MEMORY_REQ                 TYPE
0000A2          0X0010A400 C2600 Dual Fast Ethernet
0036EE            UNKNOWN                  AIM
                0X000F34A8 public buffer pools
                0X00211000 public particle pools
TOTAL:          0X0040E8A8

If any of the above Memory Requirements are
"UNKNOWN", you may be using an unsupported
configuration or there is a software problem and
system operation may be compromised.
Rounded IOMEM up to: 5Mb.

 Not enough memory in the system to run this image
 Required pmem/iomem: 38927045/524288
*** System received a Software forced crash ***
signal= 0x17, code= 0x200, context= 0x80005f94
PC = 0xffffffff, Vector = 0x200, SP = 0xffffffff

System Bootstrap, Version 12.2(10r)1, RELEASE SOFTWARE (fc1)
TAC Support: http://www.cisco.com/tac
Copyright (c) 2002 by cisco Systems, Inc.
C2600 platform with 32768 Kbytes of main memory

program load complete, entry point: 0x80008000, size: 0xa29528
Self decompressing the image : #################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################### [OK]

Smart Init is enabled
smart init is sizing iomem
  ID            MEMORY_REQ                 TYPE
0000A2          0X0010A400 C2600 Dual Fast Ethernet
0036EE            UNKNOWN                  AIM
                0X000F34A8 public buffer pools
                0X00211000 public particle pools
TOTAL:          0X0040E8A8

If any of the above Memory Requirements are
"UNKNOWN", you may be using an unsupported
configuration or there is a software problem and
system operation may be compromised.
Rounded IOMEM up to: 5Mb.

 Not enough memory in the system to run this image
 Required pmem/iomem: 38927045/524288
*** System received a Software forced crash ***
signal= 0x17, code= 0x200, context= 0x80005f94
PC = 0xffffffff, Vector = 0x200, SP = 0xffffffff

System Bootstrap, Version 12.2(10r)1, RELEASE SOFTWARE (fc1)
TAC Support: http://www.cisco.com/tac
Copyright (c) 2002 by cisco Systems, Inc.
C2600 platform with 32768 Kbytes of main memory

rommon 1 >

Thanks in advance!

  • 1
    You can try to find an older sw version. 2600 routers are at least 15 years old. Sw images were much smaller then. – Ron Trunk Apr 7 at 23:37
  • Thanks! I was hoping that would be the case. I'm so new to this, what would be the best way to obtain and install an older version of IOS? I'm using a wireless laptop connected to the router using a console cable. Thanks! – ITguy Apr 7 at 23:42
  • I found out a few more details about my router. It's a 2621 with 32mb of memory. I have went to the cisco website to look for an older version of my IOS but there are so many options I'm not sure which one would work. Any guidance on how to downgrade my IOS? Also, can it be downgraded using the console cable or will I need to use a different connection type? Thanks! – ITguy Apr 8 at 0:09
  • is this for simulation software? – infra Apr 8 at 3:11
  • This is for a home lab. I bought it online and it appears the IOS requires more memory to work. I took it apart and saw it has two 16mb memory sticks in it. I cannot figure out where to get an older IOS version and install it to see if it fixes the problem. I have just started my cert. studying and ran into this issue. – ITguy Apr 8 at 3:56
1

According to: "Cisco 2600 Series Modular Access Routers":

Cisco 2620 and Cisco 2621XM:

  • Minimum Cisco IOS Software Release

    12.1(14) Mainline, 12.2(12) Mainline, 12.2(8)T1, or later

  • Maximum IOS Software Level

    12.4(15)T

Cisco's software download center shows the category, but I don't see the download or a means to navigate to it on my phone's browser.

Their webpage: "Cisco IOS Software Releases 12.3 Mainline - Retirement Notification" says it went EOL in 2012.

NetworkLab has an article: "CCNA lab – 2600’s and 1800’s" wherein I believe that they hint that if you can find another one, you can copy the firmware from one to another similar model. They also explain performing a memory upgrade on the site.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.