3

What's irb meaning? and what's the difference between vlan?

I found some Junos version the vlan l3-interfaces should be vlan.xxx, and some times there is irb.xxx.

enter image description here

irb {
    unit 0 {
        family inet;
    }
    unit 2 {
        family inet {
            address 10.10.10.254/24;
        }
    }
    unit 9 {
        family inet {
            address 1.1.1.14/29;
        }
    }
    unit 10 {
        family inet {
            address 1.1.1.22/29;
        }
    }
    unit 11 {
        family inet {
1
  • Please, never use an image for text. Simply copy the text and paste it into the question using the Preformatted-text feature ({}).
    – Ron Maupin
    Apr 14 '19 at 4:42
1

Enhanced Layer-2 Switching (ELS)

Juniper has a couple of different product lines (routers, switches, firewalls) that theoretically run the same operating system (Junos). However, software for these product lines is developed separately from each other, and as a result the configuration syntax for similar features (mainly layer-2 stuff) ended up being different on routers (MX platform) and switches (EX platform). This is obviously a bit confusing for people running both types of devices.

In 2013, Juniper introduced a new configuration syntax for EX switches (starting with Junos 13.2) to remedy this: Enhanced Layer-2 Software (ELS). This syntax is similar to the syntax used on MX routers. One of the changes in the new syntax is renaming vlan interfaces from vlan.xx to irb.xx. You can find a complete list of all changes on the juniper.net website.

In general, older EX switches (EX-2200, EX-3300, EX-4200, ...) still use the old style configuration syntax. Newer devices (EX-2300, EX-4300, ...) use the new syntax. The same is true for branch SRX firewalls: SRX-2xx uses the old style, SRX-3xx uses ELS syntax. Check the Juniper Feature Explorer for an authoritative list of all devices and software releases that use the ELS syntax.

Integrated Routing and Bridging (IRB)

Integrated Routing and Bridging (IRB) is a pretty common term used by both Cisco and Juniper for layer-3 VLAN interfaces. Other terms for pretty much the same concept are:

  • VLAN interface
  • Routed VLAN interface (RVI)
  • Bridge-Group Virtual Interface (BVI)
2

Juniper introduced a new "variant" of JunOS for some devices and called it ELS (Enhanced Layer 2 Software). The idea is to unify the CLI syntax between different platforms running Junos. This changed the syntax for a few commands, including switching from vlan to irb for virtual L3 interfaces. This is the same syntax that is used for Juniper router platforms. There is also a list of changes for the ELS CLI.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.