5

I work at a school district that has about 1000 students that is split into two buildings. In our junior high/high school building, we have about 300 student laptops with about 25 teachers that each have a laptop and most also have a desktop with a wireless connection.

Our elementary building has about 200 student laptops and another 20 teacher laptops.

Here is our problem. All year we have had a seemingly sporadically slow network. At certain periods of the day, things become very bogged down, people begin losing their connections often...it's a nightmare.

We started with a Ubiquiti Unifi wireless system with full building coverage in both buildings and netgear GS748TPS, 748TP, and 724TPS switches. The entire wireless system is built on a cat 6 infrastructure.

If a teacher laptop is connected to an access point, everything is fine. When a jr high or high school student connects to an access point and tries to do anything over the network (pulling files from the file server, udp desktop monitoring traffic) except for http access, ping times for everybody on that access point, including teachers, skyrockets into the thousands.

In the elementary building, there is not a single problem with any connections or ping times. If I ping from the high school to a laptop in the elementary school 8 miles away, I get an average of 1ms ping times.

We have tried removing any software that could create an issue, we have tried removing all startup programs, we have replaced access points to see if it was a bad access point, we have replaced the POE adapters, we have replaced the ends on the cable runs, we have tried reverting everything from the netgear switches to our old HP Procurve 2810-48g switches and removing the netgears entirely, we have tried removing the Unifi access points and putting our HP Procurve wireless system back into production, we have tried any version of the wireless driver driver for that particular laptop that we can find.

None of these issues happened at all last year, but it has been non stop this year and it is severely detrimental to any classroom activities. We also have standardized testing coming up.

I am pretty much at a loss as to what else could possibly be causing the problem and am very open to any and all suggestions and recommendations. Please let me know if there are any resources that would help out.

  • I feel like something is missing here - what's the distinction between "teacher" and "student" laptops? Does this happen in the incidence of every single student, or just one particular student? – Panther Modern Jan 15 '14 at 20:09
  • Teacher laptops are either 1-2 year old Lenovo E520 machines with a 1x1 wireless NIC or a Lenovo G580. The old student machines that don't cause any problems and function perfectly are Lenovo x121 and x130e machines. The new student laptops that are causing the issues are brand new Lenovo E430c machines with an intel centrino 2230 wireless NIC. I was able to replicate the issue and take down an entire access point with just 3 of the new student laptops last night. the old student machines and teacher machines did not have the same result. – MooseBalm Jan 15 '14 at 20:15
  • The problem is never caused by teacher machines or the old student machines, and we have yet to find a new student machine that doesn't cause this to happen. – MooseBalm Jan 15 '14 at 20:16
  • Well, obviously the problem is not in your infrastructure at all, but something about the laptops. A wireless sniffer or a wifi analyzer would be helpful to see what is filling up your airtime. Perhaps you can rent one. – Ron Trunk Jan 15 '14 at 20:24
  • 2
    @MikePennington, there has been a new update with this issue, finally. The problem is a widespread issue with the Intel Centrino 2230 card, itself. This is widely reported with multiple wireless manufacturers, including Cisco home networking products. The fix is posted as a new accepted answer to this question. – MooseBalm Mar 3 '14 at 13:53
6

The actual solution is to change a few settings of the wireless NIC in windows.

Three things needed to be changed in the card's settings in order to fix this.

1) Change the 802.11n channel width from the default (20) to auto

2) Turn off bluetooth in the card's properties

3) Set the Roaming aggressiveness to High

Immediately after, we were getting 100 Mbps downloads over the LAN when we were previously getting 500 Kbps.

The originally accepted solution below is no longer valid. Unifi products are not, in fact, the cause of the issue.

After extensive testing and multiple situations, it appears that the Intel Centrino 2230 Wireless NIC is simply incompatible with Ubiquiti Unifi access points.

Replacing the NIC with a 1x1 WLAN NIC from previous machines completely alleviated the problem. Connecting to the access points of three other brands worked fine as well.

We attempted to connect them to a Unifi AC access point, as well. Nothing changed.

Neither updating nor backdating drivers on the chipset and WLAN didn't work.

It appears to just be totally incompatible between the Centrino 2230 WLAN NIC and Ubiquiti Unifi access points.

  • Interesting. Did you attempt to contact Ubiquti? I'd imagine they would want to test this, considering how popular those NICs are. – Ron Trunk Feb 7 '14 at 16:54
  • We have actually contacted them rather extensively. Their only advice, given multiple times, was to make sure power levels were set to low and to update the firmware. I actually asked them if they would send us an AC or a Unifi Pro access point to test to see if it fixed the problem since the $3,000 we spent on access points had to be replaced with an older wireless system to work again. They wouldn't even consider it. – MooseBalm Feb 7 '14 at 20:33
  • Are you running 2.x or the 3.x Betas on the UniFi system? There were quite a few fixes for compatibility issues with various WiFi chipsets in the more recent betas. – jda Feb 9 '14 at 22:07
  • @jona We have tried both. We started with increments of the 2.x firmware and eventually tried upgrading to a few instances of the 3.x versions. No luck. – MooseBalm Feb 10 '14 at 13:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.