1

Weird Juniper switch behavior I have bought EX4300 and SRX300 on ebay to study it and started to read documentation.

After some time i wanted to test my knowledge and configure it to test it at home.

I have managed to set up SRX300 as a router with ge-0/0/[0-3] ports configured as untagged with different subnetworks in each of them, and SRX works as a clock without any problem.

But when i wired SRX and EX, i found some unexpected behavior.

Configuration Description:

 SRX           subnetwork                     EX
ge-0/0/0         mgmt                        ge-0/0/0
ge-0/0/1         home                        ge-0/0/2
ge-0/0/2         pbx                         ge-0/0/4
ge-0/0/3         video                       ge-0/0/6

When i connected patch cord from SRX ge-0/0/1 to EX ge-0/0/2 (both interfaces configured as home subnetwork) all worked fine, but when i connected second patch cord from SRX ge-0/0/0 to EX ge-0/0/0 (both interfaces configured as mgmt subnetwork) all devices on home subnetwork stopped discovering default gateway in this subnetwork.

Same situation goes to other subnetworks, when i connect only pbx subnetwork patch cord all works fine, until i connect home subnetwork patch cord.

If i connect video and pbx subnetwork only pbx works.

If i connect all of them, only mgmt works.

All other configuration, except this 4 ports with untagged networks on each of them works fine.

I don't understand, what could cause this behavior, can someone explain it to me?

EX4300 configuration:

root> show configuration
## Last commit: 2019-04-16 10:40:12 EEST by root
version 20190319.203446_builder.r1013243;
groups {
    global {
        system {
            login {
                ....
            }
        }
    }
}
apply-groups global;
system {
    login {
        user root {
            ....
        }
    }
    root-authentication {
        ....
    }
    services {
        ssh {
            root-login deny;
            protocol-version v2;
            port 22;
        }
        web-management {
            http {
                interface me0.0;
            }
            https {
                system-generated-certificate;
            }
        }
    }
    auto-snapshot;
    time-zone Europe/Kiev;
    name-server {
        8.8.8.8;
        8.8.4.4;
        1.0.0.1;
        1.1.1.1;
    }
    syslog {
        user * {
            any emergency;
        }
        file messages {
            any notice;
            authorization info;
        }
        file interactive-commands {
            interactive-commands any;
        }
    }
    processes {
        dhcp-service {
            traceoptions {
                file dhcp_logfile size 10m;
                level all;
                flag all;
            }
        }
    }
}
interfaces {
    ge-0/0/0 {
        unit 0 {
            family ethernet-switching {
                vlan {
                    members mgmt;
                }
            }
        }
    }
    ge-0/0/2 {
        unit 0 {
            family ethernet-switching {
                vlan {
                    members home;
                }
            }
        }
    }
    ge-0/0/4 {
        native-vlan-id 22;
        unit 0 {
            family ethernet-switching {
                interface-mode trunk;
                vlan {
                    members [ pbx home ];
                }
            }
        }
    }
    ge-0/0/6 {
        unit 0 {
            family ethernet-switching {
                vlan {
                    members video;
                }
            }
        }
    }
    ge-0/0/8 {
        unit 0 {
            family ethernet-switching {
                vlan {
                    members guest;
                }
            }
        }
    }
    ge-0/0/9 {
        unit 0 {
            family ethernet-switching {
                vlan {
                    members home;
                }
            }
        }
    }
    ge-0/0/10 {
        unit 0 {
            family ethernet-switching;
        }
    }
    ge-0/0/11 {
        unit 0 {
            family ethernet-switching {
                vlan {
                    members home;
                }
            }
        }
    }
    ge-0/0/12 {
        unit 0 {
            family ethernet-switching {
                vlan {
                    members video;
                }
            }
        }
    }
    ge-0/0/13 {
        unit 0 {
            family ethernet-switching {
                vlan {
                    members mgmt;
                }
            }
        }
    }
    ge-0/0/14 {
        unit 0 {
            family ethernet-switching {
                vlan {
                    members video;
                }
            }
        }
    }
    ge-0/0/15 {
        unit 0 {
            family ethernet-switching {
                vlan {
                    members mgmt;
                }
            }
        }
    }
    ge-0/0/16 {
        unit 0 {
            family ethernet-switching {
                vlan {
                    members pbx;
                }
            }
        }
    }
    ge-0/0/17 {
        unit 0 {
            family ethernet-switching {
                vlan {
                    members pbx;
                }
            }
        }
    }
    ge-0/0/18 {
        unit 0 {
            family ethernet-switching {
                vlan {
                    members pbx;
                }
            }
        }
    }
    ge-0/0/19 {
        unit 0 {
            family ethernet-switching {
                vlan {
                    members pbx;
                }
            }
        }
    }
    ge-0/0/20 {
        native-vlan-id 5;
        unit 0 {
            family ethernet-switching {
                interface-mode trunk;
                vlan {
                    members [ mgmt home guest ];
                }
            }
        }
    }
    ge-0/0/21 {
        unit 0 {
            family ethernet-switching {
                vlan {
                    members video;
                }
            }
        }
    }
    ge-0/0/22 {
        native-vlan-id 5;
        unit 0 {
            family ethernet-switching {
                interface-mode trunk;
                vlan {
                    members [ mgmt guest home ];
                }
            }
        }
    }
    ge-0/0/23 {
        unit 0 {
            family ethernet-switching {
                interface-mode trunk;
                vlan {
                    members [ home pbx video guest mgmt ];
                }
            }
        }
    }
    ge-0/2/0 {
        unit 0 {
            family ethernet-switching {
                storm-control default;
            }
        }
    }
    xe-0/2/0 {
        unit 0 {
            family ethernet-switching {
                storm-control default;
            }
        }
    }
    ge-0/2/1 {
        unit 0 {
            family ethernet-switching {
                storm-control default;
            }
        }
    }
    xe-0/2/1 {
        unit 0 {
            family ethernet-switching {
                storm-control default;
            }
        }
    }
    ge-0/2/2 {
        unit 0 {
            family ethernet-switching {
                storm-control default;
            }
        }
    }
    xe-0/2/2 {
        unit 0 {
            family ethernet-switching {
                storm-control default;
            }
        }
    }
    ge-0/2/3 {
        unit 0 {
            family ethernet-switching {
                storm-control default;
            }
        }
    }
    xe-0/2/3 {
        unit 0 {
            family ethernet-switching {
                storm-control default;
            }
        }
    }
    irb {
        unit 5 {
            family inet {
                address 10.5.5.43/24;
            }
        }
        unit 11 {
            family inet {
                address 10.33.11.43/24;
            }
        }
        unit 12 {
            family inet;
        }
        unit 22 {
            family inet {
                address 10.41.22.43/32;
            }
        }
        unit 23 {
            family inet;
        }
    }
    me0 {
        unit 0 {
            family inet {
                address 172.16.27.43/24;
            }
        }
    }
}
forwarding-options {
    storm-control-profiles default {
        all;
    }
    dhcp-relay {
        server-group {
            home-dhcp {
                10.33.11.1;
            }
            pbx-dhcp {
                10.41.22.1;
            }
        }
        group all {
            interface irb.11;
            interface irb.22;
        }
    }
}
protocols {
    lldp {
        interface all;
    }
    lldp-med {
        interface all;
    }
    igmp-snooping {
        vlan default;
    }
    rstp {
        interface all;
    }
}
poe {
    interface all;
}
vlans {
    home {
        vlan-id 11;
        l3-interface irb.11;
    }
    guest {
        vlan-id 12;
        l3-interface irb.12;
    }
    mgmt {
        vlan-id 5;
        l3-interface irb.5;
    }
    pbx {
        vlan-id 22;
        l3-interface irb.22;
    }
    video {
        vlan-id 23;
        l3-interface irb.23;
    }
}

{master:0}
3

At least on the switch, RSTP is active. Likely, you've got a switch group on the SRX, and STP blocks the supposedly redundant interfaces.

Check the logs and add the sanitized SRX config if you can't figure it out.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.