2

Switch 1 will be server and Switch 4 will be Client!

Switch 1 configuration

       S1#show run
   Building configuration...

Current configuration : 1451 bytes
!
version 16.3.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname S1
!
!
!
!
!
!
!
no ip cef
no ipv6 cef
!
!
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface GigabitEthernet1/0/1
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet1/0/2
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet1/0/3
!
interface GigabitEthernet1/0/4
!
interface GigabitEthernet1/0/5
!
interface GigabitEthernet1/0/6
!
interface GigabitEthernet1/0/7
!
interface GigabitEthernet1/0/8
!
interface GigabitEthernet1/0/9
!
interface GigabitEthernet1/0/10
!
interface GigabitEthernet1/0/11
!
interface GigabitEthernet1/0/12
!
interface GigabitEthernet1/0/13
!
interface GigabitEthernet1/0/14
!
interface GigabitEthernet1/0/15
!
interface GigabitEthernet1/0/16
!
interface GigabitEthernet1/0/17
!
interface GigabitEthernet1/0/18
!
interface GigabitEthernet1/0/19
!
interface GigabitEthernet1/0/20
!
interface GigabitEthernet1/0/21
!
interface GigabitEthernet1/0/22
!
interface GigabitEthernet1/0/23
!
interface GigabitEthernet1/0/24
!
interface GigabitEthernet1/1/1
!
interface GigabitEthernet1/1/2
!
interface GigabitEthernet1/1/3
!
interface GigabitEthernet1/1/4
!
interface Vlan1
 no ip address
!
ip classless
!
ip flow-export version 9
!
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
!
!
end







S1#show vtp st
        S1#show vtp status 
        VTP Version capable             : 1 to 2
        VTP version running             : 2
        VTP Domain Name                 : ccna
        VTP Pruning Mode                : Disabled
        VTP Traps Generation            : Disabled
        Device ID                       : 0030.A3BA.9100
        Configuration last modified by 0.0.0.0 at 3-1-93 00:41:16
        Local updater ID is 0.0.0.0 (no valid interface found)

        Feature VLAN : 
        --------------
        VTP Operating Mode                : Server
        Maximum VLANs supported locally   : 1005
        Number of existing VLANs          : 7
        Configuration Revision            : 7
        MD5 digest                        : 0x44 0xD7 0x99 0x68 0xF8 0x18 0x7F 0xBD 
                                            0xA4 0xDE 0xB5 0xC3 0x00 0x69 0xC3 0xC6 

Switch 4 configurations

  S4#show run
Building configuration...

Current configuration : 1390 bytes
!
version 16.3.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname S4
!
!
!
!
!
!
!
no ip cef
no ipv6 cef
!
!
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface GigabitEthernet1/0/1
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet1/0/2
!
interface GigabitEthernet1/0/3
!
interface GigabitEthernet1/0/4
!
interface GigabitEthernet1/0/5
!
interface GigabitEthernet1/0/6
!
interface GigabitEthernet1/0/7
!
interface GigabitEthernet1/0/8
!
interface GigabitEthernet1/0/9
!
interface GigabitEthernet1/0/10
!
interface GigabitEthernet1/0/11
!
interface GigabitEthernet1/0/12
!
interface GigabitEthernet1/0/13
!
interface GigabitEthernet1/0/14
!
interface GigabitEthernet1/0/15
!
interface GigabitEthernet1/0/16
!
interface GigabitEthernet1/0/17
!
interface GigabitEthernet1/0/18
!
interface GigabitEthernet1/0/19
!
interface GigabitEthernet1/0/20
!
interface GigabitEthernet1/0/21
!
interface GigabitEthernet1/0/22
!
interface GigabitEthernet1/0/23
!
interface GigabitEthernet1/0/24
!
interface GigabitEthernet1/1/1
!
interface GigabitEthernet1/1/2
!
interface GigabitEthernet1/1/3
!
interface GigabitEthernet1/1/4
!
interface Vlan1
 no ip address
!
ip classless
!
ip flow-export version 9
!
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
!
!
end 


S4#show vtp status 
VTP Version capable             : 1 to 2
VTP version running             : 2
VTP Domain Name                 : ccna
VTP Pruning Mode                : Disabled
VTP Traps Generation            : Disabled
Device ID                       : 0001.6436.1500
Configuration last modified by 0.0.0.0 at 3-1-93 00:15:42

Feature VLAN : 
--------------
VTP Operating Mode                : Client
Maximum VLANs supported locally   : 1005
Number of existing VLANs          : 5
Configuration Revision            : 1
MD5 digest                        : 0xA5 0xB4 0xB1 0x07 0x53 0x1C 0xB7 0x15 
                                    0x19 0x51 0x6B 0x51 0x4B 0xD0 0xD7 0xBA
  • I dont see any VTP configuration. – user56700 May 3 at 11:30
  • Sorry ! it's added at bottom! – Owais Qureshi May 3 at 11:36
  • How are the two switches connected? I don't see any Layer 3 interface on the two devices. If they are suppose to communicate, then you need to create a VLAN and assign an IP address so that they can communicate. – user56700 May 3 at 11:58
  • The very first thing to fix is that you have two different VTP passwords configured. The passwords must match for VTP to work. – Ron Maupin May 3 at 13:40
  • By the way, you are probably learning VTP as part of a curriculum, and that is fine, but VTP is something you probably do not really want to use in production. It can cause major problems, and it can be a security risk. In the real world, smart people set the VTP mode to transparent. – Ron Maupin May 4 at 22:15
5

For VTP to work between a VTP server and client, the VTP Domain Name and VTP passwords must match. You have the same VTP Domain Name (ccna), but the VTP Passwords do not match. You can tell that the passwords do not match because the MD5 Digests do not match:

Switch 1: 0x44 0xD7 0x99 0x68 0xF8 0x18 0x7F 0xBD 0xA4 0xDE 0xB5 0xC3 0x00 0x69 0xC3 0xC6
Switch 4: 0xA5 0xB4 0xB1 0x07 0x53 0x1C 0xB7 0x15 0x19 0x51 0x6B 0x51 0x4B 0xD0 0xD7 0xBA

You can use the show vtp password command on each switch to see the password configured on the switch. Remember that having a space before or after the password is part of the password, and it will be difficult to tell if that is the case. Also, a blank password is a password.

To fix it, you can copy a password once, then paste it into both switches. That way, you can make sure that they are the same.

  • Actually password is not configured! Oppss – Owais Qureshi May 4 at 7:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.