1

I have a topology in GNS3 with an IPsec VPN tunnel between C1 and C2 (https://imgur.com/dnNkssU). In clients networks i am configured a CME and a Softphone. When i make a call the quality is very bad. I used Startrinity for monitoring and the results are like in this photo https://imgur.com/UoRZyTs

Why the statistics are so bad?

C1 config:

crypto isakmp policy 10
 encr 3des
 hash md5
 authentication pre-share
 group 2
crypto isakmp key parola123 address 8.8.11.2       
!
!
crypto ipsec transform-set myset esp-3des esp-md5-hmac 
 mode tunnel
!
!
!
crypto map mymap 1 ipsec-isakmp 
 set peer 8.8.11.2
 set security-association lifetime seconds 86400
 set transform-set myset 
 set pfs group2
 match address 100
!
!
!
!
!
!
interface FastEthernet0/0
 ip address 8.8.10.2 255.255.255.0
 ip nat outside
 ip virtual-reassembly in
 duplex half
 crypto map mymap
!
interface FastEthernet1/0
 ip address 10.1.1.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly in
 duplex auto
 speed auto
!
!
ip nat inside source route-map nonat interface FastEthernet0/0 overload
ip route 0.0.0.0 0.0.0.0 8.8.10.1
!
access-list 100 permit ip 10.1.1.0 0.0.0.255 10.1.2.0 0.0.0.255
access-list 101 deny   ip 10.1.1.0 0.0.0.255 10.1.2.0 0.0.0.255
access-list 101 permit ip 10.1.1.0 0.0.0.255 any
no cdp log mismatch duplex
!
route-map nonat permit 10
 match ip address 101

  • Did any answer help you? If so, you should accept the answer so that the question doesn't keep popping up forever, looking for an answer. Alternatively, you can provide and accept your own answer. – Ron Maupin Dec 15 '19 at 2:55
2

Voice Over IP is quite sensitive to latency and jiter (variation in latency).

It is really not surprising that running such a protocol in an emulator on a generic purpose CPU cannot achieve the same quality as dedicated device. Especially when you simulate IPSEC tunnels, which is a CPU intensive feature without hardware acceleration.

| improve this answer | |
  • Thanks for answer! I know, but for a single call is normal to have this values? Every router have 512 RAM, in cpu history use is max 25% used. – Lucian May 14 '19 at 13:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.