2

I have a specific static routes that require advertising into EIGRP and eventually into BGP for remote offices. My goal is to cut down on the configuration updates required for updating not only the static routes for new additions, but the route-map ACL for EIGRP, and the policy-route ACL to the next hop.

I've learned that route tags may be an option for routing traffic with less configuration. Basically I can tag a static route with a number, (such as 20). Then I can create a route-map that matches on tag 20, and sets tag 20 and configure this within EIGRP to match and advertise that tag again. On the receiving router I should be able to perform this same step for BGP in a similar manner (EIGRP-to-BGP route-map that retags), however, I still have a policy route that doesn't quite fit with this tagging method (ACL has a source/destination - whereas a prefix list does not).

My goal here is to create specific static routes with tags, and have those tags carry through and advertise properly (including a policy route-map or equivalent ) without me having to update 3 other ACLs everytime. Policy-map doesn't play well with the redistribution - any one come up with other ideas for something similar?

2
  • This is a little unclear... are you merely asking to redistribute from EIGRP to BGP, or EIGRP->BGP->EIGRP. It would also help if we had a diagram and a little more info. The diagram doesn't have to be super detailed, just enough to fully illustrate the use case – This Jan 20 '14 at 12:15
  • I would also suggest more information on the policy routing that has to be applied on a per interface basis are you trying to dynamically move the ACL around? I would suggest a configuration management solution as I don't see how a routing protocol distributes an ACL that can be referenced by a route map – fredpbaker Jan 21 '14 at 1:42
3

I am not 100% sure whether tags are carried in BGP updates but here is what I put together pretty quick:

enter image description here

Router "Static":

interface Loopback0
 ip address 172.16.1.1 255.255.255.0
!
interface Loopback1
 ip address 172.16.2.1 255.255.255.0

interface Ethernet0/1
 ip address 172.16.0.1 255.255.255.0
 half-duplex

ip route 0.0.0.0 0.0.0.0 172.16.0.2

Router R1:

interface Ethernet0/0
 ip address 10.0.0.1 255.255.255.252
 half-duplex

interface Ethernet0/1
 ip address 172.16.0.2 255.255.255.0
 half-duplex

ip route 172.16.1.0 255.255.255.0 172.16.0.1 tag 20
ip route 172.16.2.0 255.255.255.0 172.16.0.1 tag 20

router eigrp 100
 redistribute static route-map MyRouteMap
 network 10.0.0.0 0.0.0.3
 no auto-summary

route-map MyRouteMap permit 10
 match tag 20

Router R2:

interface Ethernet0/0
 ip address 10.0.0.2 255.255.255.252
 half-duplex

interface Ethernet0/1
 ip address 10.0.0.5 255.255.255.252
 half-duplex

router eigrp 100
 network 10.0.0.0 0.0.0.3
 no auto-summary

router bgp 65000
 no synchronization
 bgp log-neighbor-changes
 redistribute eigrp 100 route-map MyRouteMap
 neighbor 10.0.0.6 remote-as 65000
 neighbor 10.0.0.6 next-hop-self
 no auto-summary

route-map MyRouteMap permit 10
 match tag 20

R2#show ip route 172.16.1.0
Routing entry for 172.16.1.0/24
  Known via "eigrp 100", distance 170, metric 307200
  Tag 20, type external

Router R3:

interface Ethernet0/1
 ip address 10.0.0.6 255.255.255.252
 half-duplex

router bgp 65000
 no synchronization
 bgp log-neighbor-changes
 neighbor 10.0.0.5 remote-as 65000
 no auto-summary

R3#show ip bgp 172.16.1.0
BGP routing table entry for 172.16.1.0/24, version 3
Paths: (1 available, best #1, table Default-IP-Routing-Table)
  Not advertised to any peer
  Local
    10.0.0.5 from 10.0.0.5 (10.0.0.2)
      Origin incomplete, metric 307200, localpref 100, valid, internal, best

I hope this is what you were asking for.

1
  • Yes, you've got the right idea. Router 2 would also have a policy-route route. Not all routes would be tagged with tag 20 - so some will be advertised into BGP with Router 3. Those that are tagged 20 will be policy routed (set-next-hop) to another interface to route out via an alternate router/path. This is where the tags fall apart and I have to define another ACL I believe. (those tags would be carried into BGP if your route-map included a permit 20 statement that had a set tag 20 command). – raidORlostark Jan 26 '14 at 2:35
0

I think its a bit late, but.. here I go

You should use communities to mark the routes and then use it on policies instead ACLs over BGP.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.