4

I have a link which is LT2P from a site router R1 (Cisco 867-VAE, IOS 15.3) which has two external interfaces defined (dialer1 and vlan-1000), but only one plugged in (first is ADSL, second is technician's 4g router)

   Exterior view               Tunnel view

   R99                         R99
    |                           |vpp1
   cloud                        |
    ||                          |
  d1||vlan1000                  |vpp1
    R1                          R1

All of this works fine with either ip local interface Dialer1 or ip local interface vlan1000 in the configuration of the pseudowire-class.

My question is how do I make my virtual-PPP interface work according to whether either interface is plugged in and working without having to reconfigure psuedowire-class? It seems I can't add a second pseudowire inside int virtual-ppp1, nor a second ip local inside pseudowire-class. Do I have to have a whole extra virtual-ppp2 and pseudowire-class?

Interface config of R1 has two dynamic-address external interfaces:

interface Vlan1000
 ip address dhcp
 ip nat outside
interface Dialer1
 ip address negotiated
 ip nat outside
 ...

ip route 0.0.0.0 0.0.0.0 Dialer1
ip route 0.0.0.0 0.0.0.0 dhcp

This is the tunnelling configuration:

pseudowire-class PWCLASS
 encapsulation l2tpv2
 ip local interface Dialer1

interface Virtual-PPP1
 ip address negotiated
 pseudowire R99-exernal-address 1 encapsulation l2tpv2 pw-class PWCLASS
 ...
System image file is "flash:c860vae-advsecurityk9_npe-mz.153-3.M.bin"
  • Have you tried creating an additional Virtual PPP interface and then add another pseudowire-class as you describe yourself? – user56700 May 25 at 14:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.