1

I am a newbie to BGP and have an ASR1001x router (172.16.0.3), I'm forwarding an ACL to a second router (172.16.0.1) while I try to get BGP working on this one for a specific testing prefix-list

Interfaces:

interface Loopback0
 ip address 192.168.0.1 255.255.255.0
!
interface GigabitEthernet0/0/0
 ip address 172.16.0.3 255.255.255.0
 ip nat inside
 ip policy route-map PBR_GI0/0/0
!
interface GigabitEthernet0/0/2
 ip address 2.2.201.201 255.255.255.252
 ip nat outside
 negotiation auto
 ip virtual-reassembly
!
interface GigabitEthernet0/0/3
 ip address 3.3.301.301 255.255.255.252
 ip nat outside
 negotiation auto
 ip virtual-reassembly
!

GE0/0/0 is in from SVI switch.

BGP setup as follows:

router bgp 62323
 bgp log-neighbor-changes
 neighbor 2.2.200.200 remote-as 200
 neighbor 2.2.200.200 ttl-security hops 2
 neighbor 2.2.200.200 password 7 #####
 neighbor 2.2.200.200 timers 6 20
 neighbor 3.3.300.300 remote-as 300
 neighbor 3.3.300.300 ttl-security hops 2
 neighbor 3.3.300.300 password 7 ####
 neighbor 3.3.300.300 timers 7 22
 !
 address-family ipv4
  network 172.16.0.0 mask 255.255.255.0
  network 192.168.0.0
  network 192.168.120.0
  neighbor 2.2.200.200 activate
  neighbor 2.2.200.200 send-community both
  neighbor 2.2.200.200 route-map ISPA_IN in
  neighbor 2.2.200.200 route-map ISPA_OUT out
  neighbor 3.3.300.300 activate
  neighbor 3.3.300.300 send-community both
  neighbor 3.3.300.300 route-map ISPB_IN in
  neighbor 3.3.300.300 route-map ISPB_OUT out
 exit-address-family
!
ip as-path access-list 1 permit ^$
ip as-path access-list 2 permit _200$
ip as-path access-list 2 permit _300$
!
access-list 1 permit 192.160.120.0 0.0.0.255
access-list 1 permit 192.168.0.0 0.0.0.255

static routes for 3 networks to through SVI (172.160.0.254):

ip route 192.168.100.0 255.255.255.0 172.16.0.254
ip route 192.168.110.0 255.255.255.0 172.16.0.254 name SVR_SW
ip route 192.168.120.0 255.255.255.0 172.16.0.254

access list for PBR to send to hop to second router:

ip access-list standard PRODUCTION_ACL
 permit 192.168.100.0 0.0.0.255
 permit 192.168.110.0 0.0.0.255

prefix lists for BGP:

ip prefix-list TESTING_LAN seq 5 permit 192.168.120.0/24

route-maps:

route-map PBR_GI0/0/0 permit 10
 match ip address PRODUCTION_ACL
 set ip next-hop 172.16.0.1
!
route-map ISPA_IN permit 10
 match as-path 2
!
route-map ISPB_IN permit 10
 match as-path 2
!
route-map ISPA_OUT permit 20
 match ip address prefix-list TESTING_LAN
 match as-path 1
!
route-map ISPB_OUT permit 20
 match ip address prefix-list TESTING_LAN
 match as-path 1
!

I'm getting BGP routes in, as well I can see that I'm advertising a route to both neighbors:

local router ID: 192.168.0.1

     Network          Next Hop            Metric LocPrf Weight Path
 *>  192.168.120.0    172.16.0.254             0         32768 i

But when I'm on a machine on 192.168.120.0/24 I can't ping anything past the router.

Am I missing something in the setup?

  • 1
    Please show the routing tables from both routers. – Ron Trunk May 27 at 16:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.