0

I'm new to networking and am currently 6 months into a course for it so there may be some noob mistakes or really silly answers/questions here but bare with me.

I have a task to setup RIPv2 routing. In the image below, you can see two routers. One is called Router 3 (bottom) and the other is called AccessRouter (top). Try to ignore the other cables coming out of the routers. I'm specifically focusing on the serial cable going between the 2 routers mentioned.

Routers

The Se0/0/1 interface from the AccessRouter (top) has an IP address of 172.30.150.225. The Se0/0/1 interface from the Router3 (bottom) has an IP address of 172.30.150.226. My routing is configured in my running config for each device as follows:

Router3

router rip
version 2
 network 172.30.0.0
 no auto-summary
!
ip classless

Access Router

router rip
 version 2
 redistribute static 
 network 172.30.0.0
 no auto-summary
!
ip classless

Now that I've configured RIP routing, should I not be able to ping between AccessRouter and the Router3's serial0/0/1 port and vice versa? A ping command simply yields timeouts on both routers.

If you need any more info, let me know. Again, I'm still quite a noob and have been struggling a bit in this class. Thanks guys!

EDIT: Here is the configuration pages for the serial interfaces of both routers.

Access Router (top) Access Router Interface Config

Router 3 (bottom) Router 3 Interface Config

EDIT2: The following is the output of thes show interface command on both serial interfaces. Access Router (top)

AccessRouter#show interface se0/0/1
Serial0/0/1 is up, line protocol is up (connected)
  Hardware is HD64570
  Internet address is 172.30.150.225/30
  MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation HDLC, loopback not set, keepalive set (10 sec)
  Last input never, output never, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0 (size/max/drops); Total output drops: 0
  Queueing strategy: weighted fair
  Output queue: 0/1000/64/0 (size/max total/threshold/drops)
     Conversations  0/0/256 (active/max active/max total)
     Reserved Conversations 0/0 (allocated/max allocated)
     Available Bandwidth 1158 kilobits/sec
  5 minute input rate 7 bits/sec, 0 packets/sec
  5 minute output rate 9 bits/sec, 0 packets/sec
     4 packets input, 388 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     3 packets output, 356 bytes, 0 underruns
     0 output errors, 0 collisions, 1 interface resets
     0 output buffer failures, 0 output buffers swapped out
     0 carrier transitions
     DCD=up  DSR=up  DTR=up  RTS=up  CTS=up

Router 3 (bottom)

Router3#sh interface se0/0/1
Serial0/0/1 is up, line protocol is up (connected)
  Hardware is HD64570
  Internet address is 172.30.150.226/30
  MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation HDLC, loopback not set, keepalive set (10 sec)
  Last input never, output never, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0 (size/max/drops); Total output drops: 0
  Queueing strategy: weighted fair
  Output queue: 0/1000/64/0 (size/max total/threshold/drops)
     Conversations  0/0/256 (active/max active/max total)
     Reserved Conversations 0/0 (allocated/max allocated)
     Available Bandwidth 1158 kilobits/sec
  5 minute input rate 5 bits/sec, 0 packets/sec
  5 minute output rate 14 bits/sec, 0 packets/sec
     5 packets input, 260 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     6 packets output, 552 bytes, 0 underruns
     0 output errors, 0 collisions, 1 interface resets
     0 output buffer failures, 0 output buffers swapped out
     0 carrier transitions
     DCD=up  DSR=up  DTR=up  RTS=up  CTS=up

EDIT 3 - Pastebins of the running config of each router

Access Router:

Building configuration...

Current configuration : 1413 bytes
!
version 15.3
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname AccessRouter
!
!
boot system flash c1900-universalk9-mz.SPA.155-3.M4a.bin 
!
enable password class
!
!
!
!
!
!
no ip cef
no ipv6 cef
!
!
!
!
license udi pid CISCO1941/K9 sn FTX1524WR40-
license boot module c1900 technology-package FoundationSuiteK9
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface GigabitEthernet0/0
 ip address 192.168.125.45 255.255.255.240
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 ip address 192.168.125.29 255.255.255.224
 duplex auto
 speed auto
!
interface Serial0/0/0
 ip address 172.20.125.193 255.255.255.252
!
interface Serial0/0/1
 ip address 172.30.150.225 255.255.255.252
!
interface Serial0/1/0
 ip address 192.168.225.129 255.255.255.252
!
interface Serial0/1/1
 no ip address
 clock rate 2000000
!
interface Vlan1
 no ip address
 shutdown
!
router rip
 version 2
 redistribute static 
 network 172.20.0.0
 network 172.30.0.0
 network 192.168.125.0
 network 192.168.225.0
 no auto-summary
!
ip classless
ip route 172.20.125.0 255.255.255.128 172.20.125.194 
ip route 172.20.125.128 255.255.255.192 172.20.125.194 
ip route 172.30.150.0 255.255.255.128 172.30.150.226 
!
ip flow-export version 9
!
!
!
!
!
!
!
!
line con 0
 password cisco
 login
!
line aux 0
!
line vty 0 4
 password cisco
 login
!
!
!
end

Router 3:

Building configuration...

Current configuration : 1069 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router3
!
!
!
enable password class
!
!
!
!
!
!
ip cef
no ipv6 cef
!
!
!
!
license udi pid CISCO1941/K9 sn FTX15241VLN-
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface GigabitEthernet0/0
 ip address 172.30.150.1 255.255.255.128
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Serial0/0/0
 ip address 172.30.150.229 255.255.255.252
 clock rate 2000000
!
interface Serial0/0/1
 ip address 172.30.150.226 255.255.255.252
!
interface Serial0/1/0
 ip address 172.30.150.233 255.255.255.252
!
interface Serial0/1/1
 no ip address
 clock rate 2000000
!
interface Vlan1
 no ip address
 shutdown
!
router rip
 version 2
 passive-interface GigabitEthernet0/0
 network 172.30.0.0
 no auto-summary
!
ip classless
!
ip flow-export version 9
!
!
!
!
!
!
!
!
line con 0
 password cisco
 login
!
line aux 0
!
line vty 0 4
 password cisco
 login
!
!
!
end
  • You need to post the interface configurations also. – user56700 May 29 at 11:08
  • @user56700 I've added what I believe you are referring to – Remy2402 May 29 at 11:50
  • Check the interface encapsulation and check which router is the DCE and DTE. – Roid May 29 at 13:18
  • RIP is not the issue -- you have a lower level problem. Check to see if the interfaces are up (From the CLI, type "show interface se 0/0/1" and add the output to your question. – Ron Trunk May 29 at 13:33
  • @RonTrunk I have added the outputs. It appears the interfaces are up? but you might be able to find more helpful info in the output – Remy2402 May 29 at 13:42
1

You do not have the clock set on one end of the link between the two routers. Neither interface Serial0/0/1 has a clock rate command. That means that you have two DTE connections, and that will not work. Setting the clock on one end makes it a DCE, and you must have DCE on one end and DTE on the other end.


Also, you are messing up on the access router by putting in static routes. Routers inherently know about directly connected networks, and how to route to those. A directly connected network will have an AD of 0 (most preferred), but a static route has an AD of 1. Remove the static routes and the redistribute static under RIP.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.