0

I have a network topology as below:

enter image description here

I want to use the Server0 to manage(communicate) to 10.10.10.1-3.

you know the 10.10.10.1-3 are vlan100's SVI.

there have vlan 100 and vlan 501.

IP programme:

vlan 100(10.10.10.0/24) 
vlan 501(10.50.1.0/24)

The server's IP is 10.10.10.5, but if it can be 10.50.1.*/24 too. (I mean I just want the Server0 can manage the 10.10.10.0/24)

how to realize it?


the configuration are below:

Switch0:

Switch#show running-config 
Building configuration...

Current configuration : 1427 bytes
!
version 12.2(37)SE1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch

!
spanning-tree mode pvst
!
!
!
!
!
!
interface FastEthernet0/1
...
interface FastEthernet0/24
!
interface GigabitEthernet0/1
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet0/2
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface Vlan1
 no ip address
 shutdown
!
interface Vlan100
 mac-address 0005.5ed1.7601
 ip address 10.10.10.1 255.255.255.0
!
interface Vlan501
 mac-address 0005.5ed1.7602
 ip address 10.50.1.254 255.255.255.0
!
ip classless
!
ip flow-export version 9
!
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
!
!
end

Switch1:

Switch#show running-config 
Building configuration...

Current configuration : 1341 bytes
!
version 12.2(37)SE1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch
!

!
spanning-tree mode pvst
!
!
!
!
!
!
interface FastEthernet0/1
...
interface FastEthernet0/24
!
interface GigabitEthernet0/1
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet0/2
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface Vlan1
 no ip address
 shutdown
!
interface Vlan100
 mac-address 00d0.ff83.b201
 ip address 10.10.10.2 255.255.255.0
!
ip classless
!
ip flow-export version 9
!
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
!
!
end

Switch2:

Switch#show running-config 
Building configuration...

Current configuration : 1459 bytes
!
version 12.2(37)SE1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface FastEthernet0/1
 switchport access vlan 501
!
interface FastEthernet0/2
...
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet0/2
 switchport access vlan 501
 switchport trunk encapsulation dot1q
 switchport mode access
 switchport nonegotiate
!
interface Vlan1
 no ip address
 shutdown
!
interface Vlan100
 mac-address 0002.179a.3701
 ip address 10.10.10.3 255.255.255.0
!
ip classless
ip route 0.0.0.0 0.0.0.0 10.10.10.1 
!
ip flow-export version 9
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
!
!
end

all the Switches have vlan 100 and vlan 501.


EDIT-01

I have changed the Server's IP to 10.50.1.5/24. but I don't know how to add gateway to a SVI.

the command in the Vlanif seems no params for adding a gateway:

Switch(config-if)#ip address 10.10.10.2 255.255.255.0 ?
<cr>

And my purpose is let the Server to manage(communicate to) the 10.10.10.0/24.

7
  • 1
    Your server is on vlan501, it should have the DG of SVI 501
    – manish ma
    May 29, 2019 at 12:27
  • what's the meaning of ` DG`?
    – 244boy
    May 30, 2019 at 2:04
  • Default Gateway
    – manish ma
    May 30, 2019 at 7:13
  • yes, it is. you can see the 10.50.1.254/24 in the Switch0.
    – 244boy
    May 30, 2019 at 7:22
  • You have not defined the VLANs on the switches with the global vlan <vlan #> command for each VLAN. Switch 1, as the router, must have routing enabled with the global ip routing command. You must also address the server in the network of VLAN 501 (10.50.1.0/24), and you must configure its gateway as the router address (SVI for VLAN 501 on Switch 1: 10.50.1.254), but the server configuration is off-topic here.
    – Ron Maupin
    May 30, 2019 at 10:55

2 Answers 2

4

The server's address must be part of the subnet it's configured on. Since you have the server on VLAN 501, its IP address has to be in the 10.50.1.0/24 subnet, not as you have it configured.
Set the server's default gateway to the SVI on VLAN 501: 10.50.1.254.

Switch 1 also needs the gateway set to the SVI on Sw0: 10.10.10.1, the same way as Sw2.

5
  • hi, Ron Trunk, thanks your response, but can you explain more about Switch 1 also needs the gateway set to the SVI on Sw0: 10.10.10.1, the same way as Sw2.? check my edited post.
    – 244boy
    May 30, 2019 at 2:14
  • Ip route 0.0.0.0 0.0.0.0 10.10.10.1
    – Ron Trunk
    May 30, 2019 at 2:21
  • if there is the route to 10.10.10.1, but my purpose is let the server0 have ability to communicate with the 10.10.10.0/24(10.10.10.1, 10.10.10.2, and so on).
    – 244boy
    May 30, 2019 at 2:33
  • and all the SVI under Vlan 100, so they(10.10.10.1, 10.10.10.2, 10.10.10.3) can communicate without the Ip route 0.0.0.0 0.0.0.0 10.10.10.1, right?
    – 244boy
    May 30, 2019 at 2:50
  • You seem to be missing a fundamental understanding of how routing works. In order to send traffic from one vlan (501) to another (100), you need to route. Only S0 is configured to route between the VLANs. So, in order for the switches to talk with the server0, they need to forward their traffic to the router (10.10.10.1).
    – Ron Trunk
    May 30, 2019 at 12:16
0

If you want to use Server0 communicate to the 10.10.10.0/24, you should meet the below conditions:

  1. Switch0, Switch1, Switch2 all should have the vlan 100 and vlan 501.
  2. Switch0 have two SVIs: vlanif-100: 10.10.10.1/24 and vlanif-501: 10.50.1.254/24.
  3. I assume the Server0's IP is 10.50.1.5.
  4. then 10.50.1.5 can communicate to 10.10.10.1, because the Switch0 have the SVIs in itself.
  5. If you want to communicate to the other Switches, you should write static route in the switches. ip route 10.50.1.5 255.255.255.255 10.10.10.1.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.