-2

How can a HPE MSR 2003 JG411A do 802.1q. I have had no success in getting my MSR2003 router to perfrom like my cisco 1921 router. basically the cisco does 802.1q, and dhcp, it encapsulate all vlans into a trunk out int say 0/0 to the switch which is an HP2610 and segragates them out with untagged port info.

so i guess im asking has anyone had any success configuring a MSR rotuer to perfrom in this mode.

below is my HPE Router current configuration:

#
version 7.1.059, Release 0306P30

#
sysname Plaza

#
clock timezone Z5 minus 01:00:00
clock protocol none

#
telnet server enable

#
dhcp enable

#
password-recovery enable

#
vlan 1

#
vlan 100

#
vlan 200

#
vlan 233

#
vlan 300

#
vlan 400

#
vlan 500

#
controller Cellular0/0

#
interface Aux0

#
interface NULL0

#
interface Vlan-interface100
ip address 10.101.1.254 255.255.255.0

#
interface Vlan-interface200
ip address 10.101.2.254 255.255.255.0

#
interface Vlan-interface233
ip address 10.1.233.254 255.255.255.0

#
interface Vlan-interface300
ip address 10.101.3.254 255.255.255.0

#
interface Vlan-interface400
ip address 10.101.4.254 255.255.255.0

#
interface Vlan-interface500
ip address 10.101.5.254 255.255.255.0

#
interface GigabitEthernet0/1
port link-mode route
description SITE1_WAN
ip address 10.0.0.223 255.255.255.0
nat outbound port-preserved
nat server protocol udp global 75.145.xxx.xx 50011 inside 10.101.1.11 50011
nat server protocol udp global 75.145.xxx.xx 50012 inside 10.101.1.12 50012
nat server protocol udp global 75.145.xxx.xx 50021 inside 10.101.2.21 50021
nat server protocol udp global 75.145.xxx.xx 50022 inside 10.101.2.22 50022
nat server protocol udp global 75.145.xxx.xx 55001 inside 10.101.1.10 55001
nat server protocol udp global 75.145.xxx.xx 55002 inside 10.101.2.10 55002
nat static enable
undo dhcp select server

#
interface GigabitEthernet0/0
ip address 10.1.1.254 255.255.255.0
port link-mode bridge
port link-type trunk

#
scheduler logfile size 16

#
line class aux
user-role network-admin

#
line class tty
user-role network-operator

#
line class vty
user-role network-operator

#
line aux 0
authentication-mode password
user-role network-admin
set authentication password hash $h$6$8vBqVFg9h+F0Dukp$R4QjgZFSJ/zXJh7KCK1y93U=

#
line vty 0 4
authentication-mode scheme
user-role network-admin
user-role network-operator
set authentication password hash $h$6$k4IwqxQtqql0P2ea$+h5+fsl7WNPvhDVk0ectoBr=

#
line vty 5 63
authentication-mode scheme
user-role metwork-admin
user-role network-admin
user-role network-operator
set authentication password hash $h$6$bJHqvcQArirQuOlq$CL+fEhYp7PbLM35okBPa81k=

#
ip route-static 0.0.0.0 0 10.0.0.1

#
ntp-service enable

#
acl mac 4000

#
domain system

#
domain default enable system

#
role name level-0
description Predefined level-0 role

#
role name level-1
description Predefined level-1 role

#
role name level-2
description Predefined level-2 role

#
role name level-3
description Predefined level-3 role

#
role name level-4
description Predefined level-4 role

#
role name level-5
description Predefined level-5 role

#
role name level-6
description Predefined level-6 role

#
role name level-7
description Predefined level-7 role

#
role name level-8
description Predefined level-8 role

#
role name level-9
description Predefined level-9 role

#
role name level-10
description Predefined level-10 role

#
role name level-11
description Predefined level-11 role

#
role name level-12
description Predefined level-12 role

#
role name level-13
description Predefined level-13 role

#
role name level-14
description Predefined level-14 role

#
role name role1
rule 1 permit command system-view ; interface 0/0
rule 2 permit command system-view ; vlan 100
vlan policy deny
permit vlan 100 to 500

#
user-group system

#
local-user admin class manage
password hash $h$6$F4aEV33RvbUOQwbx$W+OZ3w8gTn1aDAQdpTSw9bLz6UNlAXwUpWnmMUHwpk=
service-type telnet http https
authorization-attribute user-role network-admin
authorization-attribute user-role network-operator

#
local-user desalvo class manage
password hash $h$6$kC8TcWy1gj0OJ8i4$TEO+VCDmHRCh9K/3Tad3bNCYV1WPZ8jstxfPIOrX35=
service-type telnet http https
authorization-attribute user-role network-admin

#
local-user ronnie class manage
password hash $h$6$u1+O9Jruk0fZ2AG8$30N4op2m7op8QR/uUwJS0qRl5CkGy80m1qnU8z7ewn=
service-type telnet http https
authorization-attribute user-role network-admin
authorization-attribute user-role network-operator

#
cwmp
cwmp enable

#
ip http enable
ip https enable
web idle-timeout 20

#
return
9
  • What have you done so far? Please edit your post to include your configuration so we can see what may be incorrect. – Ron Trunk May 31 '19 at 14:23
  • Thank you for your response Ron, I have edited my post to include the HP script – mistertnp May 31 '19 at 14:32
  • The important thing to remember is that Cisco and HP use the term "trunk" differently. A HP trunk is a Cisco port-channel, so don't use trunk commands on the Procurve. You have to tag VLANs on the desired port (Gi 0/0) – Ron Trunk May 31 '19 at 14:42
  • Ron, thanks,the switch is a HP so Tagged i know carries the "trunked data" from the router the switch at port 26 which is a trunk port. all the other ports on the switch that are to be assigned to the specific vlan get "untagged" but all are "tagged to the switch trunk port 26. problem is the Router does not operate as i expect it to do like my cisco script. dhcp, default gateway, i looking to see for my mistakes, router should perform dhcp per vlan encapulate all out GE0. not to sound short. but it is mind blowing. – mistertnp May 31 '19 at 14:45
  • I'm not sure what you want. I don't see any tagging in the configuration, nor any DHCP configuration. – Ron Trunk May 31 '19 at 15:12
1

You have defined the VLANs and the IP-to-VLAN bindings, but you haven't set up port membership yet.

For an untagged (access) port:

vlan 100
port 1 (as required)

For a VLAN-trunk:

interface 1 (as required)
port link-type trunk
port trunk permit vlan 1,100,200,... (as required)
port trunk pvid vlan 1 (your untagged/native VLAN, if required)

Check HP A-MSR Router Series Layer 2 - LAN SwitchingConfiguration Guide for details.

3
  • thank you for the info, i will see how the router responds to this. – mistertnp May 31 '19 at 18:54
  • great news, those command worked as described. problem is that the following do not work, I can not access the sub <Router> system-view [Router] interface ethernet 1/1.10 [Router-Ethernet1/1.10] ip address 1.0.0.1 255.0.0.0 [Router-Ethernet1/1.10] vlan-type dot1q vid 10 [Router-Ethernet1/1.10] quit – mistertnp May 31 '19 at 22:40
  • command for this msr2003 likes stated above do not responded. and request of support is low. i have researched over and over, even HP support and no one can dot1q support. – mistertnp Jun 23 '19 at 23:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.