0

I'm trying to configure RIP routing between the 2 routers and 1 L3 Switch.

My Router0 configuration - f0/0 = 172.17.10.1 f0/1 = 172.16.10.11

Router#sh run
Building configuration...

Current configuration : 645 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
!
!
!
!
!
!
ip cef
no ipv6 cef
!
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface FastEthernet0/0
 ip address 172.17.10.1 255.255.255.252
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 172.16.10.1 255.255.255.0
 duplex auto
 speed auto
!
interface Vlan1
 no ip address
 shutdown
!
router rip
 version 2
 network 172.16.0.0
 network 172.17.0.0
!
ip classless
!
ip flow-export version 9
!
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
!
end

My Switch0 - GE1/0/1 = 172.17.10.2 GE1/0/2 = 172.17.10.5

Switch#sh run
Building configuration...

Current configuration : 1577 bytes
!
version 16.3.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch
!
!
!
!
!
!
!
no ip cef
ip routing
!
no ipv6 cef
!
!
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface GigabitEthernet1/0/1
 no switchport
 ip address 172.17.10.2 255.255.255.252
 duplex auto
 speed auto
!
interface GigabitEthernet1/0/2
 no switchport
 ip address 172.17.10.5 255.255.255.252
 duplex auto
 speed auto
!
interface GigabitEthernet1/0/3
!
interface GigabitEthernet1/0/4
!
interface GigabitEthernet1/0/5
!
interface GigabitEthernet1/0/6
!
interface GigabitEthernet1/0/7
!
interface GigabitEthernet1/0/8
!
interface GigabitEthernet1/0/9
!
interface GigabitEthernet1/0/10
!
interface GigabitEthernet1/0/11
!
interface GigabitEthernet1/0/12
!
interface GigabitEthernet1/0/13
!
interface GigabitEthernet1/0/14
!
interface GigabitEthernet1/0/15
!
interface GigabitEthernet1/0/16
!
interface GigabitEthernet1/0/17
!
interface GigabitEthernet1/0/18
!
interface GigabitEthernet1/0/19
!
interface GigabitEthernet1/0/20
!
interface GigabitEthernet1/0/21
!
interface GigabitEthernet1/0/22
!
interface GigabitEthernet1/0/23
!
interface GigabitEthernet1/0/24
!
interface GigabitEthernet1/1/1
!
interface GigabitEthernet1/1/2
!
interface GigabitEthernet1/1/3
!
interface GigabitEthernet1/1/4
!
interface Vlan1
 no ip address
 shutdown
!
router rip
 version 2
 network 172.17.0.0
 no auto-summary
!
ip classless
!
ip flow-export version 9
!
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
!
!
end

Router1 - F0/0 = 172.17.10.6 F0/1 = 172.16.11.1

Router#sh run
Building configuration...

Current configuration : 648 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
!
!
!
!
!
!
no ip cef
no ipv6 cef
!
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface FastEthernet0/0
 ip address 172.17.10.6 255.255.255.252
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 172.16.11.1 255.255.255.0
 duplex auto
 speed auto
!
interface Vlan1
 no ip address
 shutdown
!
router rip
 version 2
 network 172.16.0.0
 network 172.17.0.0
!
ip classless
!
ip flow-export version 9
!
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
!
end

enter image description here

enter image description here

How do I get my L3 switch to route the 172.17.10.0/30 network 172.17.10.4/30 network and the 172.16.10.0/24 and 11/24 networks?

  • What is your question? – Ron Trunk Jun 12 '19 at 19:25
  • @RonTrunk Hi ron, sorry I forgot to be more explicit but i'm very confused about the whole thing. I've added the question. – SagunKho Jun 12 '19 at 19:39
  • Please edit your question to include your router configurations. – Ron Trunk Jun 12 '19 at 19:50
  • 1
    You need to use the no auto-summary command on all the RIP configurations. – Ron Maupin Jun 12 '19 at 20:34
  • 1
    You have network statements covering those interfaces. The network statement doesn't add the network in the statement (a common misconception); it merely tells RIP which interfaces to include in the routing process. The networks are gotten from the interfaces that are included in the routing process. This is actually different for BGP, but that is a completely different story. – Ron Maupin Jun 12 '19 at 20:39
1

You need to use the no auto-summary command on all the RIP configurations.

okay but how do I then add the two /30 networks?

You have network statements covering those interfaces. The network statement doesn't add the network in the statement (a common misconception); it merely tells RIP which interfaces to include in the routing process. The networks are gotten from the interfaces that are included in the routing process. (This is actually different for BGP, but that is a completely different story.)

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.