1

I'm trying to configure a static route between two routers and a layer 3 switch as follows -

enter image description here

Router 0

interface FastEthernet0/0
 ip address 172.17.10.1 255.255.255.252
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 172.16.10.1 255.255.255.0
 duplex auto
 speed auto
!
interface Vlan1
 no ip address
 shutdown
!
ip classless
ip route 172.16.11.0 255.255.255.0 172.17.10.2 
!
ip flow-export version 9

L3 Switch

interface FastEthernet0/1
 no switchport
 ip address 172.17.10.2 255.255.255.252
 duplex auto
 speed auto
!
interface FastEthernet0/2
 no switchport
 ip address 172.17.10.5 255.255.255.252
 duplex auto
 speed auto
!
ip classless
ip route 172.16.10.0 255.255.255.0 172.17.10.1 
ip route 172.16.11.0 255.255.255.0 172.17.10.6 
!
ip flow-export version 9

Router 1

interface FastEthernet0/0
 ip address 172.17.10.6 255.255.255.252
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 172.16.11.1 255.255.255.0
 duplex auto
 speed auto
!
interface Vlan1
 no ip address
 shutdown
!
ip classless
ip route 172.16.11.0 255.255.255.0 172.17.10.5 
ip route 172.16.10.0 255.255.255.0 172.17.10.5 
!
ip flow-export version 9

The switch can ping all devices but the Routers can't ping each other. What am I doing wrong here?

  • sadly school assignments are off-topic here – Mike Pennington Jun 13 at 2:30
2

Router 0 knows nothing about the networks beyond the layer-3 switch and needs specific routes, so you could put in static routes for each network beyond the layer-3 switch that point to the layer-3 switch.

The layer-3 switch needs more specific routes to the networks on the other side of the routers pointing to the routers.

Router 1 needs more specific routes to the networks on the other side of the layer-3 switch.


Edit:

Router 0:

ip route 172.17.10.4 255.255.255.252 172.17.10.2
ip route 172.16.11.0 255.255.255.0 172.17.10.2

Layer-3 Switch

ip route 172.16.10.0 255.255.255.0 172.17.10.1
ip route 172.16.11.0 255.255.255.0 172.17.10.6

Router 1

ip route 172.17.10.0 255.255.255.252 172.17.10.5
ip route 172.16.10.0 255.255.255.0 172.17.10.5
  • I got through this by adding default routes - ip route 0.0.0.0 0.0.0.0 <interface>. What I don't understand is why it wouldn't work when I added the next hop (which is not the same device) instead of the interface (which is the same device). And If I hadn't used the default routes, what would be the complete static routes for this? – SagunKho Jun 12 at 21:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.