1

I am using PiVPN and set up an openvpn server. Myself and a coworker can connect to the vpn remotely with the generated .ovpn files we imported into openvpn clients. I tried creating a .p12 certificate based off the ovpn and put in the TLS-crypt key into the proper space on the cradlepoint but the server logs keep saying:

tls-crypt unwrap error: packet authentication failed
TLS Error: tls-crypt unwrapping failed from <ip address>

I tried commenting out the tls lines in the server.conf in /etc/openvpn and renaming the ta.key in /etc/openvpn/easy-rsa/pki.

I also tried turning off the tls authentication in the cradlepoint after commenting out the lines in server.conf but then the logs say

tls-crypt unwrap error: packet too short

Any help is appreciated.

closed as off-topic by Zac67, Ron Maupin Jun 16 at 14:57

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "NE is a site for to ask and provide answers about professionally managed networks in a business environment. Your question falls outside the areas our community decided are on topic. Please visit the help center for more details. If you disagree with this closure, please ask on Network Engineering Meta." – Zac67, Ron Maupin
If this question can be reworded to fit the rules in the help center, please edit the question.

  • Unfortunately, questions about host/server configurations and protocols above OSI layer-4 are off-topic here. You could try to ask this question on Server Fault for a business network. – Ron Maupin Jun 16 at 14:57

Browse other questions tagged or ask your own question.