4

I'm kinda new to networking so I'm going to do my best to try explain my issue.

The issue that I have is that I want to delete all default configuration for my xe interface.

Current configuration:

set interfaces xe-0/0/24 ether-options auto-negotiation
set interfaces xe-0/0/24 unit 0 family ethernet-switching vlan members default
set interfaces xe-0/0/24 unit 0 family ethernet-switching storm-control default

What I'm trying to do is make it look like this:

set interfaces xe-0/0/20 unit 0 family ethernet-switching interface-mode access
set interfaces xe-0/0/20 unit 0 family ethernet-switching storm-control default

How I am trying to do that:

delete interfaces xe-0/0/24 unit 0 family ethernet-switching
delete interfaces xe-0/0/24 ether-options
set interfaces xe-0/0/24 unit 0 family ethernet-switching storm-control default
set interfaces xe-0/0/24 unit 0 family ethernet-switching interface-mode access

After commit checking, there's an output error:

[edit interfaces xe-0/0/24 unit 0 family]
  'ethernet-switching'
    For access interface, please ensure vlan members is configured
error: configuration check-out failed

Somehow, it asks for a vlan for the interface to be on access mode. I know for sure, that our other switches are configured just like I'm trying to do here now.

Could it be because another switch has no default vlan configuration and this one still has?

OS Version: 13.2X51-D25.2

Model: QFX5100-48C-6Q

Other Switch Version: 14.1X53-D47.

Other Switch Model: EX4300-48T

  • Thank you for your replies, That makes sense to me too, but could you tell me then how other switch is allowed to be configured as an access mode port without having a VLAN? set interfaces ge-0/0/23 description name set interfaces ge-0/0/23 unit 0 family ethernet-switching interface-mode access set interfaces ge-0/0/23 unit 0 family ethernet-switching storm-control default Could it be because of a different model or OS version? – Nenq Jun 19 at 7:49
3

Somehow, it asks for a vlan for the interface to be on access mode. I know for sure, that our other switches are configured just like I'm trying to do here now.

I believe this is probably just an issue with the version of code on your QFX (it is quite old).

Junos ELS configuration (Layer 2 configuration used on EX4300 and QFX5100) commits fine when you don't specify a VLAN on an access port - it maps all traffic to the default VLAN (ID 1) that exists on every switch by default. In fact, you don't even need to specify interface-mode access - all ports assume access mode when family ethernet-switching is enabled, unless you specify that they are in trunk mode.

Could it be because another switch has no default vlan configuration and this one still has?

Having the default VLAN specifically defined on the switch makes no difference - even if you delete the default VLAN configuration, it will still exist and still be mapped to all access ports.

The only time the above is not true is if you create a custom-named VLAN 1 eg: set vlans V1-DEFAULT vlan-id 1 - the default VLAN will be deleted, and unconfigured access ports will no longer have an automatic mapping to VLAN 1, but this won't cause the commit error you see above.

The most likely solution to your problem is to leave the default VLAN membership on your interface eg:

set interfaces xe-0/0/24 unit 0 family ethernet-switchig vlan members default
1

When you use Port in access-mode it is required to have VLAN because VLAN carrying tagged traffic and native vlan is required to carry untagged data. Therefore it is required.

1

set interfaces xe-0/0/24 unit 0 family ethernet-switching interface-mode access

Since you're setting the port to be an access port, the switch requires you to set the access VLAN of the port using the vlan members command as pointed out by Benjamin.

See below from the Juniper Wiki:

By default, the untagged packets are dropped. That is, if you do not configure the native-vlan-id option, the untagged packets are dropped. Further info on the native-vlan here.

It is possible that your port does not have the native VLAN set therefor the device is restricting you from commiting.

  • This is incorrect - for interfaces using family ethernet-switching, membership is configured using vlan members. The vlan-id command is used on Layer 3 interfaces, or Layer 2 interfaces using family bridge encapsulation. – Benjamin Dale Jun 19 at 19:16
  • @BenjaminDale, thank you for pointing that out. After re-reading the sources, you are correct. Answer has been updated to reflect. – ditrapanij Jun 19 at 21:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.