0

We have new branch and we will connect it through 4G routers "WAN connection" and L3 switches as below Fig.

enter image description here

From 1-Branch Switch i can ping the 2-Branch Switch, but from (PC-1) i cannot ping (2-Branch Switch) also (PC-2).

Maybe i have missed some something.

Here is the Routers and Switches conf.

*

*1-Router**

Gateway of last resort is 0.0.0.0 to network 0.0.0.0

S* 0.0.0.0/0 is directly connected, Tunnel1
10.0.0.0/8 is variably subnetted, 5 subnets, 3 masks
C 10.65.17.0/29 is directly connected, Vlan1
L 10.65.17.2/32 is directly connected, Vlan1
C 10.201.51.0/24 is directly connected, Cellular0
L 10.201.51.1/32 is directly connected, Cellular0
S 10.201.56.24/32 is directly connected, Cellular0
172.20.0.0/16 is variably subnetted, 2 subnets, 2 masks
C 172.20.218.196/30 is directly connected, Tunnel1
L 172.20.218.198/32 is directly connected, Tunnel1



**2-Router**

S* 0.0.0.0/0 is directly connected, Tunnel1
10.0.0.0/8 is variably subnetted, 5 subnets, 3 masks
C 10.66.17.0/29 is directly connected, Vlan1
L 10.66.17.2/32 is directly connected, Vlan1
C 10.201.51.0/24 is directly connected, Cellular0
L 10.201.51.2/32 is directly connected, Cellular0
S 10.201.56.24/32 is directly connected, Cellular0
172.20.0.0/16 is variably subnetted, 2 subnets, 2 masks
C 172.20.218.200/30 is directly connected, Tunnel1
L 172.20.218.202/32 is directly connected, Tunnel1



**1-Branch Switch**

ip routing



interface FastEthernet0/1
no switchport
ip address 10.65.17.1 255.255.255.248


interface FastEthernet0/3
switchport access vlan 10
switchport mode access


interface Vlan10
ip address 10.20.11.254 255.255.254.0


ip default-gateway 10.65.17.2
ip classless
ip route 0.0.0.0 0.0.0.0 FastEthernet0/1



**2-Branch Switch**

ip routing



interface FastEthernet0/1
switchport access vlan 11
switchport mode access


interface FastEthernet0/24
no switchport
ip address 10.66.17.1 255.255.255.248


interface Vlan11
ip address 10.30.11.1 255.255.255.0


ip default-gateway 10.66.17.2
ip classless
ip route 0.0.0.0 0.0.0.0 10.66.17.2

your help will be highly appreciated

Thanks

  • We really need the full router and switch configurations, too. Also, if you switches have routing enabled, then you do not use the ip default-gateway command. You use the static default route that you have configured. – Ron Maupin Jun 25 at 21:55
1

On each router, you need to point a route to the VLAN behind the L3 switch. Currently, everything non-local is pointed to the tunnel, creating a routing loop for the subnets not connected to one of the routers.

Either configure static routes or use a routing protocol between all routers and L3 switches.

Also, configuring each router as default gateway for the other very easily creates a routing loop. You should either use distinct routes or use only one router as default gateway for the other. Usually, that's the one in the main location.

  • is it possible to configure vlan between two sites without Overlay and underlay network such as mpls,vxlan or evpn over 4g connection? – infra Jun 26 at 3:08
  • Possible yes, reasonable no. VLAN tagging requires a layer-2 connection across the sites. 802.1Q can't work (without tunneling), so you'd need a suitable protocol like MPLS or VXLAN. However, running L2 connections across sites is generally discouraged for various reasons (efficiency, scalability, redundancy) and can be done without. You could e.g. split a cross-location zone into multiple location-specific subnets. With the addressing from the diagram there is no need for all that nor any benefit. – Zac67 Jun 26 at 7:27
  • Thanks for your response, highly appreciate – infra Jun 26 at 8:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.