0

So as stated in Title I'm observing that one of our switch randomly send RESET flag in TCP and ends the ssh connection in the middle and sends and Window size of 0 as well. Randomly it refuses to connect.

I have Captured few packets through which i come to know this scenario. What can be done?

enter image description here

enter image description here

5
  • Dou you have some kind of statefull firewall in between your PC and this switch? In case if you do, ssh session can timeout after approx 30 mins of inactivity. – Andrey Prokhorov Jan 3 '20 at 7:50
  • 1
    Is there a NAT router between the two machines? It may be closing the connection due to inactivity and timeouts? The SSH client can turn on SSH-level KeepAlive to try to avoid this scenario. For an SSH client, you can try to include the following on the client-side config file (either /etc/ssh/ssh_config or ~/.ssh/config): KeepAlive yes – Bobby Voychin Jan 31 '20 at 15:40
  • @AndreyProkhorov There was no stateful firewall in between. And No it randomly shuts the connection not after 30 minutes – Terminator Feb 9 '20 at 6:54
  • @BobbyVoychine There was no NAT router in between. And i was using SecurCRT on windows not linux machine. It was just randomly shutting down the connection – Terminator Feb 9 '20 at 6:55
  • Did any answer help you? If so, you should accept the answer so that the question doesn't keep popping up forever, looking for an answer. Alternatively, you can post and accept your own answer. – Ron Maupin Dec 21 '20 at 17:40
1

Check the switch syslog for any indication of out-of-memory.

The switch RE kernel should not send RST unless the sshd process to which you're connected has terminated unusually. Running out of RAM could cause this.

0

tcp session timeout to a value of 3,600 seconds or one hour strictly security policy favours the timely closing of idle management sessions,and the following code also affect the timeout of transit SSH sessions

1
  • No it was sending reset flag randomly there was no Inactivity – Terminator Feb 9 '20 at 6:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.