0

I am setting up attempting to simulate a small infrastructure of Clients and Servers. Current Setup

  • 1x. Dell Inspiron Tower Running ESXI 6.5
  • 1x. HP Z800 Workstation Running ESXI 6.5
  • 1x. Juniper EX2200-C Switch
  • 1x. Dell Computer used to manage ESXI hosts

I have 3 VLANS

  • 130: Users 10.7.50.1/24
  • 140: MGMT 10.7.49.1/24
  • 10: Servers 10.7.0.1/24

The ESXI hosts and my laptop are on The MGMT vlan I am trying to use the switch as a router, I have some virtual PC's and Server's but theres no connection to the gateway

Here is my config

set version 12.3R12.4
set system root-authentication encrypted-password "$1$MfqkKwNB$D8DQ7sT3KS3wOS.NMHj5q0"
set system services ssh protocol-version v2
set system services netconf ssh
set system services web-management http
set system services dhcp traceoptions file dhcp_logfile
set system services dhcp traceoptions level all
set system services dhcp traceoptions flag all
set system syslog user * any emergency
set system syslog file messages any notice
set system syslog file messages authorization info
set system syslog file interactive-commands interactive-commands any
set chassis auto-image-upgrade
set interfaces ge-0/0/0 unit 0 family ethernet-switching port-mode trunk
set interfaces ge-0/0/0 unit 0 family ethernet-switching vlan members all
set interfaces ge-0/0/1 unit 0 family ethernet-switching port-mode trunk
set interfaces ge-0/0/1 unit 0 family ethernet-switching vlan members all
set interfaces ge-0/0/2 unit 0 family ethernet-switching port-mode trunk
set interfaces ge-0/0/2 unit 0 family ethernet-switching vlan members all
set interfaces ge-0/0/3 unit 0 family ethernet-switching port-mode trunk
set interfaces ge-0/0/3 unit 0 family ethernet-switching vlan members all
set interfaces ge-0/0/4 unit 0 family ethernet-switching
set interfaces ge-0/0/5 unit 0 family ethernet-switching
set interfaces ge-0/0/6 unit 0 family ethernet-switching
set interfaces ge-0/0/7 unit 0 family ethernet-switching
set interfaces ge-0/0/8 unit 0 family ethernet-switching
set interfaces ge-0/0/9 unit 0 family ethernet-switching
set interfaces ge-0/0/10 unit 0 family ethernet-switching
set interfaces ge-0/0/11 unit 0 family ethernet-switching
set interfaces ge-0/1/0 unit 0 family ethernet-switching
set interfaces ge-0/1/1 unit 0 family ethernet-switching
set interfaces vlan unit 0 family inet  
set interfaces vlan unit 10 family inet address 10.7.0.1/24
set interfaces vlan unit 130 family inet address 10.7.50.1/24
set interfaces vlan unit 140 family inet address 10.7.49.1/24
set protocols igmp-snooping vlan all    
set protocols rstp                      
set protocols lldp interface all        
set protocols lldp-med interface all    
set ethernet-switching-options storm-control interface all
set vlans MGMT vlan-id 140              
set vlans MGMT l3-interface vlan.140    
set vlans Servers vlan-id 10            
set vlans Servers l3-interface vlan.10  
set vlans Users vlan-id 130             
set vlans Users l3-interface vlan.130   
set vlans default l3-interface vlan.0  
0

If you can't ping the gateway, the VLAN configurations don't match.

Trunk ports need to configured in exactly the same way on both sides - one or no VLAN untagged, all others tagged.

Access ports have a single untagged VLAN, no tagged ones.

The ESXi hosts can tag, given the port groups are configured appropriately (no VLAN ID=untagged, VLAN ID=tagged).

Apparently, the trunk ports are assigned to all VLANs. All other physical ports are still in the default VLAN.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.