1

Why my ae interface Link type is down but the physical interface is up?

In my convergence layer Switch, I use two Juniper EX4300 devices realize the Stack:

so there have xe-0/0/x and xe-1/0/x interfaces.

I created the ae65 interface, added the xe-0/0/65.0 and xe-1/0/65.0 two interface into the interface ae65.

enter image description here

enter image description here

enter image description here

You see the two physical port Link Type all are up, but the aggregation interface ae65 Link Type is down. Why?

the below is the configurations:

admin@C1-HXJH-A# show interfaces xe-0/0/65
ether-options {
    802.3ad ae65;
}

===

{master:1}[edit]
admin@C1-HXJH-A# show interfaces xe-1/0/65
ether-options {
    802.3ad ae65;
}

{master:1}[edit]

===

admin@C1-HXJH-A# show interfaces ae65
aggregated-ether-options {
    lacp {
        active;
    }
}
unit 0 {
    description "down-link to LA-C08-A";
    family inet {
        address 192.168.46.2/24;
    }
}

{master:1}[edit]

====

EDIT-01

admin@C1-HXJH-A> show lacp interfaces
Aggregated interface: ae21
    LACP state:       Role   Exp   Def  Dist  Col  Syn  Aggr  Timeout  Activity
      xe-0/0/36      Actor    No    No   Yes  Yes  Yes   Yes     Fast    Active
      xe-0/0/36    Partner    No    No   Yes  Yes  Yes   Yes     Fast    Active
      xe-0/0/38      Actor    No    No   Yes  Yes  Yes   Yes     Fast    Active
      xe-0/0/38    Partner    No    No   Yes  Yes  Yes   Yes     Fast    Active
      xe-0/0/39      Actor    No    No   Yes  Yes  Yes   Yes     Fast    Active
      xe-0/0/39    Partner    No    No   Yes  Yes  Yes   Yes     Fast    Active
      xe-0/0/37      Actor    No    No   Yes  Yes  Yes   Yes     Fast    Active
      xe-0/0/37    Partner    No    No   Yes  Yes  Yes   Yes     Fast    Active
    LACP protocol:        Receive State  Transmit State          Mux State
      xe-0/0/36                 Current   Fast periodic Collecting distributing
      xe-0/0/38                 Current   Fast periodic Collecting distributing
      xe-0/0/39                 Current   Fast periodic Collecting distributing
      xe-0/0/37                 Current   Fast periodic Collecting distributing

Aggregated interface: ae22
    LACP state:       Role   Exp   Def  Dist  Col  Syn  Aggr  Timeout  Activity
      xe-0/0/40      Actor    No    No   Yes  Yes  Yes   Yes     Fast    Active
      xe-0/0/40    Partner    No    No   Yes  Yes  Yes   Yes     Fast    Active
      xe-0/0/41      Actor    No    No   Yes  Yes  Yes   Yes     Fast    Active
      xe-0/0/41    Partner    No    No   Yes  Yes  Yes   Yes     Fast    Active
      xe-0/0/42      Actor    No    No   Yes  Yes  Yes   Yes     Fast    Active
      xe-0/0/42    Partner    No    No   Yes  Yes  Yes   Yes     Fast    Active
      xe-0/0/43      Actor    No    No   Yes  Yes  Yes   Yes     Fast    Active
      xe-0/0/43    Partner    No    No   Yes  Yes  Yes   Yes     Fast    Active
    LACP protocol:        Receive State  Transmit State          Mux State
      xe-0/0/40                 Current   Fast periodic Collecting distributing
      xe-0/0/41                 Current   Fast periodic Collecting distributing
      xe-0/0/42                 Current   Fast periodic Collecting distributing
      xe-0/0/43                 Current   Fast periodic Collecting distributing

Aggregated interface: ae23
    LACP state:       Role   Exp   Def  Dist  Col  Syn  Aggr  Timeout  Activity
      xe-0/0/44      Actor    No    No   Yes  Yes  Yes   Yes     Fast    Active
      xe-0/0/44    Partner    No    No   Yes  Yes  Yes   Yes     Fast    Active
      xe-0/0/45      Actor    No    No   Yes  Yes  Yes   Yes     Fast    Active
      xe-0/0/45    Partner    No    No   Yes  Yes  Yes   Yes     Fast    Active
      xe-0/0/46      Actor    No    No   Yes  Yes  Yes   Yes     Fast    Active
      xe-0/0/46    Partner    No    No   Yes  Yes  Yes   Yes     Fast    Active
      xe-0/0/47      Actor    No    No   Yes  Yes  Yes   Yes     Fast    Active
      xe-0/0/47    Partner    No    No   Yes  Yes  Yes   Yes     Fast    Active
    LACP protocol:        Receive State  Transmit State          Mux State
      xe-0/0/44                 Current   Fast periodic Collecting distributing
      xe-0/0/45                 Current   Fast periodic Collecting distributing
      xe-0/0/46                 Current   Fast periodic Collecting distributing
      xe-0/0/47                 Current   Fast periodic Collecting distributing

Aggregated interface: ae24
    LACP state:       Role   Exp   Def  Dist  Col  Syn  Aggr  Timeout  Activity
      xe-1/0/40      Actor    No    No   Yes  Yes  Yes   Yes     Fast    Active
      xe-1/0/40    Partner    No    No   Yes  Yes  Yes   Yes     Fast    Active
      xe-1/0/41      Actor    No    No   Yes  Yes  Yes   Yes     Fast    Active
      xe-1/0/41    Partner    No    No   Yes  Yes  Yes   Yes     Fast    Active
      xe-1/0/42      Actor    No    No   Yes  Yes  Yes   Yes     Fast    Active
      xe-1/0/42    Partner    No    No   Yes  Yes  Yes   Yes     Fast    Active
      xe-1/0/43      Actor    No    No   Yes  Yes  Yes   Yes     Fast    Active
      xe-1/0/43    Partner    No    No   Yes  Yes  Yes   Yes     Fast    Active
    LACP protocol:        Receive State  Transmit State          Mux State
      xe-1/0/40                 Current   Fast periodic Collecting distributing
      xe-1/0/41                 Current   Fast periodic Collecting distributing
      xe-1/0/42                 Current   Fast periodic Collecting distributing
      xe-1/0/43                 Current   Fast periodic Collecting distributing

Aggregated interface: ae25
    LACP state:       Role   Exp   Def  Dist  Col  Syn  Aggr  Timeout  Activity
      xe-1/0/44      Actor    No    No   Yes  Yes  Yes   Yes     Fast    Active
      xe-1/0/44    Partner    No    No   Yes  Yes  Yes   Yes     Fast    Active
      xe-1/0/45      Actor    No    No   Yes  Yes  Yes   Yes     Fast    Active
      xe-1/0/45    Partner    No    No   Yes  Yes  Yes   Yes     Fast    Active
      xe-1/0/46      Actor    No    No   Yes  Yes  Yes   Yes     Fast    Active
      xe-1/0/46    Partner    No    No   Yes  Yes  Yes   Yes     Fast    Active
      xe-1/0/47      Actor    No    No   Yes  Yes  Yes   Yes     Fast    Active
      xe-1/0/47    Partner    No    No   Yes  Yes  Yes   Yes     Fast    Active
      xe-0/0/24      Actor    No   Yes    No   No   No   Yes     Fast    Active
      xe-0/0/24    Partner    No   Yes    No   No   No   Yes     Fast   Passive
      xe-0/0/25      Actor    No   Yes    No   No   No   Yes     Fast    Active
      xe-0/0/25    Partner    No   Yes    No   No   No   Yes     Fast   Passive
    LACP protocol:        Receive State  Transmit State          Mux State
      xe-1/0/44                 Current   Fast periodic Collecting distributing
      xe-1/0/45                 Current   Fast periodic Collecting distributing
      xe-1/0/46                 Current   Fast periodic Collecting distributing
      xe-1/0/47                 Current   Fast periodic Collecting distributing
      xe-0/0/24           Port disabled     No periodic           Detached
      xe-0/0/25           Port disabled     No periodic           Detached

Aggregated interface: ae32

Aggregated interface: ae33

Aggregated interface: ae53

Aggregated interface: ae54

Aggregated interface: ae55

Aggregated interface: ae56

Aggregated interface: ae57

Aggregated interface: ae58

Aggregated interface: ae59

Aggregated interface: ae60

Aggregated interface: ae61

Aggregated interface: ae62

Aggregated interface: ae63

Aggregated interface: ae64

Aggregated interface: ae65
    LACP state:       Role   Exp   Def  Dist  Col  Syn  Aggr  Timeout  Activity
      xe-0/0/65      Actor    No   Yes    No   No   No   Yes     Fast    Active
      xe-0/0/65    Partner    No   Yes    No   No   No   Yes     Fast   Passive
      xe-1/0/65      Actor    No   Yes    No   No   No   Yes     Fast    Active
      xe-1/0/65    Partner    No   Yes    No   No   No   Yes     Fast   Passive
    LACP protocol:        Receive State  Transmit State          Mux State
      xe-0/0/65               Defaulted   Fast periodic           Detached
      xe-1/0/65               Defaulted   Fast periodic           Detached

Aggregated interface: ae66

Aggregated interface: ae48

Aggregated interface: ae49

Aggregated interface: ae50

Aggregated interface: ae51

Aggregated interface: ae52

Aggregated interface: ae69

Aggregated interface: ae70

{master:1}

===

EDIT-02

the other end is a Juniper EX3300 switch with two interface:

enter image description here

root@LA-C08-A# show interfaces xe-0/1/0
ether-options {
    802.3ad ae65;
}

{master:0}[edit]
root@LA-C08-A# show interfaces xe-0/1/1
ether-options {
    802.3ad ae65;
}

{master:0}[edit]
root@LA-C08-A# show interfaces ae65
description "uplink to LA-GWHJ";
unit 0 {
    family ethernet-switching {
        port-mode trunk;
        vlan {
            members all;
        }
    }
}

{master:0}[edit]

====

EDIT-03

Thanks for "Phil-Work", the ae65 Link Type become Up. I follow him add the lacp in the EX3300, it works.

in my Juniper EX4300, it has a management IP 10.10.10.254/24 :

admin@C1-HXJH-A# run show configuration | display set | match "irb unit 2 "
set interfaces irb unit 2 family inet address 10.10.10.254/24

{master:1}[edit]
admin@C1-HXJH-A# run show configuration | display set | match "10.10.10.254"
set interfaces irb unit 2 family inet address 10.10.10.254/24

{master:1}[edit]
admin@C1-HXJH-A# run show configuration | display set | match "vlan2 "
set vlans vlan2 vlan-id 2
set vlans vlan2 l3-interface irb.2

{master:1}[edit]

in the EX3300, I also have a management IP 10.10.10.8/24:

...
set interfaces xe-0/1/0 ether-options 802.3ad ae65
set interfaces xe-0/1/1 ether-options 802.3ad ae65
set interfaces ae1 description "uplink to LA-xxx-GWHJ"
set interfaces ae1 unit 0 family ethernet-switching
set interfaces ae65 description "uplink to LA-GWHJ"
set interfaces ae65 aggregated-ether-options lacp active
set interfaces ae65 unit 0 family ethernet-switching port-mode trunk
set interfaces ae65 unit 0 family ethernet-switching vlan members all
set interfaces vlan unit 2 family inet address 10.10.10.8/24
set routing-options static route 0.0.0.0/0 next-hop 10.10.10.254
set protocols igmp-snooping vlan all
set protocols rstp
set protocols lldp interface all
set protocols lldp-med interface all
set vlans vlan2 vlan-id 2
set vlans vlan2 l3-interface vlan.2
...

but they are not communicate to each other. can not ping each other. Why?

I tested change the ae65.0 IP from 192.168.65.2/24 to 10.10.10.65/24, but still not work. the 10.10.10.65 can not ping 10.10.10.8 each other.


EDIT-04

I check the MAC address in EX3300, there shows:

root@LA-C08-A# run show ethernet-switching table brief
Ethernet-switching table: 2 entries, 0 learned, 0 persistent entries
  VLAN              MAC address       Type         Age Interfaces
  vlan2             *                 Flood          - All-members
  vlan2             80:ac:ac:f0:b5:81 Static         - Router

in the EX4300, there is no vlan2 MAC from ae65.0.


EDIT-05

I use monitor traffic capture the packages in The EX4300 ae65 and EX3300 ae65 all logs:

...
17:18:44.762225  In STP 802.1w, Rapid STP, Flags [Learn, Forward], bridge-id 8000.80:ac:ac:f0:b5:81.8042, length 43
17:18:46.702003  In STP 802.1w, Rapid STP, Flags [Learn, Forward], bridge-id 8000.80:ac:ac:f0:b5:81.8042, length 43
17:18:48.519318  In STP 802.1w, Rapid STP, Flags [Learn, Forward], bridge-id 8000.80:ac:ac:f0:b5:81.8042, length 43
...

is this the issue reason?

1
  • Can you show the output of show arp no-resolve, as well as show vlans on both units? Jul 11 '19 at 0:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.