1

How can I set the "DHCP Addr. Assignment" checkbox on the WLAN Advanced tab on the Cisco 2504 WLC from the CLI?

I think I found something, but it gives me an error and does not set the checkbox:

(Cisco Controller) >config wlan dhcp_server 1 0.0.0.0 required 1

Note: DHCP server override is applicable only to the default AP group.

(Cisco Controller) >

To be clear, I don't care about a DHCP server override (that's the checkbox up to the top of "DHCP Addr. Assignment") - see screenshot below.

WLAN-Advanced

  • Did any answer help you? If so, you should accept the answer so that the question doesn't keep popping up forever, looking for an answer. Alternatively, you can provide and accept your own answer. – Ron Maupin Dec 15 '19 at 5:21
1

The error is a standard "warning" message you get when making this configuration. I don't believe this has any relation to your problem.

Instead, you said you entered this:

config wlan dhcp_server 1 0.0.0.0 required 1

This is not correct syntax for the CLI command. This is the correct syntax:

config wlan dhcp_server <WLAN_ID> 0.0.0.0 required

So if your WLAN ID is 1 it would be as follows:

config wlan dhcp_server 1 0.0.0.0 required.

This will still output the same warning message, but should apply in the configuration. If it doesn't, then you may have an issue with the particular version of code you are running.

I know you mention you did not want to set the DHCP override, but for completeness let me add to this answer that if you did, then simply setting the IP address to a valid IP other than 0.0.0.0 should do so (and setting it back to 0.0.0.0 should disable the override).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.