0

I have configured separate vlan for voip and connected interface to it (as shown below). But the phone is not getting ip address automatically. switch- cisco 2960-x phone- yealink

I had tried: (on phone) 1) changing cables 2) factory reset 3) static ip address setup

On switch, I had provided IP and no shut. It is getting IP of access vlan 10 instead of vlan 30.

enter image description here

enter image description here

enter image description here

  • 1
    Unless the phone can use CDP or LLDP to negotiate a trunk with the switch, and it is properly configured on both the switch and phone, you will need to configure the VoIP VLAN as the access VLAN for the switch interface where the phone is connected. Many off-brand IP phones do not use either CDP or LLDP, so they cannot negotiate a trunk with the switch. – Ron Maupin Jul 16 '19 at 10:38
  • The LLDP is enabled in phone. Is there any configuration in switch required? I had configured access and VoIP vlan as vlan 30. Yet, no ip allocated. – nirali Jul 18 '19 at 0:29
  • You need to configure LLDP, globally and on the switch interface where the phone is connected. Unlike CDP, which is enabled by default, LLDP is not. – Ron Maupin Jul 18 '19 at 0:34
2

How should the switch know that the device you connect to a switch is a phone? Cisco and other phones speak CDP / LLDP (Cisco Discovery / Link Layer Discovery Protocol) which tells the switch "this is a phone connected to me, I must put it in the Voice VLAN".

| improve this answer | |
0

With the above issue, I have found that in Yeahlink phone you must configure the port with appropriate Vlan access and Vlan voice.

In my case, I had an issue because I configured both Yealink phone ports with VLAN access. Make sure you configure the port (which connects the computer to the IP phone) as Access Vlan and the other port (connecting IP phone with Wall/switch port) with Vlan Voice. For changing the VLANs you can go to the Advance setting>> IPv4/IPv6 (whichever addressing you are using in your network)

Also, LLDP and DHCP have to be enabled in the phone. (DHCP only if you are using dynamic addressing)

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.