5

What does this error and how can I fix?enter image description here

3
  • The simple/quick solution: no lldp run (turn off lldp) Might not fix the problem, but it will make that message go away. :-)
    – Ricky
    Jan 28 '14 at 9:20
  • I changed the transcerver, and the message stopped appearing for now, I'll see how it behaves in the next days. Jan 28 '14 at 12:47
  • If you're sure that changing the transceiver actually stopped the messages, please post an answer and accept it after confirming this fact.
    – This
    Jan 28 '14 at 13:51
5

This isn't necessarily a misconfiguration, but likely is.

LLDP carries primary vlan id in one of its attributes to help switches identify mismatches like this.

We have a number of cases were VLAN ids are only locally significant in our equipment and on completely untagged ports, with lldp enabled, the procurves will log these messages periodically because the ports have different VLAN ids on the two switches. It doesn't matter, though because the vlan id numbers are only locally significant on each switch. I wish I could turn off this message in these situations, but alas, I'm stuck with the noise.

In the typical case, where VLAN ids are more than just locally significant, this likely does represent a misconfiguration where traffic could jump from one VLAN to another if the primary VLAN on a port is sent untagged (while other VLANs are tagged).

2
  • I would suspect there's more at fault here as one of the switches is claiming it's PVID is zero, which is invalid. Also that it thinks every port on SW1 is connected to port 24 on SW2.
    – Ricky
    Jan 28 '14 at 19:21
  • Thank you @Jeff McAdams The problem was this. there was an untagged vlan to door, in the other was not as untagged. Jan 29 '14 at 9:41
2

I observed this behaviour when I connected an (A-Series) HP 5800 to a procurve 5400 with a tagged interface carrying 3 VLANs. Is this a tagged Port? One way to solve it is to transmit one of the VLANs without Tag. PVID on both sides needs to be the same in this case. If it is untagged, PVID must match anyways.

If you do not want to transmit any untagged VLAN (as I did) you can turn out the log message on the procurve with the command: setmib 1.3.6.1.2.1.16.9.1.1.3.828 –i 1

1
  • I changed the transcerver, and the message stopped appearing for now, I'll see how it behaves in the next days. Jan 28 '14 at 12:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.