0

I have a Meraki MX84 in Routed mode with a Default 10.10.0.0/24 subnet and then VLAN 10.10.3.0/24 ID 3, VLAN 10.10.4.0/24 ID 4, VLAN 10.10.5.0/24 ID 5, and 10.10.8.0/24 with ID 8. All ports on it are set to Native VLAN 1 and Trunk I have a Cisco SG200. I've added the VLANs 3-5 and 8. All ports are set to Trunk.

The MX is in port 1 of the SG200 and I set the Administrative VLANs to 1 and 5. I have PCs on 10.10.0.0 and 10.10.8.0 and then a server uses the other subnets and need them to connect with each other. There is no reason to keep the subnets separated.

As it is right now they can not talk to each other. Is there a step I'm missing? Should all ports on the SG200 be added to all VLANs? *Port 5 on the MX is set to VLAN 8 just for testing.
MX VLANs SG200 VLANs

0

Trunks are not appropriate for your access interfaces where you connect PCs, printers, etc. Most end-devices do not understand VLAN tags, so they will drop traffic from trunk interfaces.

What you want to do is configure a trunk between the router and switch, and between the switch and any other switches. For all the other interfaces, you configure access interfaces. Each access interface is configured for the particular VLAN to which the end-device connects.

  • so they will drop traffic from trunk interfaces - that applies to traffic with VLAN tags from trunk switchports. Traffic in the trunk's given native VLAN is untagged and accepted by the end device. One case to think of: servers in the PXE-boot phase (before they can bring up the 802.1q capable drivers in their networking stacks). – Marc 'netztier' Luethi Jul 24 at 5:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.