I am currently in the situation of needing to monitor several ports on a Aruba 2530-24G simultaneously from several other ports. Those are basically HP devices, right?

A good solution would be a mirroring-group like suggested by HP here. Only is this docu for a HP 5830 device and my switch tells me it does not know the mirroring-group command as well as the reflector-port command. Is there any information out there on when HP implemented this functionality into their firmware (knowing 2530 is a somewhat elderly device) and if there are differences in the firmwares between HP and Aruba stopping me from using HP functionality?

Also, does anybody have any other solution to my problem? Goals exactly:

  • 3 ports to be monitored (both directions). Cannot be wrapped into the same vlan.
  • 3 analyzers to be served with the monitored traffic. May be wrapped into a new vlan as demonstrated by HP (see up).

1 Answer 1


The Aruba 2530 are rebranded HPE (Provision), yes.

I'm using the "ArubaOS-Switch Management and Configuration Guide for YA/YB.16.04" pp. 272 which should be fairly easy to find at HPE.

You can configure up to four mirror "sessions". Basically, you assign an egress interfaces to a session

mirror 1 - 4 port exit-port-# [name name-str]

and then assign each source interface to one or more sessions

[no] interface port/trunk/mesh monitor [in | out | both] [mirror 1 - 4 | name-str]
[{1 - 4 | name-str} | {1 - 4 | name-str} | {1 - 4 | name-str}] [no-tag-added]


Apparently, there's a misprint in the manual and the 2530 series only supports a single egress port for mirroring.

I've located the current 16.09 manual here where the multi-session option seems to be removed.

  • Thank you for the Aruba guide. Tried that solution though. mirror 2 port 13 name somename leaves me with Invalid input: port. Then mirror ? gives me [ethernet] PORT-NUM Define the mirror port for diagnostic purposes. suggesting there is no session to be configured but one which is already used, hence my trouble. Checked firmware version, fits your guide. Jul 31, 2019 at 9:52
  • Hmm - always wanted to try that but didn't. I've just checked with a 2530-24G PoE+ & YA.16.09.0001 firmware: Apparently, the manual is wrong and the 2530 only supports a single mirror port...
    – Zac67
    Jul 31, 2019 at 10:13
  • Firmware YA.16.04 lacks the functionality, YA.16.08 has it implemented. Solved, thanks! Aug 1, 2019 at 10:43
  • 1
    Well, that's pretty much the opposite from the manual revs. With YA.16.09 it doesn't work either, so beware when upgrading...
    – Zac67
    Aug 1, 2019 at 12:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.