4

I am unable to ping from R1 to R2. debug ip packet detail returns IP: s=172.16.12.1 (local), d=172.16.12.2 (FastEthernet0/0.12), len 100, encapsulation failed. I understand this means it can't resolve an arp address. I am looking for some guidance on what could be causing this.

I am using GNS3 to test some configurations. I have three 3725 routers. One acting as a switch (R1, R2, SW1). ip cef is enabled on all three devices.

R1 and R2 connect to SW1, from their f0/0 to f1/1 & F1/2 respectively. R1 & R2 have subinterfaces enabled on f0/0.12 VLAN 12. SW1 f1/1 & f1/2 are both assigned to vlan 12.

Is there a feature on SW1 I need to disable/enable? What am I missing?

R1 config

interface FastEthernet0/0.12  
 encapsulation dot1Q 12  
 ip address 172.16.12.1 255.255.255.0  

R2 config

interface FastEthernet0/0.12  
 encapsulation dot1Q 12  
 ip address 172.16.12.2 255.255.255.0  

SW1 config

interface FastEthernet1/1  
 switchport access vlan 12  
 switchport mode trunk  
 duplex full  
 speed 100  
!  
interface FastEthernet1/2  
 switchport access vlan 12  
 switchport mode trunk  
 duplex full  
 speed 100  
  • 1
    Did you create vlan 12 on Sw1? – Ron Trunk Jan 29 '14 at 23:33
  • @Ron Agh (facepalm). I copy/pasted a sequence of commands with the vlan assignments. Never really looked at whether they took or not. The 3725 uses the old vlan database syntax, so the vlans were never created. I just never checked that. My mistake. If you make an answer out of this I'll mark it. Thank you. – KyraH Jan 30 '14 at 3:09
4

Before you can forward traffic on a VLAN, you have to create it in the switch's VLAN database. For older switches, there is a separate configuration mode for VLANs. From privileged (enable) mode type:

switch# vlan database
switch(vlan)# vlan 12
switch(vlan)# exit
switch#

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.