0

I know we cannot create OSPF with different subnets. What network addresses should I put in the MLS and R1 to make it adjacent?

Here's the configuration for MLS:

interface FastEthernet0/15
 no switchport
 ip address 10.1.100.1 255.255.255.252
 duplex auto
 speed auto 
!
router ospf 1
 log-adjacency-changes
 network 10.1.100.1 0.0.0.0 area 0 !

End of configurations for MLS

R1

interface FastEthernet0/0
 ip address 10.1.100.2 255.255.255.0
! 
interface FastEthernet0/1
 ip address 10.1.1.1 255.255.255.0
!
interface Vlan1
 no ip address
 shutdown
!
router ospf 1
 log-adjacency-changes
 network 10.1.100.2 0.0.0.0 area 0

OSPF network

  • You should use the two available addresses on the link between them. I really do not understand the problem. If you really want help, you should include the device configurations. – Ron Maupin Aug 13 at 0:28
  • 1
    First of all, please check reachability. The R1 interface FastEthernet0/0 mask is 24 bits. ip address 10.1.100.2 255.255.255.0 If 30 bits are a correct IP address, set as follows. 10.1.100.2 255.255.255.252 – Roger Sanghee Gold Aug 13 at 4:19
  • As was pointed out in the previous comment, your masks do not match, and the router mask does not agree with the diagram. Also, You really need to include the full configurations because you leave us guessing if you enabled routing in the layer-3 switch. – Ron Maupin Aug 13 at 4:33
  • 1
    Mask on interfaces should be equal /30 or /24 on both sides. And I would set proper wildcards for network statement in OSPF router configuration: 0.0.0.255 for /24 or 0.0.0.3 for /30. – Andrey Prokhorov Aug 13 at 7:04
2

Interfaces Fa0/15 on MLS and Fa 0/0 on R1 do not have the same subnet mask. In order for routers to become adjacent neighbors, they must have the same subnet mask.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.